Post new topic   Reply to topic
Author Message
Registered Member
Registered Member
Joined: Jan 06, 2004
Posts: 23817

If you have ever been using MyEclipse and opened up a tool like MyUML, the Image Editor or Matisse4MyEclipse and seen a corrupted screen like the following:

The problem is most likely that you need to upgrade your graphics display drivers to their latest versions. Please check your respective display provide for updated drivers (e.g. nVidia, ATI, Intel, etc).

If upgrading your drivers didn't fix the problem, then what you need to do is tell the JRE or JDK running MyEclipse to not accelerate Swing operations by using the following flag in your startup arguments:


So for example, my startup arguments used to run MyEclipse look like this:

-vm C:\Java\jdk1.5.0_08\bin\javaw.exe -vmargs -Xms128M -Xmx512M -XX:PermSize=64M -XX:MaxPermSize=128M -Dsun.java2d.d3d=false

This is just an example, if you want to add these to your arguments, please adjust the your arguments acccording (you can usually just add the new -D argument at the end of your argument list then relaunch MyEclipse).

Optionally, if the flag above didn't do the trick, one of our users ernestz found another flag that you can use to disable Swing acceleration and likely correct rendering issues:

 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
All times are GMT - 6 Hours
Post new topic   Reply to topic
® 2014 - Genuitec, LLC.