Post new topic   Reply to topic
Author Message
support-scott
Moderator
Moderator


Joined: May 06, 2003
Posts: 6761

Version 5.1.0 GA of MyEclipse Enterprise Workbench for Windows, Linux, and Macintosh for Eclipse 3.2.1 is now available in the Downloads section.

To make installation and trial of this new release easier, a new "All-In-One" installer is now available in the downloads area (Windows only). This particular download has no prerequistes and is the fastest way to get started with MyEclipse. If you take this path, you can stop reading now.

This release is a fully compatible with Eclipse 3.2.1 and the latest Callisto update. If you're interested in installing additional tools from other sites, our recommended installation order is: Eclipse 3.2.1 SDK, then MyEclipse 5.0GA, Matisse4MyEclipse (if desired), and finally any other tools any Discovery Site that you want to try.

More information can be found in the official announcement on the News page and the New & Noteworthy section shows you what's been added since MyEclipse 5.0M2.

To try this release, you may install prior releases and MyEclipse 5.1.0GA on the same machine without conflict, provided that separate Eclipse installations are used (3.1.2 for MyEclipse 4.1.1 and 3.2 for MyEclipse 5.0GA, 3.2 or 3.2.1 for MyEclipse 5.1.0GA). To make trial of this new release easier, a new "All-In-One" installer is now available in the downloads area.


Upgrading from prior versions
From MyEclipse 5.0M1, 5.0M2, 5.0GA, 5.0.1GA
If you already have MyEclipse 5.01 installed, you can update it through our update site by selecting 'Help > Software Updates > Find and Install... > Search for updates of currently installed features' and following the prompts. If no updates are found, please navigate to Window > Preferences > Install/Update > Valid Updates and turn on 'compatible', not 'equivalent'. That will allow the 5.1.0GA update to be selected properly.

When asked, restart the workbench to complete the update. If you experience any obvious problems after the update, the issue is likely that the Eclipse plugin cache has become stale or did not cleanly rebuild after the update. To rectify the problem you'll need to restart Eclipse with the -clean flag one time:
eclipse.exe -clean
That should resolve any issues.

From any release prior to MyEclipse 5.0M1
Since this release provides support for a completely new Eclipse SDK platform (3.2.x) there is no upgrade path from MyEclipse 4.x versions due to platform API changes. A full installation must be performed for this release, however follow-on releases of MyEclipse 5.x will be available using the Eclipse update manager.


Installing MyEclipse 5.1.0 GA
If you haven't installed WTP 1.5 from Callisto or don't know what Callisto is...
The only prerequisites required before installing MyEclipse 5.0GA are the presence of a Java JDK (available from Sun) and an existing Eclipse 3.2.1 SDK installation (available from Eclipse). Note: You do not need to install any components from the Callisto simultaneous release since all required platform dependencies (WTP 1.5.2 etc) are already included in the MyEclipse distribution. If you already have installed WTP 1.5.x, please see the next section.

Once the prerequisites are installed, you can download one of the platform-specific installers from the 'MyEclipse 5.1.0 for Eclipse 3.2.x Releases' section of the MyEclipse Downloads page.

If you have installed WTP 1.5.x from the Callisto distribution...
This release is a fully compatible with Eclipse 3.2.1 and the latest Callisto update. If you're interested in installing additional tools from other sites, our recommended installation order is: Eclipse 3.2.1 SDK, then MyEclipse 5.1.0GA, Matisse4MyEclipse (if desired), and finally any other tools from the other discovery sites that you want to try.

However, if you've already installed Eclipse 3.2.x and WTP 1.5.2, you can still install MyEclipse using that distribution, but some manual configuration will be necessary and you'll be using substantially more disk space since you'll have two copies of several of the Callisto projects installed. If you'd rather not do any manual configuration or would like to reduce the disk footprint, then reinstalling in the order listed at the top of this section will be necessary. If you choose to reinstall, then you don't need to read any further in this section.

After installing MyEclipse using the steps contained in the prior section, launch Eclipse and navigate to Window > Preferences > General > Capabilities and press the 'Advanced' button. On the next dialog, expand the 'Development' section and turn off all the items *except* 'Java Development' (and 'Plug-in Development' if you're also an Eclipse plugin developer). While this seems unusual, the other categories are provided by the initial Callisto version of WTP and MyEclipse remaps and enhances these features while moving them to more standard locations in the user interface. If you do not disable these capabilities manually, the side-effect is that you'll have two copies of many of the features at different places in the UI. Naturally, this redundancy will create confusion while you use the tools. Please do not attempt to turn on all the capabilities in the 'MyEclipse Standard Tools' category or this configuration will be undone and will not work properly. Once you've turned off the capabilities as instructed, MyEclipse will be ready to use.


Installing Matisse4MyEclipse 5.1.0GA
Matisse4MyEclipse is not shipped as part of the 5.1.0GA distribution. However, once 5.1.0GA is installed you can install Matisse4MyEclipse from the MyEclipse update site by selecting Help > Software Updates > Find and Install... > Search for new features to install... Select the 'MyEclipse Discovery Site' and then 'Finish'. Matisse4MyEclipse will display as an available feature from the MyEclipse Discovery Site. Please select it and follow the remaining prompts to complete the installation.

To find out the differences between the Standard and Professional versions, please see this link:
http://www.myeclipseide.com/images/credit_card/me_pro_info.html

Prerequisites
If you're using the new "All-In-One" installer for Windows: There are no prerequistes

If you're not:
You'll need a fresh Eclipse 3.2.1 SDK installation and JDK 1.4.2_05+ or JDK 1.5 on Windows or Mac, and *only* JDK 1.5 on Linux.

_________________
--Scott
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
All times are GMT - 6 Hours
Post new topic   Reply to topic
® 2014 - Genuitec, LLC.