This thread has been locked & this forum has been archived.
Please post new topics to Java EE Development (EJB, JSP, Struts, XDoclet, etc.)
Author Message
curtking
Registered Member
Registered Member


Joined: Mar 29, 2006
Posts: 72

I'm trying to run the REST Demo project in the REST tutorial and I'm getting an exception:

Code:

Jan 29, 2009 12:34:15 PM org.apache.catalina.core.AprLifecycleListener init
INFO: The Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Program Files\Java\JRE_1.5.0_17\bin;C:\Program Files\Genuitec\Common\plugins\com.genuitec.eclipse.easie.tomcat.myeclipse_7.0.0.zmyeclipse70020081206\tomcat\bin
Jan 29, 2009 12:34:15 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-80
Jan 29, 2009 12:34:15 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 428 ms
Jan 29, 2009 12:34:15 PM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Jan 29, 2009 12:34:15 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.13
Jan 29, 2009 12:34:15 PM org.apache.catalina.core.ApplicationContext log
INFO: Marking servlet JAX-RS REST Servlet as unavailable
Jan 29, 2009 12:34:15 PM org.apache.catalina.core.ApplicationContext log
SEVERE: Error loading WebappClassLoader
  delegate: false
  repositories:
    /WEB-INF/classes/
----------> Parent Classloader:
org.apache.catalina.loader.StandardClassLoader@56f631
 com.sun.jersey.spi.container.servlet.ServletContainer
java.lang.ClassNotFoundException: com.sun.jersey.spi.container.servlet.ServletContainer


Any ideas on what I might do to fix this?

Thanks,
Curt
 
 View user's profile Send private message  
Reply with quote Back to top
support-nipun
Registered Member
Registered Member


Joined: Apr 18, 2007
Posts: 8010

Have you tried running the demo against MyEclipse Tomcat. Do you get the same error ?

_________________
Nipun
MyEclipse Support
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
curtking
Registered Member
Registered Member


Joined: Mar 29, 2006
Posts: 72

Hi, Nipun! I've been doing some research and tracked down the problem: I'm running Groovy on this web server and the asm-2.2.jar file that Groovy requires is causing a classloader issue.

I'll track this down with the Groovy folks to see if I can find a resolution there.

Thanks,
Curt
 
 View user's profile Send private message  
Reply with quote Back to top
support-nipun
Registered Member
Registered Member


Joined: Apr 18, 2007
Posts: 8010

Your welcome.

_________________
Nipun
MyEclipse Support
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
hoteagle
Registered Member
Registered Member


Joined: Feb 17, 2011
Posts: 11

Is there some update. I faced with the same problem with the latest version of MyEclipse for Spring 9.0/8.9 on MAC OS 10.6.
 
 View user's profile Send private message  
Reply with quote Back to top
support-tony



Joined: Mar 09, 2011
Posts: 988

hoteagle,

Could you confirm that you're getting the exact same problem as in the first post of this thread? If so are you using groovy, as the first poster was? There is a problem with the REST Web Services Explorer in some Linux based environments but the service itself should run OK.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
AnkurGoyal



Joined: Aug 31, 2011
Posts: 1

Hi,

I tried the same demo & getting the same error.
I have all Jersey jar files in the web-inf/lib folder as well as in the build path of the application.


Code:
INFO: Marking servlet JAXRS Service as unavailable
Aug 31, 2011 3:41:26 PM org.apache.catalina.core.ApplicationContext log
SEVERE: Error loading WebappClassLoader
  context: /restdemo
  delegate: false
  repositories:
    /WEB-INF/classes/
----------> Parent Classloader:
org.apache.catalina.loader.StandardClassLoader@482923
 com.sun.jersey.spi.container.servlet.servletcontainer

I also have jersey-server-1.8.jar in my classpath & under web-inf/lib.

Also, I tried some other projects on Eclipse & they are doing fine with same configuration.
Any help would be appreciated.
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna



Joined: Nov 11, 2010
Posts: 2704

AnkurGoyal ,

Sorry that you are seeing this issue with MyEclipse.

1) Can you share your Build Id from Help > About MyEclipse Enterprise Workbench > Build ID ?

2) Can you also give us your OS and version details ?

3) Are you using Groovy like the first user who posted this issue ?

4) Clear the contents of the .log file which is located at <workspace dir>/.metadata/.log , replicate the issue and copy paste the entire contents of the .log file here for us to investigate it further.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
All times are GMT - 6 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
® 2014 - Genuitec, LLC.