MyEclipse Forums
This thread has been locked & this forum has been archived.
Please post new topics to Java EE Development (EJB, JSP, Struts, XDoclet, etc.)
View previous topic Printable version Log in to check your private messages View next topic
Author Message
edross
Post subject: Reports designed in report designer had issues in runtime  PostPosted: Feb 13, 2009 - 01:32 PM
Registered Member
Registered Member


Joined: Oct 24, 2004
Posts: 77

I design reports in the MyEclipse report designer, then take the rtpdesign file and use is as part of my ant task.

Started getting this issues when using reports designed with the MyEclipse designer.

Any ideas how to resolve this?

thx
Code:

  [CCIAnt] Feb 13, 2009 8:25:42 AM org.eclipse.birt.report.model.metadata.ExtensionLoader handleError
   [CCIAnt] SEVERE: Message:The class [org.eclipse.birt.report.engine.api.script.EngineScriptableClassInfo] can not be instantiated. Error code:FAILED_TO_CREATE_INSTANCE
   [CCIAnt] Feb 13, 2009 8:25:46 AM org.eclipse.birt.data.engine.odaconsumer.Driver doGetDriverManifest
   [CCIAnt] SEVERE: Cannot process data source extension configuration.
   [CCIAnt] java.lang.IllegalArgumentException: com.genuitec.eclipse.reporting.oda
   [CCIAnt]    at org.eclipse.datatools.connectivity.oda.util.manifest.ManifestExplorer.getExtensionManifest(ManifestExplorer.java:200)
   [CCIAnt]    at org.eclipse.birt.data.engine.odaconsumer.Driver.doGetDriverManifest(Driver.java:147)
   [CCIAnt]    at org.eclipse.birt.data.engine.odaconsumer.Driver.findDataSourceExtensionConfig(Driver.java:123)
   [CCIAnt]    at org.eclipse.birt.data.engine.odaconsumer.Driver.getDriverExtensionConfig(Driver.java:78)
   [CCIAnt]    at org.eclipse.birt.data.engine.odaconsumer.Driver.getExtensionConfig(Driver.java:60)
   [CCIAnt]    at org.eclipse.birt.data.engine.odaconsumer.Driver.getDriverHelper(Driver.java:93)
   [CCIAnt]    at org.eclipse.birt.data.engine.odaconsumer.DriverManager.getDriverHelper(DriverManager.java:97)
 
 
 View user's profile Send private message  
Reply with quote Back to top
support-nipun
Post subject: RE: Reports designed in report designer had issues in runtim  PostPosted: Feb 13, 2009 - 03:02 PM
Registered Member
Registered Member


Joined: Apr 18, 2007
Posts: 8010

edross,
Can you please give me a more detailed explanation of what exactly you did when you ran into this issue.

_________________
Nipun
MyEclipse Support
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
edross
Post subject: RE: Reports designed in report designer had issues in runtim  PostPosted: Feb 14, 2009 - 02:52 PM
Registered Member
Registered Member


Joined: Oct 24, 2004
Posts: 77

I design the reports using MyEclipse report designer. I then take the rpt design and move it into a reports directory.
I have created an ant task that sets up the report engine (Using the Runtime from the eclipse page) and wish to generate pdf reports.

This worked ok in MyEclipse 6.x, but I get the above error in MyEclipse 7.
If I use the "all in one package" from the Eclipse download to design the report I don't seem to encounter this problem. I prefer to use the MyEclipse version to keep all of my datasources and definitions in one place.
 
 View user's profile Send private message  
Reply with quote Back to top
support-rkalla
Post subject: RE: Reports designed in report designer had issues in runtim  PostPosted: Feb 16, 2009 - 06:46 PM
Registered Member
Registered Member


Joined: Jan 06, 2004
Posts: 23818

Ed,

MyEclipse Reports was upgraded in the MyEclipse 7.0 release to the latest BIRT platform, it's possible the APIs have changed for that class (possibly deprecated?) It's hard to tell, not really a usage scenario I've tried before.

_________________
Riyad
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
rmcvay
Post subject: RE: Reports designed in report designer had issues in runtim  PostPosted: Feb 16, 2009 - 10:15 PM
Registered Member
Registered Member


Joined: Sep 17, 2004
Posts: 217

BIRT does not suffer gladly report designs from an earlier version.

_________________
Ray
Just another MyEclipse user
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
edross
Post subject: RE: Reports designed in report designer had issues in runtim  PostPosted: Feb 20, 2009 - 03:01 PM
Registered Member
Registered Member


Joined: Oct 24, 2004
Posts: 77

The problem is that your reports have
com.genuitec.eclipse.reporting.oda

Normal birt reports use a more generic datasource/driver

I think If you could just tell me which jar(s)& data resource files to copy to the reportEngineHome from eclipse this might work.
 
 View user's profile Send private message  
Reply with quote Back to top
Maturin
Post subject:   PostPosted: Aug 31, 2011 - 10:58 AM
Registered Member
Registered Member


Joined: Apr 09, 2008
Posts: 9

Hi Edross,

Sorry posting on this old post but I also want to schedule MyEclipse Birt reports tu run and I am having the same error...

I am not sure this is fixable easilty as MyEclipse reports are not standard BIRT reports!
I was wondering did you ever get it to work?

Cheers
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits