MyEclipse Forums
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
raj.vacrro@gmail.com
Post subject: Myeclipse 10-Maven project deployment not working  PostPosted: Apr 16, 2012 - 09:18 AM
Registered Member
Registered Member


Joined: Apr 16, 2012
Posts: 5

Hi there,

Hope you doing great and had a good weekend!

My name is Raj and I work for a German automobile company. I am trying to evaluate Maven capability for Myeclipse 10 so that we could take advantage of Myeclipse features and move our development to Myeclipse. We are currently using Eclipse for the development.

Well I did import all modules of my project using Maven4MyEclipse-->Existing Maven Project.
I have checked out source code on my local disk using TortoiseSVN and want to configure this code with MyEclipse. This is a multimodule maven project.

I would appreciate if you could help me with the way the configuration should be made. Do I need to use commands like setting the workspace using maven command on cmd after importing the project?
Something like setting the workspace:-
mvn eclipse:configure-workspace -Declipse.workspace="C:\Raj\xxxWorkspace"
and then mvn eclipse:eclipse?

Any tutorial on this would be great because if I am successfully able to do it, we will order a good number of license for MyEclipse.

Waiting for your response,
Raj
 
 View user's profile Send private message  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Apr 16, 2012 - 11:24 AM



Joined: Mar 09, 2011
Posts: 958

Raj,

Thank you for considering MyEclipse.

If you have been using m2eclipse with your eclipse IDE to develop your maven project then you should import the eclipse project as an eclipse project, rather than as a maven project. That is, you should use Import->General->Existing Projects into Workspace. Otherwise, for stand-alone maven projects, use the Import mechanism that you mentioned. No further configuration is needed, in either case.

If you want to check out maven projects (that is, projects that are stand-alone maven projects) that have been stored in Subversion, you will need to install a Subversion plugin (either Subversive or Subclipse) and a maven SCM connector, as mentioned in this FAQ. Again, no further configuration of the project is necessary after checking it out with Import->Maven4MyEclipse->Check out Maven Projects from SCM.

I'm afraid we don't have a tutorial on this but please let us know if you have further questions.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
raj.vacrro@gmail.com
Post subject:   PostPosted: Apr 16, 2012 - 11:45 AM
Registered Member
Registered Member


Joined: Apr 16, 2012
Posts: 5

Thanks for your mail Tony,

Well right now Eclipse with Maven is working fine without any issue but the problem is to set it up with MyEclipse. I am sorry if I was not clear enough.

I want to take advantage of MyEclipse hot deployment specially and that's one of the main reason I would like to move to MyEclipse.

Now as you said when I click on (using myeclipse 10 for Spring) Import->General->Existing Projects into Workspace and when I select the root folder of my multimodule maven project it says "No Project are found to import".

Not sure how should I proceed. could you please help me here?

Appreciate your time and help Tony!
Thanks,
Raj
 
 View user's profile Send private message  
Reply with quote Back to top
raj.vacrro@gmail.com
Post subject:   PostPosted: Apr 16, 2012 - 12:25 PM
Registered Member
Registered Member


Joined: Apr 16, 2012
Posts: 5

Update:-

I was able to import project from Import->General->Existing Projects into Workspace only after firing this command from command prompt:- mvn eclipse:eclipse.

Now after doing that when I deploy and start the server I get this error:-
Caused by: java.lang.NoSuchMethodError: org.slf4j.helpers.MessageFormatter.format(Ljava/lang/String;Ljava/lang/Object;)Lorg/slf4j/helpers/FormattingTuple;

I think is because of library mismatch which I could see from Java Build Path>Order and Export- there are two library for slf4j and slf4j-api(v1.5.11) and slf4j-log4j12(v1.6.1). Is it so?

I also get error on Java Build Path>Order and Export header:-
Cannot nest output folder 'qs-loop/target/qs-loop/WEB-INF/classes/lang' inside output folder 'qs-loop/target/qs-loop/WEB-INF/classes'

Also please correct the steps I am taking to deploy and run this app:-

1. Import the existing Maven project as Import->General->Existing Projects into Workspace.
2. From your root directory run this command to make it eclipse project "mvn eclipse:eclipse"
3. refresh/Clean your project.
4. clean and install it by right click on the main pom.xml and clicking on run as>maven build>"clean install -DskipTests=true"
5. Deploy using "manage deployment" and selecting "Exploded Archive" mode
6. Start Server in debug mode


please tell me whats wrong I am doing?

Thanks a lot for your help!
Raj
 
 View user's profile Send private message  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Apr 16, 2012 - 12:31 PM



Joined: Mar 09, 2011
Posts: 958

Raj,

When importing projects, you need to select the parent folder of the project. So it is not the root folder of the project but the parent of that folder. Think of the project folder as the project, so the folder to select is the one that contains one or more project folders.

For example, the workspace folder that you use with eclipse is the parent folder of the projects in that workspace (usually). To import projects from that workspace, select the workspace folder itself. You will then be able to select which projects in the eclipse workspace that you want to import to MyEclipse. You also have the option of leaving the actual project folders where they are (project folders can exist outside the workspace), or copying them into the new workspace.

If the projects are web projects, then there may be some further configuration that is needed depending on how they were set up in eclipse. For example, you may need to Add Web Project Capabilities (from the MyEclipse menu of the context menu for the project), if it isn't recognized as a web project on import.

Running mvn eclipse:eclipse should not be necessary as the project is already an eclipse project. This would only have been necessary before importing non-eclipse maven projects into an eclipse without integrated maven support. MyEclipse has integrated support for maven.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
raj.vacrro@gmail.com
Post subject:   PostPosted: Apr 16, 2012 - 12:39 PM
Registered Member
Registered Member


Joined: Apr 16, 2012
Posts: 5

I am sorry for confusion Tony but my mean was parent folder only when I said root folder. I was successfully able to import it after running "mvn eclipse:eclipse" command which I had to do because it was not recognizing otherwise. If you look at the mail I sent before this you might get a better idea of the issue I am talking about.

Thanks again for your respond and time Tony,
Raj
 
 View user's profile Send private message  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Apr 16, 2012 - 12:42 PM



Joined: Mar 09, 2011
Posts: 958

Raj,

To add to my last comment, MyEclipse can import existing maven eclipse projects and existing maven non-eclipse projects, as previously mentioned. In the latter case, mvn eclipse:eclipse is not needed, as the import process turns the maven project into an eclipse project.

If you weren't able to import your previous project without running mvn eclipse:eclipse then the project could not have been an eclipse project. So I'm a bit confused by your statement that you use eclipse to develop your maven projects.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
raj.vacrro@gmail.com
Post subject:   PostPosted: Apr 16, 2012 - 12:49 PM
Registered Member
Registered Member


Joined: Apr 16, 2012
Posts: 5

Sorry again for the confusion but could you please tell me how to deploy and run the project if I am able to successfully import all the module including parent?

1. Import the existing Maven project as Import->General->Existing Projects into Workspace.
2. Refresh/Clean your project.
3. What next step do I need to take to deploy and run?

I am sure I am doing something wrong there...

Thanks again,
Raj
 
 View user's profile Send private message  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Apr 17, 2012 - 04:35 AM



Joined: Mar 09, 2011
Posts: 958

Raj,

The steps to deploy and run maven applications in MyEclipse are the same as for any other project. There is no need to run a maven install to build, deploy and run MyEclipse projects. Of course, you may have other reasons to build with maven.

So, the steps you took to deploy and start the server are correct. If you are seeing errors, please post the exact errors you are seeing, in full as well as a description of your project structure. Also, attach the .log file that is in the .metadata folder of your workspace and the information you see in MyEclipse->Installation Summary->Installation Details.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits