MyEclipse Forums
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
hahagal
Post subject: Error when accessing application  PostPosted: May 18, 2012 - 11:04 AM



Joined: Apr 22, 2011
Posts: 97

Hi,

I am using WebSphere 7.0. Enterprise project is JavaEE 5.. It get deployed successfully. However, when I get the following error when I tried to access the application.

[5/18/12 17:58:02:874 SGT] 00000016 servlet E com.ibm.ws.webcontainer.servlet.ServletWrapper service SRVE0068E: Uncaught exception created in one of the service methods of the servlet Faces Servlet in application Belsize. Exception created : java.lang.NoSuchMethodError: com/sun/faces/util/Util.verifyFactoriesAndInitDefaultRenderKit(Ljavax/servlet/ServletContext;)V
at com.ibm.faces.context.MultipartFacesContextFactoryImpl.getFacesContext(MultipartFacesContextFactoryImpl.java:73)
at javax.faces.webapp.FacesServlet.service(FacesServlet.java:260)
at com.ibm.ws.webcontainer.servlet.ServletWrapper.service(ServletWrapper.java:1657)
at com.ibm.ws.webcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:939)
at com.ibm.ws.webcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:502)
at com.ibm.ws.webcontainer.servlet.ServletWrapperImpl.handleRequest(ServletWrapperImpl.java:179)
at com.ibm.ws.webcontainer.webapp.WebApp.handleRequest(WebApp.java:3935)
at com.ibm.ws.webcontainer.webapp.WebGroup.handleRequest(WebGroup.java:276)
at com.ibm.ws.webcontainer.WebContainer.handleRequest(WebContainer.java:931)
at com.ibm.ws.webcontainer.WSWebContainer.handleRequest(WSWebContainer.java:1592)
at com.ibm.ws.webcontainer.channel.WCChannelLink.ready(WCChannelLink.java:186)
at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleDiscrimination(HttpInboundLink.java:452)
at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleNewRequest(HttpInboundLink.java:511)
at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.processRequest(HttpInboundLink.java:305)
at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.ready(HttpInboundLink.java:276)
at com.ibm.ws.tcp.channel.impl.NewConnectionInitialReadCallback.sendToDiscriminators(NewConnectionInitialReadCallback.java:214)
at com.ibm.ws.tcp.channel.impl.NewConnectionInitialReadCallback.complete(NewConnectionInitialReadCallback.java:113)
at com.ibm.ws.tcp.channel.impl.AioReadCompletionListener.futureCompleted(AioReadCompletionListener.java:165)
at com.ibm.io.async.AbstractAsyncFuture.invokeCallback(AbstractAsyncFuture.java:217)
at com.ibm.io.async.AsyncChannelFuture.fireCompletionActions(AsyncChannelFuture.java:161)
at com.ibm.io.async.AsyncFuture.completed(AsyncFuture.java:138)
at com.ibm.io.async.ResultHandler.complete(ResultHandler.java:204)
at com.ibm.io.async.ResultHandler.runEventProcessingLoop(ResultHandler.java:775)
at com.ibm.io.async.ResultHandler$2.run(ResultHandler.java:905)
at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1604)

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Installation Summary
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
*** Date:
Friday, May 18, 2012 6:02:22 PM SGT

** System properties:
OS=WindowsVista
OS version=6.1.0
Java version=1.6.0_13


*** MyEclipse details:
MyEclipse Blue Edition
Version: 10.0 Blue
Build id: 10.0-Blue-20111028


*** Eclipse details:
MyEclipse Blue Edition

Version: 10.0 Blue
Build id: 10.0-Blue-20111028




Eclipse Platform

Version: 3.7.0.v20110530-9gF7UHNFFt4cwE-pkZDJ7oz-mj4OSEIlu9SEv0f
Build id: I20110613-1736


Eclipse Java Development Tools

Version: 3.7.0.v20110520-0800-7z8gFchFMTdFYKuLqBLqRja9B15B
Build id: I20110613-1736


Eclipse Plug-in Development Environment

Version: 3.7.0.v20110504-0800-7b7qFVpFEx2XnmYtj_9RfO7
Build id: I20110613-1736


Eclipse Graphical Editing Framework GEF

Version: 3.7.0.v20110425-2050-777D-81B2Bz0685C3A6E34272
Build id: 201105020958


Eclipse RCP

Version: 3.7.0.v20110216-9DB5Fm1FpBGy_AaVz-mFamgY
Build id: I20110613-1736




Eclipse startup command=-os
win32
-ws
win32
-arch
x86
-showsplash
-launcher
C:\Users\admin\AppData\Local\Genuitec\MyEclipse Blue Edition 10\myeclipse-blue.exe
-name
Myeclipse-blue
--launcher.library
C:\Users\admin\AppData\Local\Genuitec\MyEclipse Blue Edition 10\../Common/plugins/org.eclipse.equinox.launcher.i18n.win32.win32.x86_3.2.0.v201103301700\eclipse_3215.dll
-startup
C:\Users\admin\AppData\Local\Genuitec\MyEclipse Blue Edition 10\../Common/plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
-install
C:\Users\admin\AppData\Local\Genuitec\MyEclipse Blue Edition 10
-configuration
C:\Users\admin\AppData\Local\Genuitec\MyEclipse Blue Edition 10\configuration
-vm
C:\Users\admin\AppData\Local\Genuitec\Common\binary\com.sun.java.jdk.win32.x86_1.6.0.013\jre\bin\client\jvm.dll
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: May 18, 2012 - 01:31 PM



Joined: Nov 11, 2010
Posts: 2669

hahagal,

Please update to version 10.1 which is the latest version. Go to MyEclipse Configuration Center > Software > Software Updates Available. Select 10.1, apply the changes and restart the IDE when it prompts to.

This looks more like a Websphere and JSF issue. Take a look at these links :

http://fixunix.com/websphere/559823-faces-was7-0-nosuchmethoderror.html
http://www.ibm.com/developerworks/forums/thread.jspa?messageID=14571127
http://www.websphereusergroup.org/go/thread/view/108057/25592641/?pg=last

Please post to development forums for better support.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
hahagal
Post subject:   PostPosted: May 19, 2012 - 07:06 PM



Joined: Apr 22, 2011
Posts: 97

Hi swapna,

Is there any fixes in 10.1 relating to my issue?
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: May 22, 2012 - 06:51 AM



Joined: Nov 11, 2010
Posts: 2669

hahagal,

It looks more like a Websphere and JSF issue. We have not fixed anything in MyEclipse related to this issue.

I suggest you cross post to relevant forums for the fix/workaround.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits