MyEclipse: MyEclipse 8.6 and Jax-ws 2.2.1

skolson - Aug 17, 2010 - 09:12 PM
Post subject: MyEclipse 8.6 and Jax-ws 2.2.1
I have a small problem - We have some projects using jax-ws2.2.1 downloaded from the normal site. Since this is a little newer than the support that comes with MyEclipse, we see a spurious compile error on source generated by the 2.2.1 version of WSIMPORT.

Is there a way to get MyEclipse 8.6 to use jax-ws 2.2.1 for the inline compiles? If not, is 2.2.1 scheduled for the next release by any chance?

The source itself that wsimport generates is fine, as ANT scripts will build it just fine as long as the wsimport task has the xendorsed="true" tag specified. The default JRE (1.6.0_21) has the updated jaxb-api.jar and jaxws-api.jar in lib/ext, as does the jre inside the JDK. But in eclipse, the generated service classes for each service referenced has a syntax error about a missing constructor definition. So something that myeclipse is using for the real-time inside-the-ide compiles is still using old jax-ws stuff.

I know the JRE insdie eclipse is older. 1.6.0_21 (with the updated stuff in lib/ext) is marked as the JRE for the project in question, but that doesn't seem to help the problem. Inline compiles still don't seem to use the jaxws-api.jar that has the new stuff needed.

This is definitely a low priority - it doesn't stop me from debugging under Tomcat, or from doing deploys, so the only minor annoyance is the false syntax error messages in the Errors window, and the red Xs in the package explorer window.

In case it's useful, the errors all look like this one:

"The constructor Service(URL, QName, WebServiceFeature[]) is undefined"

3 of these happen on each generated @WebServiceClient class. I believe this constructor signature is new with Jax-ws 2.2.0.

Thanks in advance for any help/info...
support-shalini - Aug 18, 2010 - 05:29 AM
Post subject: RE: MyEclipse 8.6 and Jax-ws 2.2.1
skolson,
Can you try updating the libraries provided by MyEclipse? Go to Window > Preferences > MyEclipse > Project Capabilities > Web-Services > JAX-WS. Here you can choose either API Libraries or Runtime Libraries and add the new Jar files.
Please note that any changes made to the libraries here will effect all the projects using those libraries.
Let me know how that works for you.
skolson - Aug 18, 2010 - 02:08 PM
Post subject:
Thanks - I looked and there are two jars in there that don't look like they come from the jax-ws project (maybe xfire?). But the classes inside look like they are the same endorsed packages as the spec ones. The names are webservices-api.jar and webservices-extra-api.jar. So I'm guessing I should remove these, and replace them with the jax-ws project (Metro) ones, is that correct? The API endorsed jars from the jax-ws project are jaxb-api.jar and jaxws-api.jar.

The above takes care of the API jars, but it looks like there is also a pair of runtime jars, which should probably also match. To save me some looking, do you know what the jax-ws equivalent jars are for runtime? I'm sure at least one of the is jaxws-rt.jar, but am unsure of any others. The two names in the current stuff are webservices-extra.jar and webservices-extra.jar.
skolson - Aug 18, 2010 - 03:50 PM
Post subject:
OOPS! I tried the above, and it didn't help, but I realized when i tried it I was on one of our older images that was still on MyEclipse 7.5. So keep that in mind about the second post (from today). The problem happens on both versions, but I haven't tried the above fix on an 8.6 install yet.

FYI on 7.5 I tried the above change and it didn't help. I then did a clean, no help. Just for paranoia's sake, I then tried cycling eclipse, no help. Same spurious syntax error.
support-shalini - Aug 19, 2010 - 12:39 PM
Post subject:
skolson,
I shall escalate this issue to the dev team member.
They will get back to you on this
agthomas - Nov 09, 2010 - 05:40 AM
Post subject: MyEclipse 8.6 and Jax-ws 2.2.1
I have the same issue.
(How to use jax-ws 2.2.1 with MyEclipse 8.6)
If this is addressed please share.

Thanks
THomas
moilejter - Sep 16, 2011 - 09:55 PM
Post subject: Re: MyEclipse 8.6 and Jax-ws 2.2.1
Hi!

I just ran into this issue, myself. Is there a recommended way to proceed?
(It would be great if, when such an issue is addressed, the answer were to be posted here - in addition to emailing the original poster...)

Thank you!

Moises
support-swapna - Sep 20, 2011 - 05:19 AM
Post subject:
moilejter ,

Sorry for the delay. I have escalated this one to a dev team member. They will get back to you.

Sorry for the inconvenience caused.
Support-Brian - Sep 20, 2011 - 01:06 PM
Post subject:
Moises,

Official support for JAX-WS 2.1 has been pushed to the 10.1 release.

In the interim, to libraries to be replaced are at Window > Preferences > MyEclipse > Project Capabilities > Web Services > JAX-WS.

These are libraries directly from the JAX-WS reference implementation (you might notice XFire in the path but that is only the name of the bundle housing the libraries, ignore it).

If you could update these libraries with the latest versions and please let me know exactly what is going wrong with your environment, I can help further. If you see any errors in the problems view, please paste them here.
All times are GMT - 6 Hours
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits