MyEclipse: Opensymphony RIP and so does its DTD?

patricktsang - Jun 05, 2011 - 09:49 AM
Post subject: Opensymphony RIP and so does its DTD?
Hi ,

I know this is not myeclipse issue, but I wanna know someone could help me to solve the xwork validator xml issues.

Now opensymphony is RIP, all validator xml have to change the dtd to struts.apache.org.

eg.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE validators PUBLIC
"-//OpenSymphony Group//XWork Validator Config 1.0//EN"
"http://www.opensymphony.com/xwork/xwork-validator-config-1.0.dtd">

This is invalid, and can be replaced by:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE validators PUBLIC "-//Apache Struts//XWork Validator 1.0.2//EN"
"http://struts.apache.org/dtds/xwork-validator-1.0.2.dtd">

but this is not working for original validators.xml

http://struts.apache.org/2.2.3/docs/validation.html

It prompts me a warning message:
The content of element type "validator" is incomplete, it must match "(param*,message)".

Except that I can turn off the validation check, I still wanna keep it enabled.

What should I do ?

Please help
patricktsang - Jun 14, 2011 - 10:23 AM
Post subject: RE: Opensymphony RIP and so does its DTD?
hi,
Sorry I missed the official struts dtds url here:

http://struts.apache.org/dtds/

Thus, for validators.xml

<!DOCTYPE validators PUBLIC
"-//OpenSymphony Group//XWork Validator Config 1.0//EN"
"http://struts.apache.org/dtds/xwork-validator-config-1.0.dtd">

and customized validation

<!DOCTYPE validators PUBLIC
"-//OpenSymphony Group//XWork Validator Config 1.0//EN"
"http://struts.apache.org/dtds/xwork-validator-1.0.3.dtd">

Thanks
All times are GMT - 6 Hours
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits