MyEclipse: Not able to open jsp file with jsp designer

rdbarri - Aug 30, 2011 - 01:47 PM
Post subject: Not able to open jsp file with jsp designer
Hi ,

I am trying to open a jsp file with jsp designer but it is not opening in designer view..

i am getting this error log

java.lang.NullPointerException
at com.genuitec.eclipse.webdesigner3.editors.WebDesignerMultiPageEditor.previewInMozillaBrowser(WebDesignerMultiPageEditor.java:1189)
at com.genuitec.eclipse.webdesigner3.editors.WebDesignerMultiPageEditor.previewPageChange(WebDesignerMultiPageEditor.java:1096)
at com.genuitec.eclipse.webdesigner3.editors.WebDesignerMultiPageEditor.pageChange(WebDesignerMultiPageEditor.java:1024)
at org.eclipse.ui.part.MultiPageEditorPart$2.widgetSelected(MultiPageEditorPart.java:290)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:234)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1077)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1062)
at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:774)
at org.eclipse.swt.custom.CTabFolder.setSelection(CTabFolder.java:2743)
at org.eclipse.swt.custom.CTabFolder.onMouse(CTabFolder.java:1429)
at org.eclipse.swt.custom.CTabFolder$1.handleEvent(CTabFolder.java:257)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4066)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3657)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2640)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2604)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2438)
at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:664)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:115)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
at org.eclipse.equinox.launcher.Main.main(Main.java:1383)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at com.genuitec.pulse.eclipse.launcher.Main.main(Main.java:110)
support-swapna - Aug 31, 2011 - 09:16 AM
Post subject:
rdbarri ,

Sorry that you are seeing this issue with MyEclipse.

Can you answer some more questions for us to investigate further ?

1) Paste your Build Id here from Help > About MyEclipse Enterprise Workbench > Build Id.

2) Can you also share your OS and version details ?

3) Clear the contents of the .log file which is located at <workspace dir>/.metadata/.log. Now replicate the issue and paste the entire contents of the .log file here.
rdbarri - Sep 01, 2011 - 02:49 AM
Post subject: Not able to open jsp file with jsp designer
support-swapna wrote:
rdbarri ,

Sorry that you are seeing this issue with MyEclipse.

Can you answer some more questions for us to investigate further ?

1) Paste your Build Id here from Help > About MyEclipse Enterprise Workbench > Build Id.

2) Can you also share your OS and version details ?

3) Clear the contents of the .log file which is located at <workspace dir>/.metadata/.log. Now replicate the issue and paste the entire contents of the .log file here.



-----------------------------------------------------------------------------------------

1) Version: 9.1
Build id: 9.1-20110701

2)Windows 7 Professional
Service Pack 1
64 bit Operating Syatem

3)!ENTRY com.genuitec.eclipse.webdesigner3 4 0 2011-08-31 21:08:14.743
!MESSAGE
!STACK 0
java.lang.NullPointerException
at com.genuitec.eclipse.webdesigner3.editors.WebDesignerMultiPageEditor.previewInMozillaBrowser(WebDesignerMultiPageEditor.java:1189)
at com.genuitec.eclipse.webdesigner3.editors.WebDesignerMultiPageEditor.previewPageChange(WebDesignerMultiPageEditor.java:1096)
at com.genuitec.eclipse.webdesigner3.editors.WebDesignerMultiPageEditor.pageChange(WebDesignerMultiPageEditor.java:1024)
at org.eclipse.ui.part.MultiPageEditorPart$2.widgetSelected(MultiPageEditorPart.java:290)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:234)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1077)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1062)
at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:774)
at org.eclipse.swt.custom.CTabFolder.setSelection(CTabFolder.java:2743)
at org.eclipse.swt.custom.CTabFolder.onMouse(CTabFolder.java:1429)
at org.eclipse.swt.custom.CTabFolder$1.handleEvent(CTabFolder.java:257)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4066)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3657)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2640)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2604)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2438)
at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:664)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:115)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
at org.eclipse.equinox.launcher.Main.main(Main.java:1383)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at com.genuitec.pulse.eclipse.launcher.Main.main(Main.java:110)
esiegemun - Sep 01, 2011 - 08:03 AM
Post subject: Same trouble
Hi,

I have exactly the same problem with MyEclsipe 9.1.0 and JSP files. Same behaviour in editor, same error log and stack trace.

Code:

!ENTRY com.genuitec.eclipse.webdesigner3 4 0 2011-09-01 08:43:39.578
!MESSAGE
!STACK 0
java.lang.NullPointerException
   at com.genuitec.eclipse.webdesigner3.editors.WebDesignerMultiPageEditor.previewInMozillaBrowser(WebDesignerMultiPageEditor.java:1189)
   at com.genuitec.eclipse.webdesigner3.editors.WebDesignerMultiPageEditor.previewPageChange(WebDesignerMultiPageEditor.java:1096)
   at com.genuitec.eclipse.webdesigner3.editors.WebDesignerMultiPageEditor.pageChange(WebDesignerMultiPageEditor.java:1024)
   at org.eclipse.ui.part.MultiPageEditorPart$2.widgetSelected(MultiPageEditorPart.java:290)
   at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:234)
   at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)

esiegemun - Sep 01, 2011 - 08:14 AM
Post subject: OS and Build ID
... sorry - I forgott:

- same build ID (Version: 9.1 Build id: 9.1-20110701)
- same OS (Win 7 Prof 64 bit SP 1)
...
rdbarri - Sep 01, 2011 - 07:21 PM
Post subject: Not able to open jsp file with jsp designer
Hi esiegemun

Did you find any solution???
esiegemun - Sep 01, 2011 - 09:50 PM
Post subject: no idea
Not at all and no idea!

There is an other error in the log
Code:

!ENTRY org.eclipse.osgi 2 0 2011-09-01 08:43:06.474
!MESSAGE While loading class "org.eclipse.wst.jsdt.internal.core.JavaModelManager$16", thread "Thread[Worker-6,5,main]" timed out waiting (5000ms) for thread "Thread[Worker-2,5,main]" to finish starting bundle "org.eclipse.wst.jsdt.core_1.1.2.me201106211924 [1210]". To avoid deadlock, thread "Thread[Worker-6,5,main]" is proceeding but "org.eclipse.wst.jsdt.internal.core.JavaModelManager$16" may not be fully initialized.
!STACK 0
org.osgi.framework.BundleException: State change in progress for bundle "reference:file:/C:/Users/erik/AppData/Local/Genuitec/Common/plugins/org.eclipse.wst.jsdt.core_1.1.2.me201106211924.jar" by thread "Worker-2".
...


I'm not sure, if there exist any relationship between both errors ...

As I can see, the trouble with the JSP editor (NPE in the log) exists already for some weeks. I've not used the JSP editor for some time - fail to see the error.
support-swapna - Sep 05, 2011 - 11:39 AM
Post subject:
esiegemun , rdbarri ,

Apologies for delayed response.

1) Firstly Visual Designers are not available for 64 bit installations on Windows.
Is your MyEclipse installation a 32 bit version or 64 bit version ?

2) Can you start the IDE with -clean and check if the issue persists ? Here is an FAQ for clean : http://myeclipseide.com/PNphpBB2-viewtopic-t-10280.html

3) If you still see the issue, clear the contents of the .log file which is located at <workspace dir>/.metadata/.log, replicate the issue and then copy paste the entire log contents here for further investigation.
rdbarri - Sep 05, 2011 - 06:34 PM
Post subject: Not able to open jsp file with jsp designer
Hi..

My installation of MyEclipse is 64 bit version.

How to move to 32 bit...MyEclipse
and will 32 bit MyEclipse cause any issues..because my OS is 64 bit...
support-swapna - Sep 06, 2011 - 06:07 AM
Post subject:
rdbarri ,

If you run the installer for MyEclipse, it will give you option of installing the 32 bit or 64 bit version as you have 64 bit OS. Choose the 32 bit version and install it.

You can either uninstall your existing MyEclipse and rerun the installer or you can simply install it to a different location. There should not be any issues in running MyEclipse 32 bit on 64 bit OS.

Let me know how this works for you.
All times are GMT - 6 Hours
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits