MyEclipse Forums
This thread has been locked & this forum has been archived.
View previous topic Printable version Log in to check your private messages View next topic
Author Message
gzhuye
Post subject: MyEclipse support J2se1.5 completely? [Closed]  PostPosted: May 06, 2005 - 06:47 PM
Registered Member
Registered Member


Joined: Aug 12, 2004
Posts: 39

Hi:

does the newest MyEclipse support J2se1.5 completely?

I'm using MyEclipse 3.8.4, but it seems not to support java1.5, for example, when List<String> used, it knows nothing about it and marks red wave line under it.

give more advide

Thanks

Paul
 
 View user's profile Send private message  
Reply with quote Back to top
support-scott
Post subject:   PostPosted: May 06, 2005 - 08:12 PM
Moderator
Moderator


Joined: May 06, 2003
Posts: 6761

Paul,

Java language support for JDK 1.5 is provided only by Eclipse 3.1, not 3.0. Right now there is an Eclipse 3.1 milestone build (M6) that supports JDK 1.5, and we have a 3.8.4 Beta release that support 3.1M6 available in our download area. I'd suggest you keep your current installations and install the new Eclipse & MyEclipse builds in parallel to them so you can test and make sure they meet your needs.

_________________
--Scott
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
gzhuye
Post subject:   PostPosted: May 06, 2005 - 09:02 PM
Registered Member
Registered Member


Joined: Aug 12, 2004
Posts: 39

Thank you very much! I'll do.
 
 View user's profile Send private message  
Reply with quote Back to top
gzhuye
Post subject:   PostPosted: May 06, 2005 - 10:01 PM
Registered Member
Registered Member


Joined: Aug 12, 2004
Posts: 39

Scott:

After I reinstalled what you told, when I put : List<String> wordlist = new ArrayList<String>(); in java file

IDE complains:

The type List is not generic; it cannot be parameterized with arguments <String>

Syntax error, parameterized types are only available if source level is 5.0

The type ArrayList is not generic; it cannot be parameterized with arguments <String>

Syntax error, parameterized types are only available if source level is 5.0


My env setting:

Installed IDEs: C:\Program Files\Java\jre1.5.0_01

C:\>
C:\>java -version
java version "1.5.0_01"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_01-b08)
Java HotSpot(TM) Client VM (build 1.5.0_01-b08, mixed mode)

C:\>echo %java_home%
C:\Program Files\Java\jre1.5.0_01


Possible somethng else wrong?

Thanks for your helsps

Paul
 
 View user's profile Send private message  
Reply with quote Back to top
support-scott
Post subject:   PostPosted: May 07, 2005 - 01:38 AM
Moderator
Moderator


Joined: May 06, 2003
Posts: 6761

Paul,

You need to be sure that Eclipse is picking JDK 1.5 to run with. You can set that on the commandline with:
eclipse.exe -vm <path-to-jdk1.5-install>\bin\javaw.exe. You can see which JDK Eclipse launched with by
navigating to Help > About Eclipse Platform > Configuration Details. Also, you'll need to check your compiler
settings at Window > Preferences > Java > Compiler and pay close attention to the "Compliance and Classfiles" setting.

_________________
--Scott
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
gzhuye
Post subject:   PostPosted: May 09, 2005 - 03:58 PM
Registered Member
Registered Member


Joined: Aug 12, 2004
Posts: 39

Scott:

Thank you very much!

I didn't set :

settings at Window > Preferences > Java > Compiler and pay close attention to the "Compliance and Classfiles" setting.

It is ok now.

Paul
 
 View user's profile Send private message  
Reply with quote Back to top
Busher
Post subject:   PostPosted: Apr 10, 2008 - 09:00 AM



Joined: Apr 10, 2008
Posts: 1

gzhuye wrote:
Scott:

Thank you very much!

I didn't set :

settings at Window > Preferences > Java > Compiler and pay close attention to the "Compliance and Classfiles" setting.

It is ok now.

Paul


I got the same problem.And now I got it,thank you Scott and Paul
 
 View user's profile Send private message  
Reply with quote Back to top
zhongxhua
Post subject:   PostPosted: Apr 26, 2008 - 04:44 AM



Joined: Apr 26, 2008
Posts: 2

thanks very much,
i have got the problem too
 
 View user's profile Send private message  
Reply with quote Back to top
zhongxhua
Post subject:   PostPosted: Apr 26, 2008 - 04:44 AM



Joined: Apr 26, 2008
Posts: 2

thanks very much,
i have got the problem too
 
 View user's profile Send private message  
Reply with quote Back to top
dilippatel999
Post subject:   PostPosted: Apr 30, 2009 - 09:21 PM



Joined: Apr 30, 2009
Posts: 1

Hi I am using Java 1.4.2_03 and getting error
for executing

ArrayList<String> list = new ArrayList<String>();
list.add("One");
list.add("Two");
list.add("Three");
list

Error is

The type ArrayList is not generic; it cannot be parameterized with arguments <String>
The type ArrayList is not generic; it cannot be parameterized with arguments <String>


Do i have to install java 1.5 and jre 5.0?

Please help requested
 
 View user's profile Send private message  
Reply with quote Back to top
rmcvay
Post subject:   PostPosted: May 01, 2009 - 08:15 PM
Registered Member
Registered Member


Joined: Sep 17, 2004
Posts: 217

Yes.

_________________
Ray
Just another MyEclipse user
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits