MyEclipse Forums
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
criecke
Post subject: Very Slow Startup on 7.5  PostPosted: Sep 25, 2009 - 04:19 PM



Joined: Mar 31, 2006
Posts: 5

My computer's no slouch - I have a p7. Yet when MyEclipse starts up, it takes 60 seconds before the first plugin loads. It's peppy from then on. During the 60 seconds, there's barely any CPU.

Is there any profiling setting I can turn on to see what's taking so long?
 
 View user's profile Send private message  
Reply with quote Back to top
support-nipun
Post subject: RE: Very Slow Startup on 7.5  PostPosted: Sep 25, 2009 - 07:18 PM
Registered Member
Registered Member


Joined: Apr 18, 2007
Posts: 8010

Can you go to MyEclipse > Installation Summary > Installation Details and paste the information here for me.

If you switch to a new workspace and try starting up MyEclipse again, does it still take this long?

_________________
Nipun
MyEclipse Support
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
criecke
Post subject: RE: Very Slow Startup on 7.5  PostPosted: Sep 28, 2009 - 08:24 PM



Joined: Mar 31, 2006
Posts: 5

Pasted below. And yes, when I start up in a completely blank workspace, it's definitely faster.

*** Date:
Monday, September 28, 2009 3:21:07 PM EDT

** System properties:
OS=WindowsXP
OS version=5.1.0
Java version=1.6.0_13


*** MyEclipse details:
MyEclipse Enterprise Workbench
Version: 7.5
Build id: 7.5-20090609


*** Eclipse details:
MyEclipse Enterprise Workbench

Version: 7.5
Build id: 7.5-20090609




Eclipse Plug-in Development Environment

Version: 3.4.2.R342_v20090122-7T7U1E9imVKz-A8Vz-p_jRS
Build id: M20080703-0800


Eclipse Platform

Version: 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL
Build id: M20090211-1700


Eclipse Graphical Editing Framework GEF

Version: 3.4.2.v20090218-1145-67728084A56B4I233613552
Build id: 200809101400


Eclipse RCP

Version: 3.4.200.R342_v20090122-989JESTEbig-SVaL8UJHcYBr4A63
Build id: M20090211-1700


Eclipse Java Development Tools

Version: 3.4.2.r342_v20081217-7o7tEAoEEDWEm5HTrKn-svO4BbDI
Build id: M20090211-1700




Eclipse startup command=-os
win32
-ws
win32
-arch
x86
-showsplash
-launcher
C:\Program Files\Genuitec\MyEclipse 7.5\myeclipse.exe
-name
Myeclipse
--launcher.library
C:\Program Files\Genuitec\MyEclipse 7.5\../Common\plugins\org.eclipse.equinox.launcher.win32.win32.x86_1.0.101.R34x_v20080731\eclipse_1115.dll
-startup
C:\Program Files\Genuitec\MyEclipse 7.5\../Common\plugins\org.eclipse.equinox.launcher_1.0.101.R34x_v20081125.jar
-clean
-configuration
configuration
-vm
C:\Program Files\Genuitec\Common\binary\com.sun.java.jdk.win32.x86_1.6.0.013\jre\bin\client\jvm.dll
 
 View user's profile Send private message  
Reply with quote Back to top
support-nipun
Post subject: RE: Very Slow Startup on 7.5  PostPosted: Sep 29, 2009 - 07:32 PM
Registered Member
Registered Member


Joined: Apr 18, 2007
Posts: 8010

Quote:

And yes, when I start up in a completely blank workspace, it's definitely faster.

How many projects do you have in your old workspace? I believe it is one of your projects that could be causing the slow startup or your workspace could be corrupt. You can try using the -clean command to fix this issue.
http://myeclipseide.com/PNphpBB2-viewtopic-t-10280.html

Incase the problem still persists, you should transfer you projects to a new workspace and resume working. Sorry for the inconvenience.

_________________
Nipun
MyEclipse Support
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
criecke
Post subject: RE: Very Slow Startup on 7.5  PostPosted: Oct 02, 2009 - 08:11 PM



Joined: Mar 31, 2006
Posts: 5

The -clean option did not work, but I had some projects open that really didn't need to be. One was pretty big - over 4,000 files. Closing them definitely improved startup time. I can live with that.
 
 View user's profile Send private message  
Reply with quote Back to top
support-joy
Post subject: RE: Very Slow Startup on 7.5  PostPosted: Oct 05, 2009 - 07:05 AM
Registered Member
Registered Member


Joined: Feb 03, 2009
Posts: 3442

criecke,

Good to hear that you have a working solution. Adding to this you can also do the following to increase the performace of the IDE -
Turn off features:
Windows > Preferences > General > Capabilities > Advanced and disable the capabilities that you are not using

_________________
Joy
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
katesr
Post subject: RE: Very Slow Startup on 7.5  PostPosted: Oct 16, 2009 - 07:55 PM
Registered Member
Registered Member


Joined: Apr 28, 2009
Posts: 12

I found that removing "-clean" from the myeclipse.ini file reduced my startup time to around 10 seconds, from about 30 seconds.

After the ide displays, it then checks for updates. Turning off the automatic update checking seemed to remove around 15 seconds delay until the ide is really usable (meaning that until that update window displays you might as well not edit anything because it's just going to interrupt you anyway when it does).

Opening the ide with a JSP as the active tab seems to add 10 seconds back to the start up time. Opening with .java file as the active tab does not.
 
 View user's profile Send private message  
Reply with quote Back to top
support-joy
Post subject: RE: Very Slow Startup on 7.5  PostPosted: Oct 19, 2009 - 04:36 AM
Registered Member
Registered Member


Joined: Feb 03, 2009
Posts: 3442

katesr,

Thank you very much for your valuable information. This may be helpful for other users who has similar problem. I appreciate your help.

_________________
Joy
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
katesr
Post subject: Re: RE: Very Slow Startup on 7.5  PostPosted: Apr 01, 2010 - 03:52 PM
Registered Member
Registered Member


Joined: Apr 28, 2009
Posts: 12

support-joy wrote:
katesr,

Thank you very much for your valuable information. This may be helpful for other users who has similar problem. I appreciate your help.


Joy - I've been hoping that some sort of update would occur that would address the slow JSP tooling/editing problems in 7.5. But it appears that the problem is still occuring in version 8 - would you or someone else involved with support please comment on this post http://www.myeclipseide.com/PNphpBB2-viewtopic-t-25338.html
 
 View user's profile Send private message  
Reply with quote Back to top
support-joy
Post subject: RE: Re: RE: Very Slow Startup on 7.5  PostPosted: Apr 05, 2010 - 01:25 PM
Registered Member
Registered Member


Joined: Feb 03, 2009
Posts: 3442

katesr,

Can you install ME 8.5 and give it a shot? ME 8.5 has added performance improvements over ME 7.5 and ME 8.0. Please give it a try and let me know your findings.

_________________
Joy
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
mkaul
Post subject: Slow when using JSP/Javascript etc  PostPosted: Mar 20, 2011 - 10:26 PM
Veteran Member
Veteran Member


Joined: Sep 21, 2005
Posts: 11

Looking at the posts it seems like I made the wrong choice in choosing MyEclipse 8.6! I had been using MyEclipse in the past and thought it rocked but now the lag is so unbearable that I simply cannot write any JSP or javascript code in it. Why is this so slow? Is there a setting I can change to stop doing extra checks or whatever its trying to do for the js code?
I will download 9.0 M2 and see if thats any better.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-joy
Post subject: RE: Slow when using JSP/Javascript etc  PostPosted: Mar 21, 2011 - 10:21 AM
Registered Member
Registered Member


Joined: Feb 03, 2009
Posts: 3442

mkaul,

Please try out ME 9.0 GA and let me know your feedback.

Best

_________________
Joy
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits