MyEclipse Forums
This thread has been locked & this forum has been archived.
Please post new topics to Java EE Development (EJB, JSP, Struts, XDoclet, etc.)
View previous topic Printable version Log in to check your private messages View next topic
Author Message
Travancore
Post subject: DB Browser Issues  PostPosted: Apr 05, 2011 - 08:00 AM
Registered Member
Registered Member


Joined: Apr 05, 2011
Posts: 3

Subsriber ID : Travancore-UL3-EX2012-03-28
Installation Summary
Code:

*** Date:
Tuesday, April 5, 2011 12:20:15 PM IST

** System properties:
OS=WindowsXP
OS version=5.1.0
Java version=1.6.0_13


*** MyEclipse details:
MyEclipse Enterprise Workbench
Version: 8.6.1
Build id: 8.6.1-20101117


*** Eclipse details:
MyEclipse Enterprise Workbench

Version: 8.6.1
Build id: 8.6.1-20101117






Eclipse startup command=-os
win32
-ws
win32
-arch
x86
-showsplash
-launcher
D:\MyEclipse-8.6\myeclipse.exe
-name
Myeclipse
--launcher.library
D:\MyEclipse-8.6\../Genuitec/Common/plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.200.v20090519\eclipse_1206.dll
-startup
D:\MyEclipse-8.6\../Genuitec/Common/plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar
-install
D:\MyEclipse-8.6
-configuration
D:\MyEclipse-8.6\configuration
-vm
D:/Genuitec/Common/binary/com.sun.java.jdk.win32.x86_1.6.0.013/jre/bin/client/jvm.dll

PROBLEMS
We had downloaded the demo version from the site and when obtained the subscription details updated the same in the Subscription window. We had installed the demo version in two computers. Both running winxp (same version). But in both machines the DB Browser is behaving differently. We are using oracle 10g as backend.


    In machine1, while creating a new table through DB Browser, we are not able to create fields of TIMESTAMP Type. In SQL create TIMESTAMP is permitted and created. But while editing the table, TIMESTAMP field is displayed as <UnSupported>. In machine 2, DB Browser permits TIMESTAMP Data Type

    In Machine 1, under Generate Menu, we only have two options that is, Select Statement and DDL. Again when you select DDL it displays error 'Invalid Column Name'. But Machine 2 not only has more options under 'Generate' menu, but also permits proper DDL generation.


Kindly Help
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-swapna
Post subject: RE: DB Browser Issues  PostPosted: Apr 05, 2011 - 10:36 AM



Joined: Nov 11, 2010
Posts: 2491

Travancore,

Can you answer some more questions for me to understand the issue better ?

1) Can you verify if you have used the same version of driver jars in the Oracle Database Connection Settings in both the machines ?

2) Are you connected to the same Oracle server from both the machines ?

3) Can you check if you are able to create a table with TIMESTAMP directly on Oracle 10g without using the MyEclipse IDE ?

4) What exact error do you see when using the TIMESTAMP in Machine 1 ? Paste it here for me.

5) Do you see any errors of interest logged in the .log file which is located at < workspace dir>/ .metadata / .log file ? If yes then paste them here for me.

6) Can you attach a screenshot of the connection settings of Machine 1 and 2 ?

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Travancore
Post subject: RE: DB Browser Issues  PostPosted: Apr 09, 2011 - 07:35 AM
Registered Member
Registered Member


Joined: Apr 05, 2011
Posts: 3

Quote:

1) Can you verify if you have used the same version of driver jars in the Oracle Database Connection Settings in both the machines ?



We use copies of same JBoss folder with classes12.jar in its lib directory. We use copy of same project folder in both machines so all settings are same.


Quote:

2) Are you connected to the same Oracle server from both the machines ?



Yes, both machine access same oracle server

Quote:

3) Can you check if you are able to create a table with TIMESTAMP directly on Oracle 10g without using the MyEclipse IDE ?


yes.It is possible.

Quote:

4) What exact error do you see when using the TIMESTAMP in Machine 1 ? Paste it here for me.



when we create a table using the "new table" functionality the Timestamp data type is not being shown in 'Type drop down'.

Quote:

5) Do you see any errors of interest logged in the .log file which is located at < workspace dir>/ .metadata / .log file ? If yes then paste them here for me.



I couldn't see any abnormal errors in log file.
Quote:

6) Can you attach a screenshot of the connection settings of Machine 1 and 2 ?


I couldn't find any option to attach a file here. Iif you provide me with a contact email id i will send them to it.

To make the issue more clear:

1)In computer A,when we create a table using the "new table" functionality the Timestamp data type is not being listed. While editing the table, TIMESTAMP field is displayed as <UnSupported>. In Computer B this feature is functioning well.


2) In computer A the generate DDL is not working as it shows an error " invalid column name". Also under generate menu, DDL(advanced) and XML menus are not available which are available in computer B.But in computer B , for some tables, in sql result viewer, timestamp fields are shown as dates.In Generate DDL of that table, the tymestamp datatype of the column is erroneously shown as 'Date' datatype.

we downloaded trial version of myeclipse and same setup file is used to install in both machines, and later activated both with same licence info.
Please look into these problems.


Looking forward to hearing from you soon,
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-swapna
Post subject: RE: DB Browser Issues  PostPosted: Apr 11, 2011 - 06:36 AM



Joined: Nov 11, 2010
Posts: 2491

Travancore,

1) Can you attach a screenshot of MyEclipse > Subscription Information and send it to me ?

Here is an FAQ on how you can attach files :
http://www.myeclipseide.com/PNphpBB2-viewtopic-t-27029.html

2) Can you also attach the screenshot of the Oracle connector settings of Machine A ?

3) Can you close the MyEclipse IDE in Machine B and check if the issue is reproducible in Machine A ?

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
danieldrews092
Post subject:   PostPosted: May 23, 2011 - 01:04 PM



Joined: May 23, 2011
Posts: 1

i will review it twice so that i can understand it..

_________________
taos - taos hotels - santa fe nm hotels
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: May 24, 2011 - 06:00 AM



Joined: Nov 11, 2010
Posts: 2491

danieldrews092,

Let us know if you have any issues.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits