MyEclipse Forums
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
Mulder8472
Post subject: Missing resources in jar files  PostPosted: Jun 16, 2011 - 11:41 AM



Joined: Jul 21, 2009
Posts: 15

we have a multi project web project. some of the modules have resources (e.g. spring config files or faces-config files) which need to be packed in the jar files META-INF folder, or deploy to WEB-INF/classes/META-INF (depending on your deployment method).

This kind of works, but we are experiencing random behaviour in that often a module would be deployed without its resources. it is very annoying because you can not distinguish a real problem from those random deploy errors. The only temporary solution I came up with so far is to right click the project and select Maven4MyEclipse-->Update Project Configuration. Nothing actually changes within the project, but it will start to deploy the resources (from src/main/resources) to the server again... at least for a while.

any hints or help is greatly appreciated, this is causing us some pain...
oh, we run ME 8.6.
 
 View user's profile Send private message  
Reply with quote Back to top
support-joy
Post subject: RE: Missing resources in jar files  PostPosted: Jun 16, 2011 - 11:46 AM
Registered Member
Registered Member


Joined: Feb 03, 2009
Posts: 3442

Mulder8472,

Sorry to hear you are running into this issue. Could you try this - remove the "maven-resources-plugin" from the local repository in your system and build your project again. This would force maven to add necessary resources.

Let me know how this works for you.

Best.

_________________
Joy
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Mulder8472
Post subject: RE: Missing resources in jar files  PostPosted: Jun 16, 2011 - 01:41 PM



Joined: Jul 21, 2009
Posts: 15

i have removed the plugin. but it did not make any difference, after a few redeploys to tomcat, it started to randomly forget resources again.
 
 View user's profile Send private message  
Reply with quote Back to top
support-joy
Post subject: RE: Missing resources in jar files  PostPosted: Jun 17, 2011 - 10:22 AM
Registered Member
Registered Member


Joined: Feb 03, 2009
Posts: 3442

Mulder8472,

I am escalating your issue to dev team member. They would get back to you on this.
Could you provide below details -
1. Copy and paste your installation details. Refer - http://myeclipseide.com/index.php?name=PNphpBB2&file=viewtopic&t=27030&highlight=
2. Clear your .log file located at [your workspace dir]/.metadata/.log, replicate issue and copy and paste the same here. Refer - http://myeclipseide.com/index.php?name=PNphpBB2&file=viewtopic&t=27029&highlight=

Sorry for the inconvenience.

_________________
Joy
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
support-tomasz
Post subject: RE: Missing resources in jar files  PostPosted: Jun 18, 2011 - 01:49 PM



Joined: Apr 14, 2011
Posts: 22

and please send us Your pom.xml. Thanks.
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits