MyEclipse Forums
This thread has been locked & this forum has been archived.
Please post new topics to Java EE Development (EJB, JSP, Struts, XDoclet, etc.)
View previous topic Printable version Log in to check your private messages View next topic
Author Message
howardh
Post subject: Report Web Libraries BIRT 2.6 not available  PostPosted: Oct 11, 2011 - 09:05 PM



Joined: Dec 15, 2005
Posts: 37

Updated existing report project from 8.5 to 9.1, which updated my .reportdesign file.

Now project will not run due to tomcat error:
java.lang.NoSuchMethodError: org.eclipse.birt.report.engine.api.EngineConfig.getLogRollingSize()

As I understand, this is a BIRT 2.6 method.

I have MyEclipse Reports 9.1 installed (supposedly), but when I try to add the 9.1/BIRT 2.6 library, it is not available - doesn't show up as a choice in the add library process.

It appears the 'upgrade' to 9.1 missed at least this library.

How do I make this available to my project?

Installation summary::
*** Date:
Tuesday, October 11, 2011 4:02:45 PM EDT

** System properties:
OS=WindowsVista
OS version=6.1.0
Java version=1.6.0_13


*** MyEclipse details:
MyEclipse Enterprise Workbench
Version: 9.1
Build id: 9.1-20110701


*** Eclipse details:
MyEclipse Enterprise Workbench

Version: 9.1
Build id: 9.1-20110701






Eclipse startup command=-os
win32
-ws
win32
-arch
x86
-showsplash
-launcher
C:\Users\hmh\AppData\Local\Genuitec\MyEclipse 9\myeclipse.exe
-name
Myeclipse
--launcher.library
C:\Users\hmh\AppData\Local\Genuitec\MyEclipse 9\../Common/plugins/org.eclipse.equinox.launcher.i18n.win32.win32.x86_3.2.0.v201103301700\eclipse_3215.dll
-startup
C:\Users\hmh\AppData\Local\Genuitec\MyEclipse 9\../Common/plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-clean
-install
C:\Users\hmh\AppData\Local\Genuitec\MyEclipse 9
-configuration
C:\Users\hmh\AppData\Local\Genuitec\MyEclipse 9\configuration
-vm
C:\Users\hmh\AppData\Local\Genuitec\Common\binary\com.sun.java.jdk.win32.x86_1.6.0.013\jre\bin\client\jvm.dll
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Oct 13, 2011 - 06:44 AM



Joined: Nov 11, 2010
Posts: 2489

howardh ,

I have escalated it to a dev team member. They will get back to you.
Sorry for the inconvenience caused.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Support-Brian
Post subject:   PostPosted: Oct 13, 2011 - 08:20 AM
Moderator
Moderator


Joined: Aug 21, 2004
Posts: 2583

Howard,

We stopped shipping BIRT libraries as containers with MyEclipse 9. The problem was the fact that with every BIRT release, we needed to keep shipping the older containers as well as the newer ones, typically increasing the size of MyEclipse by 10 to 20 megabytes with each BIRT upgrade.

If you create a new BIRT project with 9.1, all the required libraries that typically were in containers will now be copied directly into WEB-INF/lib. The rest of the libraries are in WEB-INF/report-engine as they have always been. For a new project created in MyEclipse 9.1, you will get BIRT 2.6.1 libraries.

To upgrade your project, I suggest you create a new dummy report project, and copy into your project the following, replacing the versions that currently exist in your project (other than your project specific libraries, of course).

1) WebRoot/report-viewer
2) WebRoot/WEB-INF/lib
3) WebRoot/WEB-INF/report-engine
4) WebRoot/WEB-INF/tlds
5) WebRoot/WEB-INF/server-config.wsdd
6) WebRoot/WEB-INF/viewer.properties

We're working on an upgrade wizard, but that is not currently available, I hope this helps. Let us know if you need further assistance.

_________________
Brian
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
howardh
Post subject:   PostPosted: Oct 14, 2011 - 07:15 PM



Joined: Dec 15, 2005
Posts: 37

Brian,

Good to know. Did create new project and copy report-viewer and report-engine like I usually do after an upgrade, but didn't have to copy the lib or those others before that I am aware of.

That did work. Hopefully I'll remember next time...

Thanks
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Oct 17, 2011 - 06:19 AM



Joined: Nov 11, 2010
Posts: 2489

howardh,

Glad that it is working.
Do let us know if you have any other issues.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits