MyEclipse Forums
This thread has been locked & this forum has been archived.
Please post new topics to General Development
View previous topic Printable version Log in to check your private messages View next topic
Author Message
javaboy88
Post subject: Matisse design tab is empty  PostPosted: Oct 17, 2011 - 05:45 PM



Joined: May 21, 2009
Posts: 15

I'm attempting to add an element to an existing form. However, when I open the form, there is nothing on the design tab (blank) and nothing in the outline area. I've googled this issue, but found nothing relevant. As far as I can tell, I have the software for Matisse and I'm using the Matisse perspective. I've tried creating a new form according to the tutorial, but it's blank too and I'm cannot drag anything from the Matisse Palette.

_________________
javaboy88
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Oct 18, 2011 - 05:48 AM



Joined: Nov 11, 2010
Posts: 2491

javaboy88,

Sorry that you are seeing this issue with MyEclipse.

1) Can you share your Build ID from Help > About MyEclipse Enterprise Workbench > Build ID ? Paste the Build ID here.

2) For the new Form, you need to use the load and drop instead of drag and drop to add controls to the form. Select the control from the Palatte, hold and then drop it on to the form.

3) For the issue with existing form, on the source-tab of matisse does everything look fine and does the source compile and work as expected ?

4) Close the form, clear the contents of the .log file which is located at <workspace dir>/.metadata/.log, now open the form again and paste the contents of the .log file here.

Let me know how it works for you.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
javaboy88
Post subject:   PostPosted: Oct 18, 2011 - 02:21 PM



Joined: May 21, 2009
Posts: 15

Version and build id:
Version: 8.6
Build id: 8.6-20100806
I was following your instructions this morning ... when I got to number 4, the form opened and the design is now visible. Some kind of magic (lol). The only change since yesterday is that I have restarted my computer.
Thanks for your assistance,
Mike

_________________
javaboy88
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Oct 19, 2011 - 03:25 AM



Joined: Nov 11, 2010
Posts: 2491

javaboy88 ,

Glad that it is working.
Do let us know if you have any other issues.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
ehodges
Post subject:   PostPosted: Jun 05, 2012 - 08:50 PM



Joined: Aug 26, 2011
Posts: 10

I'm getting the same behavior on Version: 10.1, Build id: 10.1-20120316. Nothing is written to the .log file. The design tab is completely empty, no tool bar or anything. The Properties tab is empty, too.

A few of my .form files show components in the design tab, but the vast majority don't.
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Jun 06, 2012 - 08:16 AM



Joined: Nov 11, 2010
Posts: 2491

ehodges,

Sorry that you are seeing this issue.

1. Can you share with us the details of what components are there on the form ? You can see the list in the Outline tab.

2. Can you send us a screenshot of the MyEclipse Swing/Matisse Perspective with clear view of Outline tab for us to help get a visual.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
ehodges
Post subject:   PostPosted: Jun 06, 2012 - 04:11 PM



Joined: Aug 26, 2011
Posts: 10

Here's a screen shot of one of them. It's a JPanel with 3 labels and 2 combo boxes.



Matisse Fail Design Image.JPG
 Description:
Properties and design tabs.
 Filesize:  33.33 KB
 Viewed:  4477 Time(s)

Matisse Fail Design Image.JPG



Matisse Fail Outline Image.JPG
 Description:
Outline tab.
 Filesize:  22.13 KB
 Viewed:  4477 Time(s)

Matisse Fail Outline Image.JPG


 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Jun 08, 2012 - 12:15 PM



Joined: Nov 11, 2010
Posts: 2491

ehodges,

Thank you for the screenshot.

1. In the Outline view, I see a component with "null" under JPanel. Can you let us know what exactly it is ? Can you delete it and see what the effect is on the rest of the form?

2. Can you attach the form and the java class for us to take a look ? If you have the time you can replicate the problem in a simpler form and send it to us for further investigation.

3. I could not replicate the issue at my end with a JPanel and the components listed by you.
Attached is the screenshot for your reference.



MatForm.JPG
 Description:
 Filesize:  126.87 KB
 Viewed:  4441 Time(s)

MatForm.JPG



_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
ehodges
Post subject:   PostPosted: Jun 08, 2012 - 04:41 PM



Joined: Aug 26, 2011
Posts: 10

The "null" is the null layout, I believe.

I can't send you any code.

We changed the order of some unrelated libraries in another project and it forced a thorough rebuild. After that rebuild, Matisse seems to be working again. Other developers have run into this problem repeatedly.
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Jun 11, 2012 - 07:26 AM



Joined: Nov 11, 2010
Posts: 2491

ehodges ,

Glad that it is working fine now. I could not replicate the issue at my end with a null layout.

The next time you see the issue, please right click on the "null" element in the Outline view and send us the screenshot of what exactly it is.

Let us know if you have any issues.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits