MyEclipse Forums
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
flawlor
Post subject: VERY Slow Shutdown  PostPosted: Oct 04, 2011 - 08:09 PM
Veteran Member
Veteran Member


Joined: Jul 01, 2006
Posts: 132

Whenver I shut ME (9.1) down it takes about 5 minutes.
This is even longer than it takes to start up.

There are no log entries.

Any idea how to speed this up or find out why?
It is almost as if it is waiting to time out on something.
 
 View user's profile Send private message  
Reply with quote Back to top
support-joy
Post subject:   PostPosted: Oct 05, 2011 - 10:15 PM
Registered Member
Registered Member


Joined: Feb 03, 2009
Posts: 3442

flawlor,

Sorry to hear you are facing a slow shutdown. Could you answer below queries to help me understand your environment -
1. Open MyEclipse IDE, from menu options click on MyEclipse > Installation Summary > Installation Details and copy and paste the same here
2. How did you install MyEclipse ? Meaning using - all-in-one installer / pulse / archived update site on top of eclipse classic
3. Have you added any third party plugins? If yes, please list them here with their update site / download weblink and version

I would recommend you -clean. Please refer - http://www.myeclipseide.com/PNphpBB2-viewtopic-t-10280.html

_________________
Joy
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
flawlor
Post subject:   PostPosted: Oct 06, 2011 - 02:09 PM
Veteran Member
Veteran Member


Joined: Jul 01, 2006
Posts: 132

When I say it takes 5 minutes to shut down I mean the time it
takes the myexlipse.exe and javaw.exe processes to end in the
Windows task manager. The GUI disappears quickly.

I tried -clean and that did not speed things up.

The installation was an all-in-one install.

3rd Party items added:
These were all added from the sites presented by the ME Config Center

- AspectJ Development Tools (AJDT) (w/related) - from Eclipse.org
- Drools - http://download.jboss.org/jbosstools/updates/stable/helios
- FindBugs Plug-in - FindBugs Project
- RTC Plugin:
- Maven Integration for Eclipse (w/related) - maven.org
- Maven Extras - http://m2eclipse.sonatype.org/sites/m2e-extras
- Maven Support for MyEclipse

Installation Details:

*** Date:
Thursday, October 6, 2011 7:53:30 AM CDT

** System properties:
OS=WindowsVista
OS version=6.1.0
Java version=1.6.0_13


*** MyEclipse details:
MyEclipse Enterprise Workbench
Version: 9.1
Build id: 9.1-20110701


*** Eclipse details:
MyEclipse Enterprise Workbench

Version: 9.1
Build id: 9.1-20110701






Eclipse startup command=-os
win32
-ws
win32
-arch
x86_64
-showsplash
-launcher
C:\Users\flawlor\AppData\Local\MyEclipse\MyEclipse 9\myeclipse.exe
-name
Myeclipse
--launcher.library
C:\Users\flawlor\AppData\Local\MyEclipse\MyEclipse 9\../Common/plugins/org.eclipse.equinox.launcher.i18n.win32.win32.x86_64_3.2.0.v201103301700\eclipse_3215.dll
-startup
C:\Users\flawlor\AppData\Local\MyEclipse\MyEclipse 9\../Common/plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-exitdata
2330_5c
-clean
-install
C:\Users\flawlor\AppData\Local\MyEclipse\MyEclipse 9
-configuration
C:\Users\flawlor\AppData\Local\MyEclipse\MyEclipse 9\configuration
-vm
C:\Users\flawlor\AppData\Local\MyEclipse\Common\binary\com.sun.java.jdk.win32.x86_64_1.6.0.013\bin\javaw.exe

------------------------ end Installation Details -----------------------------
 
 View user's profile Send private message  
Reply with quote Back to top
support-joy
Post subject:   PostPosted: Oct 07, 2011 - 09:59 PM
Registered Member
Registered Member


Joined: Feb 03, 2009
Posts: 3442

flawlor,

Thank you for the details. I have escalated your issue to dev team members. We shall investigate and get back to you on this.

_________________
Joy
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Oct 10, 2011 - 11:03 AM



Joined: Mar 09, 2011
Posts: 919

Frank,

I thought it might be related to plug-ins, in some way. However, I couldn't replicate the problem but I only installed some of the plug-ins you mentioned as I couldn't locate others. Also configuring or using the plug-ins in some way might cause some unexpected extensive cleanup.

You said that all of the plug-ins were available from sites presented by the config center. However, I could only find a few of the listed plug-ins without adding update sites. You listed a couple of update sites (for Drools and Maven Extras) but perhaps only hinted at others. The Drools site listed three Drools plug-ins, though the main eclipse site did have a single Drools plug-in; I installed the Drools Core plug-in from the JBoss tools update site. There was no plug-in named "Maven Extras" at the sonatype update site. I couldn't locate an RTC plug-in (though the IBM web site makes it difficult to track these things down). Lastly, Maven Support for MyEclipse comes as standard, so I'm not sure why you listed it as a 3rd party plug-in.

So, could you list the extra plug-ins you installed, again, giving their exact names, the update site (where applicable) and which related plug-ins were installed (where applicable)? Could you also mention why you installed maven plug-ins in addition to the supplied functionality from MyEclipse? When I installed the Maven Integration for Eclipse, I noticed no additional maven capability, beyond what MyEclipse already provided.

Another thing to try is a repair install of MyEclipse. Just run the installer again and at the appropriate point choose to repair the installation. This would clean up your installation, which might help. Plug-in customisations should be retained (that's an option in the repair).

Once you supply the plug-in information, I can try to replicate. Or if you repair your installation and that fixes the problem, let us know.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
flawlor
Post subject:   PostPosted: Oct 10, 2011 - 03:24 PM
Veteran Member
Veteran Member


Joined: Jul 01, 2006
Posts: 132

I used the config center information to try to recollect the plug-ins.
Where is this information available?

It seems like eclipse should track this.
 
 View user's profile Send private message  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Oct 11, 2011 - 04:35 AM



Joined: Mar 09, 2011
Posts: 919

The configuration center will tell you which plug-ins you've installed. Look at the Software tab and the My Software panel. Select a plug-in and click the binoculars icon at the top of that panel to see details, including any optional additional plug-ins that were installed. A complete list of plug-ins is available from Help->About MyEclipse->Installation Details->Plug-ins. The Configuration tab on that screen also shows all the plug-ins (though not in as much detail) and pretty much all other configuration data - that might be useful to attach.

None of these show exactly where the plug-in was installed from, but the name and version should be enough to track it down.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
flawlor
Post subject:   PostPosted: Oct 14, 2011 - 09:59 PM
Veteran Member
Veteran Member


Joined: Jul 01, 2006
Posts: 132

The My Software section has a large list (and did when I installed).

I have no way of knowing what I installed beyond the base install, do I?

I guessed as best I could. If this is important for support then there should be some tracking of it.

There is "Maven Support for MyEclipse" and "Maven Integration for Eclipse" plus "Maven Integration for WTP". I think the RTC plugin had specified these.

----------- Configuration Tab info ----------
[Removed - data is in file attached to later post]
 
 View user's profile Send private message  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Oct 17, 2011 - 11:13 AM



Joined: Mar 09, 2011
Posts: 919

Frank,

Your configuration details didn't all appear in the post. Could you create a file and attach it?

However, one thing I noticed was a vast array of IBM plug-ins, presumably from the RTC plug-in. I don't have Rational Team Concert with which to really check that out but would it be possible for you to uninstall or disable that feature to see if it has an impact?

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
flawlor
Post subject:   PostPosted: Oct 17, 2011 - 04:16 PM
Veteran Member
Veteran Member


Joined: Jul 01, 2006
Posts: 132

Attached a file with the Configuration details.
 
 View user's profile Send private message  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Oct 18, 2011 - 05:53 AM



Joined: Mar 09, 2011
Posts: 919

Thanks for the file, Frank.

Will you be able to test a shutdown without the RTC plug-in?

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
flawlor
Post subject:   PostPosted: Oct 18, 2011 - 01:49 PM
Veteran Member
Veteran Member


Joined: Jul 01, 2006
Posts: 132

Tell me if the following would work:

1) zip my workspace and save it.
2) remove the RTC plugin
3) test shutdown
4) unzip original workspace (I need RTC for my work).

If RTC is the problem then I can pursue getting a fix.
 
 View user's profile Send private message  
Reply with quote Back to top
flawlor
Post subject:   PostPosted: Oct 18, 2011 - 02:02 PM
Veteran Member
Veteran Member


Joined: Jul 01, 2006
Posts: 132

I'm trying to figure out what constitutes "RTC"

I see in My Software an "RTC Plugin" item, but the RTC site also had "Maven integration for Eclipse" (which may be redundant with Maven Support for MyEclips??).

Is there anything else which you noticed?
 
 View user's profile Send private message  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Oct 19, 2011 - 05:11 AM



Joined: Mar 09, 2011
Posts: 919

Frank,

You don't need to worry about your workspace. You can uninstall plug-ins freely and then reinstall them again. It should not affect your workspace as the plug-in is installed into the MyEclipse installation, not the workspace.

I believe the RTC plug-in needs to be told about an RTC server and I wondered if it would be trying to do some cleanup processing between your workspace and the server during shutdown. Maybe some kind of timeout is happening, which can take a long time, especially with retries.

An alternative is to install a new copy of MyEclipse and add the plug-ins you need except RTC, then open your workspace with the new installation of MyEclipse and see if it closes quickly. But it would probably be easier to uninstall the RTC plug-in.

If you're worried about your workspace, you can always take a backup.

I haven't noticed anything else, so far.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
flawlor
Post subject:   PostPosted: May 07, 2012 - 07:33 PM
Veteran Member
Veteran Member


Joined: Jul 01, 2006
Posts: 132

I had moved to using a new workspace (which shuts down quickly), but now I'm back on the one with the slow shutdown.

I noticed when all my windows were closed and I closed ME, it popped up a progress window saying "Saving Workspace" and the sub-message was "Cancel to skip compacting local history". This is where it is spedning so much time.

Why is this taking so long and how can I speed it up.

What are the implications of canceling this?
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits