MyEclipse Forums
This thread has been locked & this forum has been archived.
Please post new topics to Feature Requests
View previous topic Printable version Log in to check your private messages View next topic
Author Message
gme58
Post subject: parameters in a birt report don't work on second refresh  PostPosted: Aug 08, 2011 - 02:07 PM
Registered Member
Registered Member


Joined: Feb 03, 2010
Posts: 34

I have parameters in a Birt report that run fine when I preview the report in eclipse but when i install the application on a websphere 7.0.1.13 server it will only take the parameters on the first try. The second time I try to run the report it reuses the parameters that I previously selected. Any advice would be appreciated.


Thanks
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Aug 11, 2011 - 07:02 AM



Joined: Nov 11, 2010
Posts: 2491

gme58 ,

Sorry for the delayed reply.

1) Which version of MyEclipse are you working with ? Can you share your Build Id from Help > About MyEclipse Enterprise Edition > Build Id ?

2) Can you append _overwrite=true to the url and check if it fixes your issue?

WAS must be caching the parameters.I suggest you also cross post to the Reports/WAS forums for better support.

Let me know how it works for you.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
gme58
Post subject: here is how i solved the issue  PostPosted: Nov 11, 2011 - 08:11 PM
Registered Member
Registered Member


Joined: Feb 03, 2010
Posts: 34

in the web.xml file i added

<context-param>
<description>Overwrite doc</description>
<param-name>BIRT_OVERWRITE_DOCUMENT</param-name>
<param-value>true</param-value>
</context-param>
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Nov 18, 2011 - 10:01 AM



Joined: Nov 11, 2010
Posts: 2491

gme58 ,

Glad that it is working. Thank you posting it. It will surely help other users.
Do let us know if you have any issues.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits