MyEclipse Forums
This thread has been locked & this forum has been archived.
Please post new topics to Java EE Development (EJB, JSP, Struts, XDoclet, etc.)
View previous topic Printable version Log in to check your private messages View next topic
Author Message
ayc868
Post subject: ER Diagram Routing  PostPosted: Dec 06, 2011 - 06:44 PM
Veteran Member
Veteran Member


Joined: Apr 15, 2004
Posts: 182

I can not create/see the Relationship Routing line as on your tutorial.
see only the diagram.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Dec 07, 2011 - 08:51 AM



Joined: Nov 11, 2010
Posts: 2491

ayc868 ,

Sorry that you are seeing this issue with MyEclipse. I could not replicate the issue at my end.

Can you answer some more questions for us ?

1) Can you share the Build ID from Help > About MyEclipse Enterprise Edition > Build ID ?
Also share your Operating System and version details.

2) Clear the contents of the .log file which is located at <workspace dir>/.metadata/.log , replicate the issue and check if there are any errors logged in the .log file. If yes then paste them here for us.

3) Please attach a screenshot of the issue for us to help get a visual.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
ayc868
Post subject:   PostPosted: Dec 07, 2011 - 05:50 PM
Veteran Member
Veteran Member


Joined: Apr 15, 2004
Posts: 182

Version: 9.1
Build id: 9.1-20110701

delete .log , and restart myEclipse without doing any
.log as following
------------------------------------------------

!SESSION 2011-12-07 09:42:36.853 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_13
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.jface 2 0 2011-12-07 09:42:51.139
!MESSAGE Keybinding conflicts occurred. They may interfere with normal accelerator operation.
!SUBENTRY 1 org.eclipse.jface 2 0 2011-12-07 09:42:51.139
!MESSAGE A conflict occurred for SHIFT+DEL:
Binding(SHIFT+DEL,
ParameterizedCommand(Command(org.eclipse.datatools.sqltools.result.removeAllInstances,Remove All Visible Results,
,
Category(org.eclipse.datatools.sqltools.result.category,SQL Results View,null,true),
,
,,true),null),
org.eclipse.ui.defaultAcceleratorConfiguration,
org.eclipse.ui.contexts.window,,,system)
Binding(SHIFT+DEL,
ParameterizedCommand(Command(org.eclipse.ui.edit.cut,Cut,
Cut the selection to the clipboard,
Category(org.eclipse.ui.category.edit,Edit,null,true),
org.eclipse.ui.internal.handlers.WidgetMethodHandler@24df8f,
,,true),null),
org.eclipse.ui.defaultAcceleratorConfiguration,
org.eclipse.ui.contexts.dialogAndWindow,,,system)
Binding(SHIFT+DEL,
ParameterizedCommand(Command(org.topcased.modeler.deleteModelObject,remove from Model,
Allows the user to delete the selected graph element and its associated model element in a Topcased editor.,
Category(org.eclipse.ui.category.edit,Edit,null,true),
,
,,true),null),
org.eclipse.ui.defaultAcceleratorConfiguration,
org.eclipse.ui.contexts.window,,,system)

!ENTRY com.genuitec.eclipse.core.common 1 0 2011-12-07 09:43:00.593
!MESSAGE ClasspathContainer requery for classpath-string: com.genuitec.eclipse.ws

!ENTRY org.eclipse.osgi 2 0 2011-12-07 09:43:11.152
!MESSAGE While loading class "org.eclipse.wst.jsdt.internal.core.JavaModelManager$16", thread "Thread[Worker-6,5,main]" timed out waiting (5000ms) for thread "Thread[Worker-0,5,main]" to finish starting bundle "org.eclipse.wst.jsdt.core_1.1.2.me201106211924 [899]". To avoid deadlock, thread "Thread[Worker-6,5,main]" is proceeding but "org.eclipse.wst.jsdt.internal.core.JavaModelManager$16" may not be fully initialized.
!STACK 0
org.osgi.framework.BundleException: State change in progress for bundle "reference:file:/C:/Users/acheng/AppData/Local/MyEclipse/Common/plugins/org.eclipse.wst.jsdt.core_1.1.2.me201106211924.jar" by thread "Worker-0".
at org.eclipse.osgi.framework.internal.core.AbstractBundle.beginStateChange(AbstractBundle.java:1077)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:282)
at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:417)
at org.eclipse.osgi.internal.loader.BundleLoader.setLazyTrigger(BundleLoader.java:265)
at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:106)
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:453)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:216)
at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:393)
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:469)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:422)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
at org.eclipse.wst.jsdt.internal.core.JavaModelManager$15.run(JavaModelManager.java:4182)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
Caused by: org.eclipse.osgi.framework.internal.core.AbstractBundle$BundleStatusException
... 16 more
Root exception:
org.eclipse.osgi.framework.internal.core.AbstractBundle$BundleStatusException
at org.eclipse.osgi.framework.internal.core.AbstractBundle.beginStateChange(AbstractBundle.java:1077)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:282)
at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:417)
at org.eclipse.osgi.internal.loader.BundleLoader.setLazyTrigger(BundleLoader.java:265)
at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:106)
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:453)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:216)
at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:393)
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:469)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:422)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
at org.eclipse.wst.jsdt.internal.core.JavaModelManager$15.run(JavaModelManager.java:4182)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Dec 08, 2011 - 09:24 AM



Joined: Mar 09, 2011
Posts: 916

ayc868,

From your screenshot, it appears that none of your tables have foreign keys. It is the foreign keys that define a relationship in the database.

If your tables do have foreign keys, could you please reproduce the problem with just two tables that have a relationship between them? If you reproduce the problem, please provide the DDL for the two tables so that we can try to recreate the problem here. Also, please state the database that you are using and whether it is local or remote.

From your log file, it looks like you are running on Windows XP, is that correct? If so, are you at SP3?

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
ayc868
Post subject:   PostPosted: Dec 08, 2011 - 06:04 PM
Veteran Member
Veteran Member


Joined: Apr 15, 2004
Posts: 182

It is Window 7.

there is plenty of foreign keys. eg. ap-link_id etc..
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Dec 08, 2011 - 10:15 PM



Joined: Mar 09, 2011
Posts: 916

ayc868,

Thanks for that. So you are running the 32 bit version of MyEclipse on Windows 7, is that right? Also, please provide the information I asked for in my last post, if you wish us to investigate this issue.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
ayc868
Post subject:   PostPosted: Dec 09, 2011 - 07:33 PM
Veteran Member
Veteran Member


Joined: Apr 15, 2004
Posts: 182

I reinstalled with myeclipse 10 32 bit on 64 bit window 7
However, I can not see log this time, where is it?
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Dec 12, 2011 - 09:23 AM



Joined: Mar 09, 2011
Posts: 916

ayc868,

If you're referring to the workspace log, it will still be in the .metadata folder under the workspace folder. If it is not there, it means that there have been no errors or warnings to report since you last cleared the log (or since you created the workspace, if you've never cleared the log).

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
ayc868
Post subject:   PostPosted: Dec 12, 2011 - 06:07 PM
Veteran Member
Veteran Member


Joined: Apr 15, 2004
Posts: 182

now I see error when I start Myeclipse

!ENTRY org.eclipse.jface 4 0 2011-12-12 10:01:51.025
!MESSAGE Unhandled event loop exception during blocked modal context.
!STACK 0
org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NullPointerException)
at org.eclipse.swt.SWT.error(SWT.java:4282)
at org.eclipse.swt.SWT.error(SWT.java:4197)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:138)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4140)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3757)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.block(ModalContext.java:173)
at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:388)
at org.eclipse.jface.dialogs.ProgressMonitorDialog.run(ProgressMonitorDialog.java:507)
at org.eclipse.ui.internal.progress.ProgressMonitorJobsDialog.run(ProgressMonitorJobsDialog.java:275)
at org.eclipse.ui.internal.ide.application.IDEWorkbenchAdvisor.disconnectFromWorkspace(IDEWorkbenchAdvisor.java:515)
at org.eclipse.ui.internal.ide.application.IDEWorkbenchAdvisor.postShutdown(IDEWorkbenchAdvisor.java:348)
at org.eclipse.ui.internal.Workbench.shutdown(Workbench.java:3023)
at org.eclipse.ui.internal.Workbench.busyClose(Workbench.java:1118)
at org.eclipse.ui.internal.Workbench.access$15(Workbench.java:1035)
at org.eclipse.ui.internal.Workbench$25.run(Workbench.java:1279)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
at org.eclipse.ui.internal.Workbench.close(Workbench.java:1277)
at org.eclipse.ui.internal.Workbench.close(Workbench.java:1249)
at org.eclipse.ui.internal.WorkbenchWindow.busyClose(WorkbenchWindow.java:727)
at org.eclipse.ui.internal.WorkbenchWindow.access$0(WorkbenchWindow.java:715)
at org.eclipse.ui.internal.WorkbenchWindow$5.run(WorkbenchWindow.java:860)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
at org.eclipse.ui.internal.WorkbenchWindow.close(WorkbenchWindow.java:858)
at org.eclipse.jface.window.Window.handleShellCloseEvent(Window.java:741)
at org.eclipse.jface.window.Window$3.shellClosed(Window.java:687)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:98)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1077)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1062)
at org.eclipse.swt.widgets.Decorations.closeWidget(Decorations.java:308)
at org.eclipse.swt.widgets.Decorations.WM_CLOSE(Decorations.java:1677)
at org.eclipse.swt.widgets.Control.windowProc(Control.java:4530)
at org.eclipse.swt.widgets.Canvas.windowProc(Canvas.java:341)
at org.eclipse.swt.widgets.Decorations.windowProc(Decorations.java:1610)
at org.eclipse.swt.widgets.Shell.windowProc(Shell.java:2061)
at org.eclipse.swt.widgets.Display.windowProc(Display.java:4972)
at org.eclipse.swt.internal.win32.OS.DefWindowProcW(Native Method)
at org.eclipse.swt.internal.win32.OS.DefWindowProc(OS.java:2525)
at org.eclipse.swt.widgets.Shell.callWindowProc(Shell.java:498)
at org.eclipse.swt.widgets.Control.windowProc(Control.java:4623)
at org.eclipse.swt.widgets.Canvas.windowProc(Canvas.java:341)
at org.eclipse.swt.widgets.Decorations.windowProc(Decorations.java:1610)
at org.eclipse.swt.widgets.Shell.windowProc(Shell.java:2061)
at org.eclipse.swt.widgets.Display.windowProc(Display.java:4972)
at org.eclipse.swt.internal.win32.OS.DefWindowProcW(Native Method)
at org.eclipse.swt.internal.win32.OS.DefWindowProc(OS.java:2525)
at org.eclipse.swt.widgets.Shell.callWindowProc(Shell.java:498)
at org.eclipse.swt.widgets.Control.windowProc(Control.java:4623)
at org.eclipse.swt.widgets.Canvas.windowProc(Canvas.java:341)
at org.eclipse.swt.widgets.Decorations.windowProc(Decorations.java:1610)
at org.eclipse.swt.widgets.Shell.windowProc(Shell.java:2061)
at org.eclipse.swt.widgets.Display.windowProc(Display.java:4972)
at org.eclipse.swt.internal.win32.OS.DispatchMessageW(Native Method)
at org.eclipse.swt.internal.win32.OS.DispatchMessage(OS.java:2530)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3752)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2696)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2660)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2494)
at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:674)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:667)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
Caused by: java.lang.NullPointerException
at com.genuitec.pulse.client.targetcfg.collab.ui.internal.InformAboutDashboardStartup$ShowDashboardNotificationDialog.run(Unknown Source)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
... 73 more
!SESSION 2011-12-12 10:02:35.654 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_13
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.mylyn.tasks.ui 2 0 2011-12-12 10:03:12.709
!MESSAGE No search provider was registed. Tasks search is not available.

!ENTRY org.eclipse.jface 2 0 2011-12-12 10:03:44.437
!MESSAGE Keybinding conflicts occurred. They may interfere with normal accelerator operation.
!SUBENTRY 1 org.eclipse.jface 2 0 2011-12-12 10:03:44.437
!MESSAGE A conflict occurred for CTRL+F9:
Binding(CTRL+F9,
ParameterizedCommand(Command(org.eclipse.mylyn.tasks.ui.command.activateTask,Activate Task,
,
Category(org.eclipse.ui.category.navigate,Navigate,null,true),
,
,,true),null),
org.eclipse.ui.defaultAcceleratorConfiguration,
org.eclipse.ui.contexts.window,,,system)
Binding(CTRL+F9,
ParameterizedCommand(Command(RunSQLAction,Run SQL,
Run SQL,
Category(org.eclipse.ui.category.edit,Edit,null,true),
,
,,true),null),
org.eclipse.ui.defaultAcceleratorConfiguration,
org.eclipse.ui.contexts.window,,,system)

!ENTRY com.genuitec.eclipse.core.common 1 0 2011-12-12 10:03:47.198
!MESSAGE ClasspathContainer requery for classpath-string: com.genuitec.eclipse.lib.spring2
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
ayc868
Post subject:   PostPosted: Dec 13, 2011 - 01:55 AM
Veteran Member
Veteran Member


Joined: Apr 15, 2004
Posts: 182

if select java 1.5 when create web project , the problem will not show up
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Dec 13, 2011 - 04:46 AM



Joined: Mar 09, 2011
Posts: 916

ayc868,

We'd like to help sort out your problems with MyEclipse but the problem you report seems to change with every post.

I'm not sure, now what problems are outstanding. Your latest post appears to suggest that the problem occurs when creating web projects, under some circumstances but your previous post seemed to be about startup problems.

If you are having different problems, it would be useful to create separate forum topics for them. This topic is about "ER Diagram Routing" but you've mentioned problems that don't seem to be about that topic.

When creating a new topic for a problem, please give as much detail as possible about the problem and the steps to recreate it. It would also help us if you cleared your log file, recreated the problem and then attached the full log file.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
ayc868
Post subject:   PostPosted: Dec 13, 2011 - 06:32 PM
Veteran Member
Veteran Member


Joined: Apr 15, 2004
Posts: 182

let's focus the ER Diagram Routing

Why it do not show up the link? - even I upgrade to MyEclipse 10.

By the way, why it take so long to response - response once a day
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Dec 15, 2011 - 05:53 AM



Joined: Mar 09, 2011
Posts: 916

ayc868,

OK, concentrating on the UML problem, please provide the information requested in this post. For you convenience, I repeat the relevant piece of the post below:
Quote:
If your tables do have foreign keys, could you please reproduce the problem with just two tables that have a relationship between them? If you reproduce the problem, please provide the DDL for the two tables so that we can try to recreate the problem here. Also, please state the database that you are using and whether it is local or remote.

From your log file, it looks like you are running on Windows XP, is that correct? If so, are you at SP3?


If you can't reproduce the problem with two tables, you can provide the DDL for all of the tables. You can attach files here using the "Add and Attachment" section below the area you write your reply.

Sorry that you're not getting responses as quickly as you'd like. We have on-line support staff in various locations and unfortunately, their work times do not always overlap with the work times of our users.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits