MyEclipse Forums
This thread has been locked & this forum has been archived.
Please post new topics to Off Topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
Aditya04
Post subject: VSS AND MYECLIPSE  PostPosted: May 08, 2007 - 03:56 PM



Joined: Dec 05, 2006
Posts: 21

I have Myeclipse 5.1 and I want it to configure with Microsoft VisualSourceSafe 6.0 .How do i do that and what do i need to have.What plugins and how do we extract those plugins into Myeclipse IDE.

YOUR PROMPT REPLY WILL BE APPRECIATED...

tHANKS,
Meena
 
 View user's profile Send private message  
Reply with quote Back to top
Aditya04
Post subject: RE: VSS AND MYECLIPSE  PostPosted: May 08, 2007 - 05:27 PM



Joined: Dec 05, 2006
Posts: 21

With coontinution..I don't want to use CVS ...i want VSS

Please reply...i know you can't speak on VSS but please let me know..what plugins and all i can use to make my development area work....
 
 View user's profile Send private message  
Reply with quote Back to top
support-scott
Post subject: RE: VSS AND MYECLIPSE  PostPosted: May 15, 2007 - 01:54 AM
Moderator
Moderator


Joined: May 06, 2003
Posts: 6761

There is a VSS plugin for Eclipse here: http://sourceforge.net/projects/vssplugin/

That should get you the connection to SourceSafe that you're looking for.

_________________
--Scott
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
joehuangathome
Post subject: VSS and MyEclipse  PostPosted: Dec 21, 2011 - 01:49 PM



Joined: May 08, 2009
Posts: 37

How do I install vss for ME10.0? I put an unzipped vssplugin folder into dropIn folder in ME10 but it did not work.

Joe
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Dec 27, 2011 - 05:03 AM



Joined: Nov 11, 2010
Posts: 2608

joehuangathome,

Sorry that you are seeing this issue.

Can you answer some more questions for us ?

1) Can you share your Build ID from Help > About MyEclipse Enterprise Workbench > Build ID ? Also share your OS and version details.

2) Is your MyEclipse installation a 32 bit or 64 bit one ?

3) Can you clarify if the plugin version is compatible with Eclipse 3.7 which is the base Eclipse version for MyEclipse 10 ? Also share the link from where you have downloaded the plugin.

4) Please make sure you copy the relevant plugins/features to [MyEclipse directory]/dropins. Make sure you have folder named Plugins and Features under dropins(if not already present, please create these folders). You need to copy plugins and features to the relevant folder. Also recheck if you see the plugin in the installed plugins list at Help > About MyEclipse Enterprise Workbench > Installation Details > Plugins.

5) Also let us know what exact issue you are seeing after dropping the unzipped file into the Dropins directory.

6) There might be issues in getting the VSS plugin work in Eclipse 3.7. Take a look at this link :
http://sourceforge.net/tracker/index.php?func=detail&aid=3340114&group_id=54205&atid=473011

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
joehuangathome
Post subject:   PostPosted: Dec 29, 2011 - 01:43 PM



Joined: May 08, 2009
Posts: 37

support-swapna wrote:
joehuangathome,

Sorry that you are seeing this issue.

Can you answer some more questions for us ?

1) Can you share your Build ID from Help > About MyEclipse Enterprise Workbench > Build ID ? Also share your OS and version details.
Build id: 10.0-20111028. OS: XP Professional2) Is your MyEclipse installation a 32 bit or 64 bit one ?
323) Can you clarify if the plugin version is compatible with Eclipse 3.7 which is the base Eclipse version for MyEclipse 10 ? Also share the link from where you have downloaded the plugin.
I used to have base Eclipse but I was not able to find Eclipse3.7 on my machine after downloading MyEclipse104) Please make sure you copy the relevant plugins/features to [MyEclipse directory]/dropins. Make sure you have folder named Plugins and Features under dropins(if not already present, please create these folders). You need to copy plugins and features to the relevant folder. Also recheck if you see the plugin in the installed plugins list at Help > About MyEclipse Enterprise Workbench > Installation Details > Plugins.
I rechecked but did not find vss under Plugins tab. And I got a 'Fetching Elements' error.
5) Also let us know what exact issue you are seeing after dropping the unzipped file into the Dropins directory.
The vss menu used to appear on my previous MyEclipse version failed to appear in MyEclipse 10
6) There might be issues in getting the VSS plugin work in Eclipse 3.7. Take a look at this link :
http://sourceforge.net/tracker/index.php?func=detail&aid=3340114&group_id=54205&atid=473011
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Jan 02, 2012 - 11:19 AM



Joined: Nov 11, 2010
Posts: 2608

joehuangathome,

1) Did you install MyEclipse 10 on top of base Eclipse 3.7 using the update site ?

2) If you can get the version of VSS which works in Eclipse 3.7 then try it on MyEclipse 10. If you have issues getting vss plugin work on Eclipse 3.7 then post on Eclipse forums for better support.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
joehuangathome
Post subject:   PostPosted: Jan 03, 2012 - 09:57 PM



Joined: May 08, 2009
Posts: 37

support-swapna wrote:
joehuangathome,

1) Did you install MyEclipse 10 on top of base Eclipse 3.7 using the update site ?
No. I downloaded myeclipse-10.0-offline-installer-windows.exe
2) If you can get the version of VSS which works in Eclipse 3.7 then try it on MyEclipse 10. If you have issues getting vss plugin work on Eclipse 3.7 then post on Eclipse forums for better support.

I used to drop vss plug in Eclipse3.X plugin folders. But I cannot find Eclipse3.7 on my PC. Is 3.7 a must?

Thanks,

Joe
 
 View user's profile Send private message  
Reply with quote Back to top
AtmelCorp
Post subject:   PostPosted: Jan 06, 2012 - 09:34 AM
Registered Member
Registered Member


Joined: Jan 06, 2012
Posts: 5

Hi,

I am also interested in a VSS plugin which work fine with MyEclipse10 . Do you get some result about that ?

Thanks for your Help
 
 View user's profile Send private message  
Reply with quote Back to top
joehuangathome
Post subject: VSS PlugIn for MyEclipse10.0 worked!!  PostPosted: Jan 06, 2012 - 05:44 PM



Joined: May 08, 2009
Posts: 37

AtmelCorp wrote:
Hi,

I am also interested in a VSS plugin which work fine with MyEclipse10 . Do you get some result about that ?

Thanks for your Help


AtmelCorp,
I have found why it did not work before. Yes, using MyEclipse10's /dropins folder IS the correct approach. VSS has been too old that nobody cares about making an update site for it at sourceforge.com. The bad thing about the org.vssplugin_1.6.1 zip file is that, when unzipped, it will create a redundant folder structure like this:
org.vssplugin_1.6.1\org.vssplugin_1.6.1
So what you need to do is to only copy the inner folder(do not drop the zip directly into your ME dropins folder) and paste the copied folder into MyEclipse10.0's dropins folder and it will work like a charm!!

Please let me know if it still does not work for you.

Joe
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Jan 10, 2012 - 05:45 AM



Joined: Nov 11, 2010
Posts: 2608

joehuangathome,

Thank you for posting the steps to install VSS to MyEclipse. It will certainly help other users.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits