MyEclipse Forums
This thread has been locked & this forum has been archived.
Please post new topics to Java EE Development (EJB, JSP, Struts, XDoclet, etc.)
View previous topic Printable version Log in to check your private messages View next topic
Author Message
gmumford@optonline.net
Post subject: basic web service startup & access error(s)  PostPosted: Feb 03, 2012 - 10:42 PM
Registered Member
Registered Member


Joined: May 31, 2007
Posts: 3

Created a basic web service and client - Started the service under tomcat.
BTW : We're Running jre 1.6 - web service says that it needs JRE 1.5..... (Is there a work around.)

ON starting the web service :

com.sun.jersey.api.container.ContainerException: The ResourceConfig instance does not contain any root resource classes.
at com.sun.jersey.server.impl.application.RootResourceUriRules.<init>(RootResourceUriRules.java:103)
at com.sun.jersey.server.impl.application.WebApplicationImpl._initiate(WebApplicationImpl.java:1182)
at com.sun.jersey.server.impl.application.WebApplicationImpl.access$600(WebApplicationImpl.java:161)
at com.sun.jersey.server.impl.application.WebApplicationImpl$12.f(WebApplicationImpl.java:698)


Accessed the web service from the client and got the following :

Exception in thread "main" com.sun.xml.ws.client.ClientTransportException: HTTP Status-Code 404: Not Found - /fvisbt_w2/TestWSPort
at com.sun.xml.ws.transport.http.client.HttpClientTransport.checkResponseCode(HttpClientTransport.java:219)
at com.sun.xml.ws.transport.http.client.HttpTransportPipe.process(HttpTransportPipe.java:149)
at com.sun.xml.xwss.XWSSClientPipe.process(XWSSClientPipe.java:118)
at com.sun.xml.ws.api.pipe.helper.PipeAdapter.processRequest(PipeAdapter.java:115)
at com.sun.xml.ws.api.pipe.Fiber.__doRun(Fiber.java:595)
at com.sun.xml.ws.api.pipe.Fiber._doRun(Fiber.java:554)
at com.sun.xml.ws.api.pipe.Fiber.doRun(Fiber.java:539)
at com.sun.xml.ws.api.pipe.Fiber.runSync(Fiber.java:436)
at com.sun.xml.ws.client.Stub.process(Stub.java:248)
at com.sun.xml.ws.client.sei.SEIStub.doProcess(SEIStub.java:135)
at com.sun.xml.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:109)
at com.sun.xml.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:89)
at com.sun.xml.ws.client.sei.SEIStub.invoke(SEIStub.java:118)
at $Proxy34.getData(Unknown Source)
at com.idc.fvisbt.test.WebServiceClient.main(WebServiceClient.java:13)

Suggestions /
Let me know if you need more info.
Thx
G
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Feb 06, 2012 - 08:35 AM



Joined: Nov 11, 2010
Posts: 2491

gmumford,

Sorry that you are seeing this issue with MyEclipse.

Can you answer some more questions for us ?

1) Can you share the Build ID from Help > About MyEclipse Enterprise Edition > Build ID?

2) Are you deploying to MyEclipse Tomcat or external tomcat ? Can you check if you see the same issue when publishing to external tomcat ?

3) Can you build the project first before publishing it and check if the issue persists?

4) Please list out exact steps you followed for us to be able to replicate the issue at our end.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
gmumford@optonline.net
Post subject:   PostPosted: Feb 06, 2012 - 02:12 PM
Registered Member
Registered Member


Joined: May 31, 2007
Posts: 3

---- Build info :
MyEclipse Enterprise Workbench

Version: 9.1
Build id: 9.1-20110701

(c) Copyright Genuitec, L.L.C. 2000-2011. All rights reserved.
Visit http://www.myeclipseide.com/

This product includes software developed by the following
Eclipse Foundation http://www.eclipse.org/
Apache Software Foundation http://www.apache.org/

---- Yes, deploying to the internal tomcat.

----- Project builds properly with 1 warming :
Description Resource Path Location Type
No grammar constraints (DTD or XML schema) detected for the document. sun-jaxws.xml /fvisbt_w2/WebRoot/WEB-INF line 1 XML Problem


Followed the tutorial :
http://www.myeclipseide.com/documentation/quickstarts/webservices_jaxws/

Jaxws 2.1 libraries added....

Bottom up web service creation.
Run as Myeclipse Server application

Web service Client creation.
Run as Java application

Hope that gives you what you need....
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Feb 07, 2012 - 09:30 AM



Joined: Nov 11, 2010
Posts: 2491

gmumford,

Thank you for the details. I could not replicate the issue at my end following the tutorial.

1) Can you share the installation details from MyEclipse > Installation Summary > Installation Details ? Paste them here for us.

2) Can you clarify if you tried to follow the REST tutorial, instead, given the error message (it refers to jersey, which is Sun's reference implementation for REST) ?

3) Did you deviate from the tutorial at any point ? If yes then please let us know what exactly you did.

4) Take a look at this thread which discusses the same problem :
http://www.coderanch.com/t/465479/Web-Services/java/Deployment-Client-Simple-Jax-ws

If you have an external Tomcat, can you please deploy the project to it and check if you still see the issue ?

5) For the JRE 1.5 issue, the work around is to remove the Java EE 6 libraries from the project > Build Path > Libraries and add Java EE 5 libraries from Add Library > MyEclipse Libraries. Close and Open the project.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits