MyEclipse Forums
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
ethutch
Post subject: ME4S Mylyn Install problems  PostPosted: Feb 03, 2012 - 07:56 PM
Registered Member
Registered Member


Joined: Jul 03, 2008
Posts: 38

I am opening a new thread so my messages won't be mixed with the other customer's. As I said it that thread Mylyn has never installed remotely cleanly in any ME version back at least to 6. When I tried to add it this time it cause the initialization of my JPA facet to abort and made the installation basically unusable.

I deleted everything in /Program Files/Genute and installed ONLY ME4S and then added ONLY the Mylyn stuff. I did not pick all the portions because I believe they are unnecessary. Please tell me if this is not true.

Once Mylyn is installed I get the "Detected dependency conflicts in updates. No actionable updates check log for details. THIS message is ALWAYS with me. I will refrain from cursing about Pulse but Every installation of ME has always ended up with this in very short order. The "workaround" I was given to run Pulse stand alone is completely unacceptable and unusable. Basically once it starts doing this I do not update any plug-ins until the next release of ME. Then it will work for a while, until it stops again.

Anyhow back on subject I do not know to which "log" it is referring.but I attached the Log from the errors tab.


Below are my Installation Details:
MyEclipse for Spring 10 (Profile) 2.0.0.0000000002 com.poweredbypulse.profile-1059398-rmb-3127815 null
Desktop Utilities for MyEclipse 10.0.0.me201110311918 com.genuitec.myeclipse.desktop.feature.group Genuitec, LLC
Eclipse CVS Client 1.3.100.v20110520-0800-7B78FHk8sF7BB7SBB5EYD5 org.eclipse.cvs.feature.group Eclipse.org
Eclipse Java Development Tools 3.7.0.v20110520-0800-7z8gFchFMTdFYKuLqBLqRja9B15B org.eclipse.jdt.feature.group Eclipse.org
Eclipse Platform 3.7.0.v20110530-9gF7UHNFFt4cwE-pkZDJ7oz-mj4OSEIlu9SEv0f org.eclipse.platform.feature.group Eclipse.org
Eclipse Plug-in Development Environment 3.7.0.v20110504-0800-7b7qFVpFEx2XnmYtj_9RfO7 org.eclipse.pde.feature.group Eclipse.org
Eclipse RCP 3.7.0.v20110216-9DB5Fm1FpBGy_AaVz-mFamgY org.eclipse.rcp.feature.group Eclipse.org
Geronimo Support for MyEclipse 10.0.0.me201110311918 com.genuitec.myeclipse.geronimo.feature.group Genuitec, LLC
Glassfish Support for MyEclipse 10.0.0.me201110311918 com.genuitec.myeclipse.glassfish.feature.group Genuitec, LLC
Hibernate / JPA Support for MyEclipse 10.0.0.me201110311918 com.genuitec.myeclipse.persistence.feature.group Genuitec, LLC
ICEfaces AJAX and Java EE Tooling for MyEclipse 10.0.0.me201110311918 com.genuitec.myeclipse.icefaces.feature.feature.group Genuitec, LLC / ICEsoft Technologies, Inc.
Image Editor for MyEclipse 10.0.0.me201110311918 com.genuitec.myeclipse.imageeditor.feature.group Genuitec, LLC
JavaServer Faces Support for MyEclipse 10.0.0.me201110311918 com.genuitec.myeclipse.jsf.feature.group Genuitec, LLC
JBoss Support for MyEclipse 10.0.0.me201110311918 com.genuitec.myeclipse.jboss.feature.group Genuitec, LLC
Jetty Support for MyEclipse 10.0.0.me201110311918 com.genuitec.myeclipse.jetty.feature.group Genuitec, LLC
JOnAS Support for MyEclipse 10.0.0.me201110311918 com.genuitec.myeclipse.jonas.feature.group Genuitec, LLC
JRun Support for MyEclipse 10.0.0.me201110311918 com.genuitec.myeclipse.jrun.feature.group Genuitec, LLC
Maven Support for MyEclipse 10.0.0.me201110311918 com.genuitec.myeclipse.maven.feature.group Genuitec, LLC
MyEclipse Database Tools 10.0.0.me201110311918 com.genuitec.myeclipse.database.feature.group Genuitec, LLC
MyEclipse Enterprise Workbench 10.0.0.me201110311918 com.genuitec.myeclipse.enterprise.workbench.feature.group Genuitec, LLC
MyEclipse for Spring 10.0.0.20111114175256 pulse.com.skyway.myeclipseforspring.product.group null
MyEclipse for Spring 10.0.0.201111091436 com.skyway.myeclipseforspring.feature.feature.group Skyway Software, Inc.
MyEclipse IE JavaScript Debugger 10.0.0.me201110311918 com.genuitec.myeclipse.iedebugger.feature.group Genuitec, LLC
MyEclipse Reports 10.0.0.me201110311918 com.genuitec.myeclipse.reports.feature.group Genuitec, LLC
MyEclipse Required Components 10.0.0.me201110311918 com.genuitec.myeclipse.editor.feature.group Genuitec, LLC
MyEclipse UML 1 / 2 Visual Design Tools 10.0.0.me201110311918 com.genuitec.myeclipse.uml2.feature.group Genuitec, LLC
MyEclipse Visual Swing Designer 10.0.0.me201110311918 com.genuitec.myeclipse.matisse.feature.group Genuitec, LLC
MyEclipse VisualVM Profiler 10.0.0.me201110311918 com.genuitec.myeclipse.visualvm.feature.group Genuitec, LLC
MyEclipse VisualVM Profiler Server Support 10.0.0.me201110311918 com.genuitec.myeclipse.visualvm.server.feature.group Genuitec, LLC
Mylyn Context Connector: Eclipse IDE 3.6.4.v20111118-0100 org.eclipse.mylyn.ide_feature.feature.group Eclipse Mylyn
Mylyn Context Connector: Java Development 3.6.4.v20111118-0100 org.eclipse.mylyn.java_feature.feature.group Eclipse Mylyn
Mylyn Task List 3.6.4.v20111118-0100 org.eclipse.mylyn_feature.feature.group Eclipse Mylyn
Mylyn Task-Focused Interface 3.6.4.v20111118-0100 org.eclipse.mylyn.context_feature.feature.group Eclipse Mylyn
Mylyn WikiText 1.5.4.v20111118-0100 org.eclipse.mylyn.wikitext_feature.feature.group Eclipse Mylyn
Oracle Server Support for MyEclipse 10.0.0.me201110311918 com.genuitec.myeclipse.oracle.feature.group Genuitec, LLC
Orion Support for MyEclipse 10.0.0.me201110311918 com.genuitec.myeclipse.orion.feature.group Genuitec, LLC
Pulse Client Services with Drop-ins Support (Eclipse 3.7) 4.0.0.v201106222000 com.genuitec.pulse2.client.targetcfg.dropins.e37.feature.group Genuitec, LLC
Resin Support for MyEclipse 10.0.0.me201110311918 com.genuitec.myeclipse.resin.feature.group Genuitec, LLC
Spring Support for MyEclipse 10.0.0.me201110311918 com.genuitec.myeclipse.spring.feature.group Genuitec, LLC
Struts Support for MyEclipse 10.0.0.me201110311918 com.genuitec.myeclipse.struts.feature.group Genuitec, LLC
Sun App Server Support for MyEclipse 10.0.0.me201110311918 com.genuitec.myeclipse.sun.feature.group Genuitec, LLC
tc Server Support for MyEclipse 10.0.0.me201110311918 com.genuitec.myeclipse.tcserver.feature.group Genuitec, LLC
Tomcat Support for MyEclipse 10.0.0.me201110311918 com.genuitec.myeclipse.tomcat.feature.group Genuitec, LLC
Web Services Support for MyEclipse 10.0.0.me201110311918 com.genuitec.myeclipse.ws.feature.group Genuitec, LLC
WebLogic Support for MyEclipse 10.0.0.me201110311918 com.genuitec.myeclipse.weblogic.feature.group Genuitec, LLC
WebSphere Support for MyEclipse 10.0.0.me201110311918 com.genuitec.myeclipse.websphere.feature.group Genuitec, LLC
 
 View user's profile Send private message  
Reply with quote Back to top
ethutch
Post subject:   PostPosted: Feb 03, 2012 - 08:04 PM
Registered Member
Registered Member


Joined: Jul 03, 2008
Posts: 38

Apparently the web site didn't like the .log extension. So uploading again with a .txt.
 
 View user's profile Send private message  
Reply with quote Back to top
Support-Brian
Post subject:   PostPosted: Feb 06, 2012 - 10:54 PM
Moderator
Moderator


Joined: Aug 21, 2004
Posts: 2659

ethutch,

Can you tell me exactly how you installed Mylyn? Did you install it from our Pulse catalog or did you use their update site directly? (If so, please give me the URL). Choosing to only install the base Mylyn bit should be just fine.

Re: dependency conflicts in updates - the data unfortunately goes into a different log file; and I agree that message needs to be improved. It is odd however, to reach this state after Mylyn has been successfully installed; my team has tried this and has had no problems.

Our MyEclipse Dashboard provides one Mylyn integration component which is not installed by default - it is called "SpringIDE for MyEclipse - Mylyn Support" - did you install this?

For now, let me look at your configuration and see where the conflict is, please upload a support bundle which will contain the necessary log files and other profile configuration data. Include a link to this thread in the upload form so we can track it back to this post. To create a bundle, follow these steps:

1) Go to Help > MyEclipse Configuration Center
2) Under *About This Profile* section on the bottom left, there is an icon to "create support bundle" (shaped like a life preserver) . Click this to create the bundle, it will guide you through the creation and upload process.

_________________
Brian
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
ethutch
Post subject:   PostPosted: Feb 07, 2012 - 04:09 PM
Registered Member
Registered Member


Joined: Jul 03, 2008
Posts: 38

Brian,

Thanks A LOT for looking into this.

I installed the MyEclipse choice for Mylyn. I only use update URLs as a last resort because they often are "not completely compatible" with ME. I did not see "SpringIDE for MyEclipse - Mylyn Support" so didn't install that. Actually as is always the case with any Eclipse plug-in it is not entirely obvious which pieces are strictly required vs need to have vs nice to have vs do not want. So if I need to install more or less packages that's a super easy answer.

The requested support bundle is uploaded:
SuppportBundle-2012--02-07-10:54:57.zip
Bundle ID: 5686-yqe-9854
 
 View user's profile Send private message  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Feb 08, 2012 - 09:56 AM



Joined: Mar 09, 2011
Posts: 948

ethutch,

Thanks for sending the bundle. I couldn't find any information about your JPA facet initialization problem in the bundle or in the log file you attached here. Could you describe the steps leading up to that problem? If you have a workspace .log file that shows the problem that would be great (with the time that the error occurred). A screenshot showing the problem might also help.

I had no problem installing Mylyn on MyEclipse for Spring 10.0, under Windows XP, though it wasn't clear which of the related software you installed. I installed two mylyn context connectors (Eclipse IDE and Java Development), plus team support, bugzilla task connector and wikitext, as, from some of the information in the bundle, it seemed as though you had installed those. I'm not a mylyn user so I'm not sure which features you need for your requirements.

I have a web project with a JPA facet, in the workspace, but couldn't find any problems, after several restarts and adding a couple of local mylyn tasks.

Hopefully, with extra information, we can track this down.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
ethutch
Post subject:   PostPosted: Feb 17, 2012 - 07:25 PM
Registered Member
Registered Member


Joined: Jul 03, 2008
Posts: 38

After much more fighting with this I learned that I lied - although not intentionally. I actually did install subclipse first. I hadn't taken that into account because I need it to get the code of course.

BUT, it turns out that subclipse has a Mylyn Integration that I believe I was installing just because I never really paid close enough attention to the components. I'm not sure what that does actually, but by leaving Subclipse Integration for Myln and SVNKit client adapter uninstalled my dependency conflict is now solved.

I don't think the SVNKit Client had anything to do with it, but for future readers I mention it here.

So this problem is solved by about 85% user error.

Thanks for your help
 
 View user's profile Send private message  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Feb 20, 2012 - 03:10 AM



Joined: Mar 09, 2011
Posts: 948

ethutch,

Thanks for following up with us and providing information that may help others. I'm glad it's working for you now.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits