MyEclipse Forums
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
anilvjava
Post subject: Error while creating new Java Maven Project  PostPosted: Mar 18, 2012 - 11:26 AM



Joined: Mar 18, 2012
Posts: 1

Hi,

I have the issue while creating a Maven project through MyEclipse.

Prompted Error is :

Unable to create project from archetype [org.apache.maven.archetypes:maven-archetype-quickstart:RELEASE -> http://repo1.maven.org/maven2]
Failed to generate project from old archetype

Here is the log:


3/18/12 2:12:36 PM GST: Unable to update index for central|http://repo1.maven.org/maven2
3/18/12 2:12:34 PM GST: Updating index central|http://repo1.maven.org/maven2
3/18/12 2:12:36 PM GST: Unable to download Repository[d9d714e11cb097b3ffcec91cccc65d3e|http://repo1.maven.org/maven2/.index]/nexus-maven-repository-index.properties: java.net.ConnectException: Connection refused: no further information
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Mar 19, 2012 - 07:43 AM



Joined: Nov 11, 2010
Posts: 2499

anilvjava ,

Sorry that you are seeing this issue.

Can you please give us some more details ?

1) Can you please share the installation details from MyEclipse > Installation Summary > Installation Details ? Paste them here for us.

2) Are you behind a firewall/proxy ? Did you setup proxy host/port in the MyEclipse network connections Window>properties>General>Network Connections?

3) Do you have an open internet connection ?

4) There are additional proxy settings for maven.

Go to MyEclipse->Preferences->Maven4Myeclipse->User Settings. There you will see the file used for user settings (named, settings.xml). That file (which may not yet exist, in which case, create it) should look something like this, when configuring the proxy:

Code:

<settings>
<proxies>
<proxy>
<active>true</active>
<protocol>http</protocol>
<host>proxy.somewhere.com</host>
<port>8080</port>
<username>proxyuser</username>
<password>somepassword</password>
<nonProxyHosts>www.google.com|*.somewhere.com</nonProxyHosts>
</proxy>
</proxies>
</settings>


Of course, you need to set the elements for your particular situation; the above is just an example.

5) If you are still seeing the issue, then clear the contents of the .log file which is located at <workspace dir>/.metadata/.log. Now try to create a new Maven project, replicate the issue and attach the .log file for us to investigate further.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits