MyEclipse Forums
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
peter@josh.se
Post subject: Project configuration is not up-to-date with pom.xml  PostPosted: Mar 16, 2012 - 02:11 PM



Joined: Feb 21, 2012
Posts: 3

Hi! We have several existing projects that we have imported into MyEclipse 10, and we're stuck in an endless loop of problems. MyEclipse complains that our "Project configuration is not up-to-date with pom.xml. Please run configuration update". When we do this, the build path in MyEclipse is changed, the output directories are set to the target directories specified in our pom.xml and some exclusion filters are added.

This results in our MyEclipse server deployment fails - this only works when the output folders are set as src/main/webapp/WEB-INF/classes/.

So - the project won't build unless we run project configuration update. After we run it, the project builds fine, but cannot be deployed on Tomcat.

Is there any way around this? Have we missed something obvious?

Regards
Peter
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Mar 19, 2012 - 11:00 AM



Joined: Nov 11, 2010
Posts: 2499

Peter,

Sorry that you are seeing this issue.

Can you give us some more details to help investigate the issue ?

1. Are the imported projects purely maven projects or created from an earlier release of MyEclipse ?

2. If they are purely Maven projects, then with which release of Maven are they created?

3. What are the target directories specified as ? Is there any specific reason why you do not want the target directories as output directories ?

4. How are you importing the projects ? Please give us steps in detail to help us replicate the issue.

5. What is the exact error you see when deploying to Tomcat ? Also mention the version of Tomcat.

6. Clear the contents of the .log file which is located at <workspace dir>/.metadata/.log. Replicate the issue and check the .log file for any errors of interest. If there are any, then please attach the .log file for us. Here is an FAQ on how to upload files to forums :
http://www.myeclipseide.com/PNphpBB2-viewtopic-t-27029.html

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits