Post new topic   Reply to topic
Author Message
dtb
Registered Member
Registered Member


Joined: Mar 10, 2006
Posts: 46

Hi,
I am using MyEclipse for Spring and trying to develop Matisse/Swing GUI application.
Very annoying that whenever I change anything on the form in Design view the view always changes to Source view. (In between a progress bar with 'formatting' text appears.)
How can I this behaviour switch off?
Balazs Toth
 
 View user's profile Send private message  
Reply with quote Back to top
support-joy
Registered Member
Registered Member


Joined: Feb 03, 2009
Posts: 3442

Balazs Toth,

Sorry to hear you are running into this issue. Could you please answer below queries to help me understand your environment and profile.

1. Open MyEclipse for Spring IDE. From menu options click on Help > About MyEclipse for Spring and copy and paste buildId and versionID here
2. From menu options click on MyEclipse > Installation Summary > Installation Details and copy and paste the same here
3. Could you clear your .log file located at [your workspace dir]/.myeclipse/.log, replicate the issue and attach file here
4. Please perform -clean and let me know if this issue persists. Refer - http://www.myeclipseide.com/PNphpBB2-viewtopic-t-10280.html

_________________
Joy
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
dtb
Registered Member
Registered Member


Joined: Mar 10, 2006
Posts: 46

Hi,
Yesterday I tried to answer your questions, but somehow it hasn't succeeded.
Before the answers let me inform you, that I tried the same thing with MyEclipse (not for Spring) of the same version and I had no problems at all.
And the answer are as follows:
1.
MyEclipse for Spring


Version: 8.6

(c) Copyright Genuitec, L.L.C. 2000-2010. All rights reserved.
Visit http://www.myeclipseide.com/

This product includes software developed by the following
Skyway Software http://www.skywaysoftware.com
Eclipse Foundation http://www.eclipse.org/
Apache Software Foundation http://www.apache.org/
2.
*** Date:
2011. szeptember 30. 11:55:50 CEST

** System properties:
OS=WindowsXP
OS version=5.1.0
Java version=1.6.0_13


*** MyEclipse details:
MyEclipse Enterprise Workbench
Version: 8.6
Build id: 8.6-20100806


*** Eclipse details:
MyEclipse for Spring





Version: 8.6








Eclipse startup command=-os
win32
-ws
win32
-arch
x86
-showsplash
-launcher
C:\Program Files\Genuitec\Profiles\MyEclipse for Spring 8.6\myeclipseforspring.exe
-name
Myeclipseforspring
--launcher.library
C:\Program Files\Genuitec\Profiles\MyEclipse for Spring 8.6\../../Common/plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.200.v20090519\eclipse_1206.dll
-startup
C:\Program Files\Genuitec\Profiles\MyEclipse for Spring 8.6\../../Common/plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar
-install
C:/Program Files/Genuitec/Profiles/MyEclipse for Spring 8.6
-configuration
configuration
-vm
C:/Program Files/Genuitec/Common/binary/com.sun.java.jdk.win32.x86_1.6.0.013/jre/bin/client/jvm.dll
3.
Nothing happens - no log created.
But when I add a Matisse form (JFrame) to my Java project =for the 1st time=, some error message displays.
'Resetting Selection' has encountered a problem.
Error processing selection.
And here is the log of it.

!ENTRY org.eclipse.osgi 2 0 2011-09-30 11:55:36.839
!MESSAGE While loading class "org.maven.ide.eclipse.internal.embedder.ArtifactTransferListenerAdapter", thread "Thread[Worker-1,5,main]" timed out waiting (5000ms) for thread "Thread[DLTK indexing,4,main]" to finish starting bundle "org.maven.ide.eclipse_0.10.0.me201005202254 [1075]". To avoid deadlock, thread "Thread[Worker-1,5,main]" is proceeding but "org.maven.ide.eclipse.internal.embedder.ArtifactTransferListenerAdapter" may not be fully initialized.
!STACK 0
org.osgi.framework.BundleException: State change in progress for bundle "reference:file:/C:/Program Files/Genuitec/Common/plugins/org.maven.ide.eclipse_0.10.0.me201005202254.jar" by thread "DLTK indexing".
at org.eclipse.osgi.framework.internal.core.AbstractBundle.beginStateChange(AbstractBundle.java:1073)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:278)
at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:408)
at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:111)
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:449)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:211)
at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:381)
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:457)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:398)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:105)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
at org.maven.ide.eclipse.internal.embedder.MavenImpl.createArtifactTransferListener(MavenImpl.java:796)
at org.maven.ide.eclipse.internal.embedder.MavenImpl.createExecutionRequest(MavenImpl.java:199)
at org.maven.ide.eclipse.internal.project.MavenProjectManagerImpl.refresh(MavenProjectManagerImpl.java:343)
at org.maven.ide.eclipse.internal.project.MavenProjectManagerRefreshJob.run(MavenProjectManagerRefreshJob.java:93)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
Caused by: org.eclipse.osgi.framework.internal.core.AbstractBundle$BundleStatusException
... 18 more
Root exception:
org.eclipse.osgi.framework.internal.core.AbstractBundle$BundleStatusException
at org.eclipse.osgi.framework.internal.core.AbstractBundle.beginStateChange(AbstractBundle.java:1073)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:278)
at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:408)
at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:111)
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:449)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:211)
at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:381)
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:457)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:398)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:105)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
at org.maven.ide.eclipse.internal.embedder.MavenImpl.createArtifactTransferListener(MavenImpl.java:796)
at org.maven.ide.eclipse.internal.embedder.MavenImpl.createExecutionRequest(MavenImpl.java:199)
at org.maven.ide.eclipse.internal.project.MavenProjectManagerImpl.refresh(MavenProjectManagerImpl.java:343)
at org.maven.ide.eclipse.internal.project.MavenProjectManagerRefreshJob.run(MavenProjectManagerRefreshJob.java:93)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

!ENTRY org.eclipse.osgi 2 0 2011-09-30 11:55:41.856
!MESSAGE While loading class "org.maven.ide.eclipse.internal.project.DependencyResolutionContext", thread "Thread[Worker-1,5,main]" timed out waiting (5000ms) for thread "Thread[DLTK indexing,4,main]" to finish starting bundle "org.maven.ide.eclipse_0.10.0.me201005202254 [1075]". To avoid deadlock, thread "Thread[Worker-1,5,main]" is proceeding but "org.maven.ide.eclipse.internal.project.DependencyResolutionContext" may not be fully initialized.
!STACK 0
org.osgi.framework.BundleException: State change in progress for bundle "reference:file:/C:/Program Files/Genuitec/Common/plugins/org.maven.ide.eclipse_0.10.0.me201005202254.jar" by thread "DLTK indexing".
at org.eclipse.osgi.framework.internal.core.AbstractBundle.beginStateChange(AbstractBundle.java:1073)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:278)
at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:408)
at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:111)
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:449)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:211)
at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:381)
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:457)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:398)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:105)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
at org.maven.ide.eclipse.internal.project.MavenProjectManagerImpl.refresh(MavenProjectManagerImpl.java:345)
at org.maven.ide.eclipse.internal.project.MavenProjectManagerRefreshJob.run(MavenProjectManagerRefreshJob.java:93)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
Caused by: org.eclipse.osgi.framework.internal.core.AbstractBundle$BundleStatusException
... 16 more
Root exception:
org.eclipse.osgi.framework.internal.core.AbstractBundle$BundleStatusException
at org.eclipse.osgi.framework.internal.core.AbstractBundle.beginStateChange(AbstractBundle.java:1073)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:278)
at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:408)
at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:111)
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:449)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:211)
at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:381)
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:457)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:398)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:105)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
at org.maven.ide.eclipse.internal.project.MavenProjectManagerImpl.refresh(MavenProjectManagerImpl.java:345)
at org.maven.ide.eclipse.internal.project.MavenProjectManagerRefreshJob.run(MavenProjectManagerRefreshJob.java:93)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
4.
No help.
Thanks
Balazs Toth
 
 View user's profile Send private message  
Reply with quote Back to top
support-joy
Registered Member
Registered Member


Joined: Feb 03, 2009
Posts: 3442

Balazs Toth,

Thank you for the details. I have escalated your issue to dev team members. They would get back to you on this shortly. Sorry for the inconvenience.

_________________
Joy
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
jkennedy



Joined: Jan 27, 2010
Posts: 245

Balazs Toth,
Thank you for the details you supplied.

Can you tell me which Editor you have open at the time that this occurs? What type of file and how it is being opened.

Regarding the behavior where when you make a change and you get a status saying formatting text, is that is status opening a dialog with that message or do you see it minimized. Does this occur on Save or on Change?

The installation variance between ME4S and MyEclipse standard should not influence the use case that you are describing. Is it possible that there is some other configuration difference between the two environments that may influence this behavior? Perhaps under the workspace or project validation settings there is a validation that is running for the file type you are editing that may be unchecked in one environment vs the other? Or perhaps there are specific options for a formatter on this file type that is selected in one environment vs the other?

Thanks for any additional details,
Jack
 
 View user's profile Send private message  
Reply with quote Back to top
dtb
Registered Member
Registered Member


Joined: Mar 10, 2006
Posts: 46

Hi,
here are the answers.
1.
The file type is *.form and is opened with MyEclipse Matisse Form editor.
(And whenever I open it that embarassing 'Resetting Selection' has encountered a problem error report occurs.)
2.
A dialog box opens, not minimized. I simply drop a new element on the form so I think it is a Change.
3.
I will try to look for such differences. What I did so far:
- Unchecked Build automatically possibility
- Switched off Checkstyle action
- Disabled all validations
Thanks
Balazs
 
 View user's profile Send private message  
Reply with quote Back to top
riahc3



Joined: Dec 22, 2011
Posts: 13

dtb wrote:
Hi,
I am using MyEclipse for Spring and trying to develop Matisse/Swing GUI application.
Very annoying that whenever I change anything on the form in Design view the view always changes to Source view. (In between a progress bar with 'formatting' text appears.)
How can I this behaviour switch off?
Balazs Toth

I have the same exact issue on MyEclipse for Spring.

MyEclipse for Spring

Version: 10.0.0
Build ID: 10.0.0 Build 7 (111109_1440)


*** Date:
viernes 27 de enero de 2012 12H07' CET

** System properties:
OS=WindowsXP
OS version=5.1.0
Java version=1.6.0_13


*** MyEclipse details:
MyEclipse Enterprise Workbench
Version: 10.0
Build id: 10.0-20111028


*** Eclipse details:
MyEclipse for Spring



Version: 10.0.0

Build ID: 10.0.0 Build 7 (111109_1440)








Eclipse startup command=-os
win32
-ws
win32
-arch
x86
-showsplash
-launcher
C:\Archivos de programa\MyEclipse for Spring\MyEclipse for Spring 10\myeclipseforspring.exe
-name
Myeclipseforspring
--launcher.library
C:\Archivos de programa\MyEclipse for Spring\MyEclipse for Spring 10\../Common/plugins/org.eclipse.equinox.launcher.i18n.win32.win32.x86_3.2.0.v201103301700\eclipse_3215.dll
-startup
C:\Archivos de programa\MyEclipse for Spring\MyEclipse for Spring 10\../Common/plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
-install
C:\Archivos de programa\MyEclipse for Spring\MyEclipse for Spring 10
-configuration
C:\Archivos de programa\MyEclipse for Spring\MyEclipse for Spring 10\configuration
-vm
C:\Archivos de programa\MyEclipse for Spring\Common\binary\com.sun.java.jdk.win32.x86_1.6.0.013\jre\bin\client\jvm.dll
 
 View user's profile Send private message  
Reply with quote Back to top
riahc3



Joined: Dec 22, 2011
Posts: 13

This doesnt happen in Microsoft Visual Studio. Id like to be when designing a GUI in that IDE. Is this, like commented, a bug or must to be changed somewhere?
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna



Joined: Nov 11, 2010
Posts: 2681

riahc3,

I have escalated it to a Spring team member. They will get back to you.
Sorry for the inconvenience caused.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
adrian.challinor
Veteran Member
Veteran Member


Joined: Mar 25, 2005
Posts: 22

MyEclipse for Spring

Version: 10.0.0
Build ID: 10.0.0 Build 7 (111109_1440)


Just a thought, but could this be JDK related? I am on Java-6-OpenJDK

java version "1.6.0_23"
OpenJDK Runtime Environment (IcedTea6 1.11pre) (6b23~pre11-0ubuntu1.11.10.2)
OpenJDK 64-Bit Server VM (build 20.0-b11, mixed mode)
 
 View user's profile Send private message  
Reply with quote Back to top
cconway



Joined: Apr 04, 2011
Posts: 196

The problem appears to be related to a particular plugin. It's the plugin that contributes the Spring Annotations view, JPA Annotations view and the JAX-WS Annotations view. Can you please try these steps to see if it gets around the problem for you?

1. Make sure the three views listed above are not open (they are not open by default in the MyEclipse Swing/Matisse perspective).
2. Open the Window > Preferences dialog.
3. Type "Start" into the filter box on the top left (without the quotes).
4. Select the "Startup and Shutdown" item in the tree.
5. Find the "Skyway Composite Editor Framework" item in the list and un-check it.
6. Press Apply, then OK.
7. Restart MyEclipse for Spring.
8. Try your Matisse editor again.

I think this has something to do with the way that plugin parses Java code but I'm not familiar with Matisse so my test scenario is less than perfect. If that works for you (or even if it doesn't) please post your results here.

_________________
Cindy
MyEclipse for Spring Support
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
adrian.challinor
Veteran Member
Veteran Member


Joined: Mar 25, 2005
Posts: 22

Early days, but it does seem to work.

Thank you.

I will be working on this over the weekend, so I will let you know, but first impressions are good.
 
 View user's profile Send private message  
Reply with quote Back to top
All times are GMT - 6 Hours
Post new topic   Reply to topic
® 2014 - Genuitec, LLC.