MyEclipse Forums
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
danielkohl
Post subject: 3 auto-deployments..?  PostPosted: Apr 18, 2012 - 08:33 AM
Veteran Member
Veteran Member


Joined: Apr 26, 2005
Posts: 20

Hello all,

currently we're facing a really bizarre problem on our EAR-project.
On deployment process (in MyEclipse 10.1) the auto-deployment is done 3 times!
In STS it seems to work properly...

We use

- GlassFish 3.1.2
- Maven 3


Any ideas?

Greetings

Daniel
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Apr 18, 2012 - 10:38 AM



Joined: Nov 11, 2010
Posts: 2499

Daniel,

Sorry that you are seeing this issue.

Can you give us some more information ?

1. Can you please share the installation details from MyEclipse > Installation Summary > Installation Details ? Paste them here for us.

2. Can you please post the console output containing the problem for us to better understand the issue ?

3. Are you seeing this issue on initial deploy/subsequent deploys or when you modify some code ?

4. Can you also check if the issue exists for non maven projects?

Let us know how it works for you.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
danielkohl
Post subject:   PostPosted: Apr 18, 2012 - 03:59 PM
Veteran Member
Veteran Member


Joined: Apr 26, 2005
Posts: 20

Sorry, i'm not allwowed to post some details information from the console, i can only describe this in detail.

Pre-conditions:
- Fresh server startup (Glassfish 3.1.2)
- New domain
- Maven 3
- JRebel turned on

If i now deploy my EAR (build by the embedded Maven4MyEclipse) Glassfish starts the automatic deployment again DURING the running deployment. This is done twice (3 deployments instead of 1).
The application itself isn't deployed correctly at the end. Some of the EJB are yet bound and i get AlreadyBoundExceptions. The app is unusable.

It looks a little bit like there's some file-modification happening after the deployment has started.
But..it doesn't matter what kind of deployment i use. Packaged or exploded, both variants behave the same way.
I turned off my virus-scanners, because i thougt the touched the packages, but it doesn't help.

Sometime it helps to turn of JRebel, sometimes it doesn't help.
On STS we din't have such problems.


Greetings

Daniel




Installation summary:
Code:

*** Date:
Mittwoch, 18. April 2012 16:56 Uhr MESZ

*** System properties:
OS=WindowsVista
OS version=6.1.0
OS arch=amd64
Profile arch=x86_64
Window system=win32
Java version=1.6.0_13
Workspace=file:/C:/sde/workspace/
VM Args=-Xmx2048m
-XX:MaxPermSize=512m
-XX:ReservedCodeCacheSize=256m
-Dosgi.nls.warnings=ignore
-jar
C:\sde\MYECLI~1\MYECLI~1\../Common/plugins/ORB7B5~1.JAR



*** Subscription information
Product Id: E3MP (MyEclipse Professional Subscription)
License version: 3.0
Full Maintenance Included
Subscription expiration date (YYYYMMDD): 20130114
Number of users: 1

*** Eclipse details:
MyEclipse Enterprise Workbench

Version: 10.1
Build id: 10.1-20120316


Blueprint: MyEclipse 10

com.genuitec.myeclipse.database - 10.1.0.me201203170059
com.genuitec.myeclipse.desktop - 10.1.0.me201203170059
com.genuitec.myeclipse.editor - 10.1.0.me201203170059
com.genuitec.myeclipse.enterprise.workbench - 10.1.0.me201203170059
com.genuitec.myeclipse.geronimo - 10.1.0.me201203170059
com.genuitec.myeclipse.glassfish - 10.1.0.me201203170059
com.genuitec.myeclipse.icefaces.feature - 10.1.0.me201203170059
com.genuitec.myeclipse.iedebugger - 10.1.0.me201203170059
com.genuitec.myeclipse.imageeditor - 10.1.0.me201203170059
com.genuitec.myeclipse.jboss - 10.1.0.me201203170059
com.genuitec.myeclipse.jetty - 10.1.0.me201203170059
com.genuitec.myeclipse.jonas - 10.1.0.me201203170059
com.genuitec.myeclipse.jrun - 10.1.0.me201203170059
com.genuitec.myeclipse.jsf - 10.1.0.me201203170059
com.genuitec.myeclipse.matisse - 10.1.0.me201203170059
com.genuitec.myeclipse.maven - 10.1.0.me201203170059
com.genuitec.myeclipse.oracle - 10.1.0.me201203170059
com.genuitec.myeclipse.orion - 10.1.0.me201203170059
com.genuitec.myeclipse.persistence - 10.1.0.me201203170059
com.genuitec.myeclipse.pulse - 10.1.0.me201203170059
com.genuitec.myeclipse.reports - 10.1.0.me201203170059
com.genuitec.myeclipse.resin - 10.1.0.me201203170059
com.genuitec.myeclipse.struts - 10.1.0.me201203170059
com.genuitec.myeclipse.sun - 10.1.0.me201203170059
com.genuitec.myeclipse.tomcat - 10.1.0.me201203170059
com.genuitec.myeclipse.uml2 - 10.1.0.me201203170059
com.genuitec.myeclipse.visualvm - 10.1.0.me201203170059
com.genuitec.myeclipse.visualvm.server - 10.1.0.me201203170059
com.genuitec.myeclipse.weblogic - 10.1.0.me201203170059
com.genuitec.myeclipse.websphere - 10.1.0.me201203170059
com.genuitec.myeclipse.ws - 10.1.0.me201203170059
org.eclipse.birt - 2.6.1.me201203170059
org.eclipse.datatools.connectivity.feature - 1.9.0.me201203170059
org.eclipse.datatools.enablement.feature - 1.9.0.me201203170059
org.eclipse.datatools.modelbase.feature - 1.9.0.v201106031100-77078CcNBHCBYKYEbNV
org.eclipse.datatools.sqldevtools.feature - 1.9.0.me201203170059
org.eclipse.emf - 2.7.0.v20110606-0949
org.eclipse.gef - 3.7.0.v20110425-2050-777D-81B2Bz0685C3A6E34272
org.eclipse.graphiti.feature - 0.8.0.v20110607-1252
org.eclipse.jpt.jpa.feature - 3.0.0.me201203170059
org.eclipse.jpt.jpadiagrameditor.feature - 1.0.0.me201203170059
org.eclipse.jst.common.fproj.enablement.jdt - 3.3.0.me201203170059
org.eclipse.jst.enterprise_ui.feature - 3.3.0.me201203170059
org.eclipse.jst.server_adapters.ext.feature - 3.3.0.me201203170059
org.eclipse.jst.server_adapters.feature - 3.2.100.me201203170059
org.eclipse.jst.server_ui.feature - 3.3.0.me201203170059
org.eclipse.jst.ws.axis2tools.feature - 1.1.200.me201203170059
org.eclipse.m2e.feature - 1.0.0.me201203170059
org.eclipse.wst.common.fproj - 3.3.0.me201203170059
org.eclipse.wst.server_adapters.feature - 3.2.100.me201203170059
org.eclipse.xsd - 2.7.0.v20110606-0949
org.springframework.ide.eclipse.feature - 2.7.1.me201203170059
org.zeroturnaround.myeclipse.feature - 1.0.3.201203151351


com.collabnet.subversion.merge.feature - 2.2.4
fr.obeo.acceleo.bridge.feature - 2.6.0.200906261742
net.sf.eclipsecs - 5.5.0.201111092104
org.eclipse.cvs - 1.3.100.v20110520-0800-7B78FHl9VF7BD7KBM4GP9C
org.eclipse.draw2d - 3.7.0.v20110425-2050-46-7w3122153603161
org.eclipse.equinox.p2.core.feature - 1.0.1.v20110906-1605-8290FZ9FVKHVRKtmx3fpNuo02129
org.eclipse.equinox.p2.extras.feature - 1.0.1.v20110906-1605-7A4FD4DiVOMap8cHSc6vPuny4gqO
org.eclipse.equinox.p2.rcp.feature - 1.0.1.v20110906-1605-782EqBqNKGVkiV-PUsgz-uny4gqO
org.eclipse.equinox.p2.user.ui - 2.1.2.R37x_v20110815-1155-6-Bk8pYWZz0qUTX5I15GZWwbXkrl
org.eclipse.help - 1.3.0.v20110530-0844-7i7uFFmFFl8nvqbDpEqTvx
org.eclipse.jdt - 3.7.2.v20120120-1414-7z8gFcuFMP7BW5XTz0jLTnz0l9B1
org.eclipse.jsf.feature - 3.3.0.me201203170059
org.eclipse.ocl - 3.1.0.v20110606-1427
org.eclipse.pde - 3.7.2.v20120120-1420-7b7rFUOFEx2Xnqafnpz0E--0
org.eclipse.platform - 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q
org.eclipse.rcp - 3.7.2.v20120120-1424-9DB5FmnFq5JCf1UA38R-kz0S0272
org.sonatype.m2e.buildhelper.feature - 0.14.0.201109282148
org.sonatype.m2e.subclipse.feature - 0.13.0.201107071330
org.tigris.subversion.clientadapter.feature - 1.6.12
org.tigris.subversion.clientadapter.javahl.feature - 1.6.17
org.tigris.subversion.clientadapter.svnkit.feature - 1.6.15
org.tigris.subversion.subclipse - 1.6.18
org.tigris.subversion.subclipse.graph.feature - 1.0.9
org.tigris.subversion.subclipse.mylyn - 3.0.0
org.zeroturnaround.eclipse.debug.feature - 1.4.2.201203151351
org.zeroturnaround.eclipse.embedder.feature - 4.6.1.201203151351
org.zeroturnaround.eclipse.feature - 1.6.1.201203151351
org.zeroturnaround.eclipse.wtp.feature - 1.4.6.201203151351


Eclipse startup command=-os
win32
-ws
win32
-arch
x86_64
-showsplash
-launcher
C:\sde\MyEclipse\MyEclipse 10\myeclipse.exe
-name
Myeclipse
--launcher.library
C:\sde\MyEclipse\MyEclipse 10\../Common/plugins/org.eclipse.equinox.launcher.i18n.win32.win32.x86_64_4.2.0.v201201111650\eclipse_4201.dll
-startup
C:\sde\MyEclipse\MyEclipse 10\../Common/plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
-exitdata
103c_58
-install
C:\sde\MyEclipse\MyEclipse 10
-configuration
C:\sde\MyEclipse\MyEclipse 10\configuration
-vm
C:\sde\MyEclipse\Common\binary\com.sun.java.jdk.win32.x86_64_1.6.0.013\bin\javaw.exe

 
 View user's profile Send private message  
Reply with quote Back to top
danielkohl
Post subject:   PostPosted: Apr 18, 2012 - 04:05 PM
Veteran Member
Veteran Member


Joined: Apr 26, 2005
Posts: 20

Ouups...forgot to answer some of your questions.

3) Only on initial deployments. If the initial deployment succeeded we can work fine.
4) No problems with non-Maven projects. I don't like Maven, but can MAVEN be the problem here?

Greetings

Daniel
 
 View user's profile Send private message  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Apr 19, 2012 - 05:44 AM



Joined: Mar 09, 2011
Posts: 919

Daniel,

You say that sometimes disabling JRebel helps and sometimes it doesn't. Do you always have the problem when JRebel is enabled but only sometimes have the problem when JRebel is disabled?

I'm not very familiar with JRebel but it may be having an impact, whether it is disabled or not. Is it possible to remove the JRebel plug-in and see if you get the same issue? If you don't see the issue, in this case, I wonder if the JRebel set-up is not correct; perhaps you could check that or ask on the JRebel forum.

If it only happens sometimes with JRebel disabled, can you see any pattern? If you can produce a minimal sample project that exhibits this behaviour consistently, without JRebel, that would be a big help.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits