MyEclipse Forums
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
hem_kec
Post subject: Unable to Connect EJB 3.0 from Client.  PostPosted: May 23, 2012 - 07:49 AM



Joined: Feb 18, 2012
Posts: 6

Hi,
I am using EJB 3.0 with WebSphere server 7.0 in windows 64 machine.
The sample project is as follows
--------------------------
DellEJB3Local.java:
--------------------------
package dellejb3;
import javax.ejb.Local;
/**
* DellEJB3 local interface
*/
@Local
public interface DellEJB3Local {
public void Hello();
}
--------------------------
DellEJB3.java:
--------------------------
package dellejb3;
import javax.ejb.Stateless;
/**
* Session Bean implementation class DellEJB3
*/
@Stateless
public class DellEJB3 implements DellEJB3Local {
/**
* Default constructor.
*/
public DellEJB3() {
}
public void Hello()
{
System.out.println("HI");
}
}

I am facing lot of issue to connect the EJB from some Client.

1) After deploying the EJB, I am unable to see JNDI name in Webshpere 7.0
2) How to connect to EJB from Client. I tried lot of combination but dose not work

3) META-INF folder contains only MANIFEST.MF file.


Thanks
With Regards
Hemant Joshi.
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: May 23, 2012 - 11:19 AM



Joined: Nov 11, 2010
Posts: 2499

Hemant,

Sorry that you are seeing this issue.

Can you please take a look at these links :

http://www.coderanch.com/t/472876/Websphere/WebSphere-Application-Server-could-not
http://docs.oracle.com/cd/B14099_19/web.1012/b15505/access.htm

I suggest you crosspost to EJB forums for better support on connecting to an EJB from Client.

Hope this helps.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
hem_kec
Post subject:   PostPosted: May 24, 2012 - 02:40 PM



Joined: Feb 18, 2012
Posts: 6

Hi,
Thanks for the reply but it dose not help much.


Is it the case the myeclipse is not able to generate the required stuff code for deployment in websphere. I am not able to see JNDI in WebShpere.



Thanks
With Regards
Hemant Joshi.
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: May 25, 2012 - 02:01 PM



Joined: Nov 11, 2010
Posts: 2499

Hemant,

1. How did you specify the JNDI name for the EJB?

2. Can you browse to the deployment location for the EJB project and check if you see any files in the META-INF folder apart from MANIFEST.MF file ?

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits