MyEclipse Forums
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
neilrichards
Post subject: Errors on first open  PostPosted: May 31, 2012 - 02:50 PM
Registered Member
Registered Member


Joined: May 19, 2010
Posts: 6

Hi,

Having installed MyEclipse 10.1 (64 bit) yesterday on a new PC, I am getting the following errors when I first open it:

Quote:

eclipse.buildId=unknown
java.version=1.6.0_13
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_GB
Command-line arguments: -os win32 -ws win32 -arch x86_64

Error
Thu May 31 14:29:11 BST 2012
Unable to find MEContainer jar: C:/Users/richarn/AppData/Local/Genuitec/MyEclipse-10/plugins/com.genuitec.eclipse.j2eedt.core_10.0.0.me201110301321/data/libraryset/EE_6/jsf-api.jar


Quote:

eclipse.buildId=unknown
java.version=1.6.0_13
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_GB
Command-line arguments: -os win32 -ws win32 -arch x86_64

Error
Thu May 31 14:29:11 BST 2012
Unable to find MEContainer jar: C:/Users/richarn/AppData/Local/Genuitec/MyEclipse-10/plugins/com.genuitec.eclipse.j2eedt.core_10.0.0.me201110301321/data/libraryset/EE_6/jsf-impl.jar


These 2 are coming up as my ECLIPSE_HOME is C:/Users/richarn/AppData/Local/MyEclipse/MyEclipse 10 not C:/Users/richarn/AppData/Local/Genuitec/MyEclipse-10

Quote:

eclipse.buildId=unknown
java.version=1.6.0_13
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_GB
Command-line arguments: -os win32 -ws win32 -arch x86_64

Info
Thu May 31 14:29:14 BST 2012
Unable to locate .myeclipse.properties file


Can't find this anywhere in C:/Users/richarn/AppData/Local/MyEclipse or my workspace. What's supposed to be in it?

Quote:

eclipse.buildId=unknown
java.version=1.6.0_13
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_GB
Command-line arguments: -os win32 -ws win32 -arch x86_64

Warning
Thu May 31 14:29:20 BST 2012
While loading class "org.eclipse.wst.jsdt.internal.core.JavaModelManager$16", thread "Thread[Worker-4,5,main]" timed out waiting (5003ms) for thread "Thread[Worker-3,5,main]" to finish starting bundle "org.eclipse.wst.jsdt.core_1.1.100.me201203060843 [960]". To avoid deadlock, thread "Thread[Worker-4,5,main]" is proceeding but "org.eclipse.wst.jsdt.internal.core.JavaModelManager$16" may not be fully initialized.

org.osgi.framework.BundleException: State change in progress for bundle "reference:file:/C:/Users/richarn/AppData/Local/MyEclipse/Common/plugins/org.eclipse.wst.jsdt.core_1.1.100.me201203060843.jar" by thread "Worker-3".
at org.eclipse.osgi.framework.internal.core.AbstractBundle.beginStateChange(AbstractBundle.java:1087)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:297)
at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:440)
at org.eclipse.osgi.internal.loader.BundleLoader.setLazyTrigger(BundleLoader.java:268)
at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:107)
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:463)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:216)
at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:400)
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:476)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:429)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:417)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
at org.eclipse.wst.jsdt.internal.core.JavaModelManager$15.run(JavaModelManager.java:4182)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
Caused by: org.eclipse.osgi.framework.internal.core.AbstractBundle$BundleStatusException
... 16 more


Mmm. No idea about this. Anyone?

Thanks in advance :)
Neil
 
 View user's profile Send private message  
Reply with quote Back to top
support-joy
Post subject:   PostPosted: Jun 01, 2012 - 10:07 PM
Registered Member
Registered Member


Joined: Feb 03, 2009
Posts: 3442

Neil,

Sorry to hear you are running into this issue. I have escalated this post to dev team member.
Sorry for the inconvenience.

_________________
Joy
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Support-Brian
Post subject:   PostPosted: Jun 03, 2012 - 09:57 PM
Moderator
Moderator


Joined: Aug 21, 2004
Posts: 2585

Neil,

1) The plugin - com.genuitec.eclipse.j2eedt.core being referred to in the error message is a plugin from 10.0 and not 10.1 - on a new system with a 10.1 installation, the 10.0 plugin won't exist which is why you see those errors. There may be something in your workspace or existing project that explicitly points to the files from the older plugin.

a) Go to Help > About > Installation Details and look for this plugin in the Plug-ins tab. Can you paste the full version number that is reported for that plugin here please?
b) Can you try creating a new web project for testing? If you close your other projects and restart your workspace, do you still see this error?
c) Can you paste the .classpath file for the project experiencing these issues here please?

2) .myeclipse.properties will reside in your home directory. If you haven't yet entered your subscription details, this message is expected. When you do enter your details, that file is created and the problem should go away - until then you will be operating MyEclipse with a 30 day trial.

3) The JSDT "state change in progress" issue you may see occasionally on startup - this can be ignored.

_________________
Brian
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits