MyEclipse Forums
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
meetsbs
Post subject: Unable to reference JARs in EAR lib  PostPosted: Jun 12, 2012 - 02:38 PM



Joined: Jun 12, 2012
Posts: 3

Hi,

I am unable to reference the JARs in EAR/lib at runtime. I am using in-workspace mode. Can you please suggest what should be my settings in the EJB project and the EAR project so that the EJBs can refer the JARs from EAR at runtime.

Regards,
Saurabh Shah
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Jun 13, 2012 - 09:22 AM



Joined: Nov 11, 2010
Posts: 2491

Saurabh,

Sorry that you are seeing this issue.

Can you answer some more questions for us ?

1. Can you please copy paste the Installation Details from MyEclipse > Installation Summary > Installation Details ?

2. Which version of Websphere server are you working with?

3. Did you make an entry in the EJB's MANIFEST.MF file ?.Any module that wants to use a jar from EAR's libraries needs to reference the jar in module MANIFEST.MF like:

Class-Path: lib/TheJarNameHere.jar

4. If you are still seeing issues, please prepare a sample project with minimum files which exhibits the behavior and send it to us for further investigation.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
meetsbs
Post subject:   PostPosted: Jun 13, 2012 - 09:39 AM



Joined: Jun 12, 2012
Posts: 3

*** Date:
Wednesday, June 13, 2012 2:07:32 PM IST

** System properties:
OS=WindowsVista
OS version=6.1.0
Java version=1.6.0_13


*** MyEclipse details:
MyEclipse Blue Edition
Version: 9.1 Blue
Build id: 9.1-Blue-20110701


*** Eclipse details:
MyEclipse Blue Edition

Version: 9.1 Blue
Build id: 9.1-Blue-20110701




Eclipse Platform

Version: 3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L
Build id: M20100909-0800


Eclipse Java Development Tools

Version: 3.6.1.r361_v20100714-0800-7z8XFUSFLFlmgLc5z-Bvrt8-HVkH
Build id: M20100909-0800


Eclipse Plug-in Development Environment

Version: 3.6.1.r361_v20100727-7b7mFL-FET3dhESDgE5_bkJ
Build id: M20100909-0800


Eclipse Graphical Editing Framework GEF

Version: 3.6.1.v20100908-1100-777B181A3Bz-6B663E7974242
Build id: 201009132020


Eclipse RCP

Version: 3.6.1.r361_v20100827-9OArFLdFjY-ThSQXmKvKz0_T
Build id: M20100909-0800




Eclipse startup command=-os
win32
-ws
win32
-arch
x86_64
-showsplash
-launcher
C:\Proj-StateOfMontana\EclipseBlue\MyEclipse Blue Edition 9\myeclipse-blue.exe
-name
Myeclipse-blue
--launcher.library
C:\Proj-StateOfMontana\EclipseBlue\MyEclipse Blue Edition 9\../Common/plugins/org.eclipse.equinox.launcher.i18n.win32.win32.x86_64_3.2.0.v201103301700\eclipse_3215.dll
-startup
C:\Proj-StateOfMontana\EclipseBlue\MyEclipse Blue Edition 9\../Common/plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-exitdata
fac_5c
-install
C:\Proj-StateOfMontana\EclipseBlue\MyEclipse Blue Edition 9
-configuration
C:\Proj-StateOfMontana\EclipseBlue\MyEclipse Blue Edition 9\configuration
-vm
C:\Proj-StateOfMontana\EclipseBlue\Common\binary\com.sun.java.jdk.win32.x86_64_1.6.0.013\bin\javaw.exe

I am using Websphere 7.0

EJB's Manifest contains the jar entries
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Jun 15, 2012 - 11:53 AM



Joined: Nov 11, 2010
Posts: 2491

Saurabh,

Thank you for the details.

1. Can you please share with us the JEE version of your project ?
2. Also paste the contents of the MANIFEST.MF file here for us to investigate further ?

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
meetsbs
Post subject: Issue Resolved  PostPosted: Jun 15, 2012 - 02:55 PM



Joined: Jun 12, 2012
Posts: 3

Hi,

I made changes to the EJB and EAR settings. Now i am able to reference the required JARs at runtime.

Regards,
Saurabh Shah
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Jun 18, 2012 - 05:32 AM



Joined: Nov 11, 2010
Posts: 2491

Saurabh,

Glad that the issue is resolved.
Do let us know if you have any issues.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits