MyEclipse Forums
This thread has been locked & this forum has been archived.
View previous topic Printable version Log in to check your private messages View next topic
Author Message
markhm
Post subject: Eclipse 3.1M5 compatibility...?  PostPosted: Feb 19, 2005 - 01:16 PM
Registered Member
Registered Member


Joined: Feb 05, 2005
Posts: 3

All,

Eclipse 3.1M5 is making it's way to the mirrors. I found it here:

http://mirror.tiscali.dk/eclipse/downloads/

Will MyEclipseIDE work without a problem with 3.1M5?

Thanks,
- Mark
 
 View user's profile Send private message  
Reply with quote Back to top
support-rkalla
Post subject:   PostPosted: Feb 19, 2005 - 03:21 PM
Registered Member
Registered Member


Joined: Jan 06, 2004
Posts: 23818

Quote:

Will MyEclipseIDE work without a problem with 3.1M5?

We are waiting for you to tell us ;)

_________________
Riyad
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
campers
Post subject:   PostPosted: Feb 20, 2005 - 09:09 AM
Registered Member
Registered Member


Joined: Jul 17, 2003
Posts: 6

I didnt have any luck with the deployments and my projects MyEclipse-Web properties page :(
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
markhm
Post subject:   PostPosted: Feb 20, 2005 - 10:26 AM
Registered Member
Registered Member


Joined: Feb 05, 2005
Posts: 3

support-rkalla wrote:
Quote:

Will MyEclipseIDE work without a problem with 3.1M5?

We are waiting for you to tell us ;)

Okay, okay... :-)

I didn't find any problems thus far, but I only did some very limited testing.
I was able to start my Tomcat-server in 3.1M5 with settings I had defined in an 3.1M4-workspace.

Cheers,
- Mark
 
 View user's profile Send private message  
Reply with quote Back to top
ggerard
Post subject:   PostPosted: Feb 20, 2005 - 03:45 PM
Veteran Member
Veteran Member


Joined: Dec 12, 2003
Posts: 15

I get a null pointer exception in "DeploymentBuilder"

java.lang.NullPointerException
at com.genuitec.eclipse.ast.deploy.core.DeploymentBuilder.webProjectBuildDelta(Unknown Source)
at com.genuitec.eclipse.ast.deploy.core.DeploymentBuilder.webProjectBuildDelta(Unknown Source)
at com.genuitec.eclipse.ast.deploy.core.DeploymentBuilder.buildDelta(Unknown Source)
at com.genuitec.eclipse.ast.deploy.core.DeploymentBuilder.build(Unknown Source)
at org.eclipse.core.internal.events.BuildManager$2.run(BuildManager.java:581)
at org.eclipse.core.internal.runtime.InternalPlatform.run(InternalPlatform.java:1015)
at org.eclipse.core.runtime.Platform.run(Platform.java:757)
at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:160)
at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:198)
at org.eclipse.core.internal.events.BuildManager$1.run(BuildManager.java:227)
at org.eclipse.core.internal.runtime.InternalPlatform.run(InternalPlatform.java:1015)
at org.eclipse.core.runtime.Platform.run(Platform.java:757)
at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:230)
at org.eclipse.core.internal.events.BuildManager.basicBuildLoop(BuildManager.java:249)
at org.eclipse.core.internal.events.BuildManager.build(BuildManager.java:278)
at org.eclipse.core.internal.events.AutoBuildJob.doBuild(AutoBuildJob.java:138)
at org.eclipse.core.internal.events.AutoBuildJob.run(AutoBuildJob.java:199)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:67)
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
ggerard
Post subject:   PostPosted: Feb 20, 2005 - 05:43 PM
Veteran Member
Veteran Member


Joined: Dec 12, 2003
Posts: 15

This shows up in the log:

!SESSION 2005-02-20 09:37:59.419 -----------------------------------------------
eclipse.buildId=I20050218-1600
java.version=1.5.0_01
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.core.resources 4 2 2005-02-20 09:37:59.421
!MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.core.resources".
!STACK 0
java.lang.LinkageError: loader constraints violated when linking org/xml/sax/EntityResolver class
at org.jdom.input.SAXBuilder.configureParser(SAXBuilder.java:506)
at org.jdom.input.SAXBuilder.build(SAXBuilder.java:351)
at org.jdom.input.SAXBuilder.build(SAXBuilder.java:673)
at com.genuitec.eclipse.j2eedt.metadata.ProjectModule.unmarshal(Unknown Source)
at com.genuitec.eclipse.j2eedt.core.J2EEProject.loadMetaData(Unknown Source)
at com.genuitec.eclipse.j2eedt.core.J2EEProject.<init>(Unknown Source)
at com.genuitec.eclipse.j2eedt.core.WebProject.<init>(Unknown Source)
at com.genuitec.eclipse.j2eedt.core.WebProject.<init>(Unknown Source)
at com.genuitec.eclipse.j2eedt.core.J2EECore.getWebProjectsList(Unknown Source)
at com.genuitec.eclipse.j2eedt.core.J2EECore.getWebProjects(Unknown Source)
at com.genuitec.eclipse.ast.deploy.core.DeployedResourceEventProcessor.?(Unknown Source)
at com.genuitec.eclipse.ast.deploy.core.DeployedResourceEventProcessor.access$0(Unknown Source)
at com.genuitec.eclipse.ast.deploy.core.DeployedResourceEventProcessor$B.visit(Unknown Source)
at org.eclipse.core.internal.events.ResourceDelta.accept(ResourceDelta.java:68)
at org.eclipse.core.internal.events.ResourceDelta.accept(ResourceDelta.java:77)
at org.eclipse.core.internal.events.ResourceDelta.accept(ResourceDelta.java:49)
at com.genuitec.eclipse.ast.deploy.core.DeployedResourceEventProcessor.resourceChanged(Unknown Source)
at org.eclipse.core.internal.events.NotificationManager$2.run(NotificationManager.java:285)
at org.eclipse.core.internal.runtime.InternalPlatform.run(InternalPlatform.java:1015)
at org.eclipse.core.runtime.Platform.run(Platform.java:757)
at org.eclipse.core.internal.events.NotificationManager.notify(NotificationManager.java:279)
at org.eclipse.core.internal.events.NotificationManager.broadcastChanges(NotificationManager.java:153)
at org.eclipse.core.internal.resources.Workspace.broadcastPostChange(Workspace.java:177)
at org.eclipse.core.internal.resources.Workspace.endOperation(Workspace.java:917)
at org.eclipse.core.internal.resources.SaveManager.save(SaveManager.java:979)
at org.eclipse.core.internal.resources.Workspace.save(Workspace.java:1736)
at org.eclipse.ui.internal.ide.IDEWorkbenchAdvisor$2.run(IDEWorkbenchAdvisor.java:282)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:111)
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
awf999
Post subject:   PostPosted: Feb 28, 2005 - 03:04 PM
Veteran Member
Veteran Member


Joined: Jul 10, 2003
Posts: 135

I have gotten addicted to using generics in Java 5. Unfortunately, M4 generic support is not as good as M5's. Is the ME team planning on releasing a M5 compatiable version of ME or will you be waiting until the M6 release?

thanks

_________________
Andy
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-scott
Post subject:   PostPosted: Feb 28, 2005 - 03:15 PM
Moderator
Moderator


Joined: May 06, 2003
Posts: 6761

Actually, there are a few compatibility problems with 3.8.4 and M5 due to some changes to the underlying Eclipse frameworks. So, 3.8.4 will not be totally reliable on M5. As far as future plans go, we'll continue to release betas for whatever release of the M1 stream is current as it coincides with our normal release schedules. Whether or not a specific patch for 3.8.4 will be issued for M5 is still under review since we haven't yet scoped the work due to our commitments building version 4.0 and getting stuff together for the team going to EclipseCon.

_________________
--Scott
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
yunkipaik
Post subject:   PostPosted: Mar 10, 2005 - 10:34 PM
Registered Member
Registered Member


Joined: Feb 01, 2005
Posts: 21

Please release a patch to 3.8.4 that will support M5.
I need it personally.
Thank you.
 
 View user's profile Send private message  
Reply with quote Back to top
GrimShieldsson
Post subject:   PostPosted: Mar 12, 2005 - 05:14 PM
Veteran Member
Veteran Member


Joined: Aug 02, 2003
Posts: 14

M4 doesn't cut it for me either. I'd reall ylike a work around or fix for this.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
ffray
Post subject:   PostPosted: Mar 23, 2005 - 08:15 AM
Registered Member
Registered Member


Joined: Feb 23, 2005
Posts: 1

I had to update to M5, because in M4 there were some errors in the Java-Compiler such as
generating erroneus bytecode for enums.
Now myeclipse doesnt work anymore, so it would be great to support M5 or M6 which will get released
in 2 weeks from now.

Thanks in advance!
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
noviforum
Post subject:   PostPosted: Mar 25, 2005 - 12:20 PM
Veteran Member
Veteran Member


Joined: Mar 10, 2005
Posts: 3

Hello, I had Eclipse 3.0.1 and MyEclipse (unfortuantely I can not remeber which version) installed prior I had to reinstall the whole OS again. I did a fresh install of Eclipse 3.1M5a and MyEclipse 3.8.4+QF2-BetaFor3.1

Now I can not Remove Web Project Capabilities nor Add it to my previous working project.

What is the latest known working pair of Eclipse and MyEclipse? Is there some config file in my project which I can manualy remove to remedy the situation or anything at all to make it work?

-bob
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-rkalla
Post subject:   PostPosted: Mar 25, 2005 - 05:05 PM
Registered Member
Registered Member


Joined: Jan 06, 2004
Posts: 23818

Bob,
You must use Eclipse 3.1M4, that's why in the download notes for that version, we say "This release will only work with Eclipse 3.1 M4", we weren't kidding ;)

_________________
Riyad
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
sureshs
Post subject:   PostPosted: Apr 03, 2005 - 05:31 AM
Registered Member
Registered Member


Joined: Jan 16, 2004
Posts: 3

So, any idea when the version compatible with 3.1M5 may become available? Also, when will 4.0 be ready as per your current roadmap?
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-rkalla
Post subject:   PostPosted: Apr 04, 2005 - 04:21 AM
Registered Member
Registered Member


Joined: Jan 06, 2004
Posts: 23818

4.0 is planned for late April, at that time we will make a release in line with the current Eclipse release (M6?) and continue to support 3.1 until final GA release. Sorry for the delays, we cannot derail to do an M5-specific release as we are in the home stretch for the 4.0 release.

_________________
Riyad
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits