MyEclipse Forums
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
support-scott
Post subject: MyEclipse 5.0 Milestone 1 for Eclipse 3.2 is Now Available  PostPosted: May 19, 2006 - 03:58 PM
Moderator
Moderator


Joined: May 06, 2003
Posts: 6761

Version 5.0 Milestone 1 of MyEclipse Enterprise Workbench for Windows, Linux, and Macintosh for Eclipse 3.2 is now available in the Downloads section. This release is a ported and enhanced version of MyEclipse 4.1.1 to the Eclipse 3.2/WTP 1.5 platform. More information can can be found in the official announcement on the News page and the New & Noteworthy section shows you what's been added since MyEclipse 4.1.1.

Milestone Warning
This release is a developmental milestone release, not a full production release. At the time of this release all platform components (Eclipse 3.2 / WTP 1.5) are still in an early release candidate state. While we've made every effort to ensure backward compatibility with MyEclipse 4.1.1, due to the immaturity of the platform components and amount of effort we had to expend to port to them, we currently do not recommend this release as a replacement for MyEclipse 4.1.1 GA. This release is intended for users who either must use Eclipse 3.2, do not have an Eclipse 3.1.2 build for their platform, or those that want a preview of our future direction to provide us constructive feedback during the MyEclipse 5.0 development timeline.

You may install both MyEclipse 4.1.1 and MyEclipse 5.0M1 on the same machine without conflict, provided that separate Eclipse installations are used (3.1.2 for MyEclipse 4.1.1 and 3.2 for MyEclipse 5.0M1). For testing MyEclipse 5.0M1, we recommend that you do not use a production workspace that you will also need to use with MyEclipse 4.1.1 as a precaution.

Upgrading from prior versions
Since this release provides support for a completely new Eclipse SDK platform (3.2) there is no upgrade path from prior MyEclipse versions due to platform API changes. A full installation must be performed for this release, however follow-on releases of MyEclipse 5.0 will be available using the Eclipse update manager.

Installing MyEclipse 5.0 Milestone 1
The only prerequisites required before installing MyEclipse 5.0M1 are the presence of a Java JDK (available from Sun) and an existing Eclipse 3.2 SDK installation (available from Eclipse). Note:You do not need to install any components from the Callisto simultaneous release since all required platform dependencies (WTP 1.5 etc) are already included in the MyEclipse distribution.

Once the prerequisites are installed, you can download one of the platform-specific installers from the 'Development Releases' section of the MyEclipse Downloads page.

You may install both MyEclipse 4.1.1 and MyEclipse 5.0M1 on the same machine without conflict, provided that separate Eclipse installations are used. For testing MyEclipse 5.0M1, we recommend that you do not use a production workspace that you will need to use with MyEclipse 4.1.1 again as a precaution.

Installing Matisse4MyEclipse 5.0M1
Matisse4MyEclipse is not shipped as part of the 5.0M1 distribution. However, once 5.0M1 is installed you can install Matisse4MyEclipse from the MyEclipse update site by selecting Help > Software Updates > Find and Install... > Search for new features to install... On the next panel, select "New Remote Site" and enter a name of "MyEclipse Update Site" and a URL of "http://downloads1.myeclipseide.com/downloads/products/eworkbench/updates-5.0/" and click OK. Select 'Finish' and Matisse4MyEclipse will display as an update from the MyEclipse update site for installation once the check is performed.

If you'd rather install from a local update site, we provide an archived update site that contains only the Matisse4MyEclipse 5.0M1 update in the Development Releases download section as an option.

To find out the differences between the Standard and Professional versions, please see this link:
http://www.myeclipseide.com/images/credit_card/me_pro_info.html

Prerequisites
You'll need a fresh Eclipse 3.2 SDK (RC4 or later) installation and JDK 1.4.2_05+ or JDK 1.5 on Windows or Mac, and *only* JDK 1.5 on Linux.

_________________
--Scott
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits