MyEclipse Forums
This thread has been locked & this forum has been archived.
Please post new topics to General Development
View previous topic Printable version Log in to check your private messages View next topic
Author Message
ragnarwestad
Post subject: Added JPanel to JTabbedPane disappears immediately  PostPosted: Sep 18, 2006 - 10:12 PM
Registered Member
Registered Member


Joined: Aug 30, 2005
Posts: 4

Hi folks,

I just bought MyEclipse 5.0 and installed Matisse on it. I'm running Java 1.5.0_06 on Windows XP.

Ran into some trouble with JTabbedPane. When I try to add a JPanel to a JTabbedPane it disappears almost immediately. I see the tab and its name for a split second and then its gone.

This seems to happen consistently when I add from the menu (Right Click | Add From Palette | Swing | JPanel), but less frequently when dragging and dropping the JPanel's on the JTabbedPane (BTW, I find it rather hard to hit the JTabbedPane when dragging and dropping).

Anyone have a clue what this is about?

/Ragnar
 
 View user's profile Send private message  
Reply with quote Back to top
support-rkalla
Post subject:   PostPosted: Sep 20, 2006 - 06:18 AM
Registered Member
Registered Member


Joined: Jan 06, 2004
Posts: 23818

Ragnar,
Can you check your log file (<workspace dir>\.metadata\.log) for messages that could be written out when this operation goes bonkers? Also just to clarify, it's not every time, just sometimes? And when it does happen, all you have to do is re-do the operation until it stops disappearing and everything works fine? You aren't getting oodles of variables like jPanel1, 2, 3, 4, 5, 6 and so on until it finally works are you?

_________________
Riyad
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
ragnarwestad
Post subject:   PostPosted: Oct 02, 2006 - 07:46 PM
Registered Member
Registered Member


Joined: Aug 30, 2005
Posts: 4

Hi Riyad, and thanks for the reply.

Sorry for the long delay. Had some trouble with my computer and had to reinstall Win XP.
It's back up again now and I have reinstalled both MyEclipse and Matisse.
The same thing happens and there is nothing in the log files.

However, I noticed during Matisse install that I got a warning that there would be potensial problems due to
different versions of GEF. I think I had v3.2 installed and Matisse relied on 3.1? I continued installation
and afterwords removed any sign of GEF 3.1 under <Eclipse dir>/[plugin | features], but it did not help.

So I am still a bit lost here. Nobody else have this problem?

/Ragnar
 
 View user's profile Send private message  
Reply with quote Back to top
support-rkalla
Post subject:   PostPosted: Oct 02, 2006 - 08:29 PM
Registered Member
Registered Member


Joined: Jan 06, 2004
Posts: 23818

Ragnar,
I am having a heck of a time trying to reproduce this with two of my test installs. Can you go to MyEclipse > Installation Summary > INstallation Details and paste the result here for me?

_________________
Riyad
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
ragnarwestad
Post subject:   PostPosted: Oct 02, 2006 - 09:14 PM
Registered Member
Registered Member


Joined: Aug 30, 2005
Posts: 4

Yup. Here it is at the bottom.
First, I did some more test and found out that:

- if I d&d from the palette I am now able to add JPanels to the JTabbedPane pretty consistently.
It is still hard to hit the target, but I am improving. And most importantly, the JPanel does not go away,
so this actually works.
- I am still not able to add the JPanel using right click and "Add From Palette" in the Outline view.
The JPanel just says hello and then disappears. One new observation though: If immediately after
trying I go to "Edit -> Redo" in Eclipse the JPanel is added AND stays there! But alas, now I am
not able to save the form. I get an error dialog saying "Save failed:null". And still nothing in the .log file.
After doing "Edit -> Undo" the added JPanel goes away and I can save the form.

Riyad, don't give this a high priority for my sake. I am just playing around with it. And the first method
actually works. But I will hang around and watch this space in case you need more informaton.

Matisse is cool!

/Ragnar :-)


*** Date: Mon Oct 02 10:02:52 CEST 2006

*** System properties:
OS=WindowsXP
OS version=5.1
Java version=1.5.0_08

*** MyEclipse details:
MyEclipse Enterprise Workbench

Version: 5.0 GA
Build id: 20060805-5.0-GA

*** Eclipse details:
MyEclipse Enterprise Workbench

Version: 5.0.1 GA
Build id: 20060810-5.0.1-GA

Eclipse Graphical Editing Framework

Version: 3.2.0.v20060626
Build id: 20060921-1617

Eclipse Platform

Version: 3.2.0.v20060609m-AgOexn6hlEUsvBO
Build id: M20060629-1905

Eclipse Java Development Tools

Version: 3.2.0.v20060609m-F7snq1fxia-Z4XP
Build id: M20060629-1905

Eclipse Graphical Editing Framework

Version: 3.2.1.v20060921
Build id: 20060921-1617

Eclipse RCP

Version: 3.2.0.v20060609m-SVDNgVrNoh-MeGG
Build id: M20060629-1905

Eclipse Plug-in Development Environment

Version: 3.2.0.v20060609m------6zXJJzJzJq
Build id: M20060629-1905

Eclipse Project SDK

Version: 3.2.0.v20060609m-GNq6oQq-7es-Y81
Build id: M20060629-1905

Eclipse startup command=-os
win32
-ws
win32
-arch
x86
-launcher
C:\eclipse\eclipse.exe
-name
Eclipse
-showsplash
600
-exitdata
ad8_74
-product
com.genuitec.myeclipse.product.ide
-vm
C:\WINDOWS\system32\javaw.exe
 
 View user's profile Send private message  
Reply with quote Back to top
support-rkalla
Post subject:   PostPosted: Oct 02, 2006 - 09:47 PM
Registered Member
Registered Member


Joined: Jan 06, 2004
Posts: 23818

Thank you for the scenarios, those are very important in our testing. With your steps outlined, I was able to reproduce the bug right away (before I was using DnD, not right click). I will file this.

_________________
Riyad
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits