MyEclipse Forums
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
support-rkalla
Post subject: Linux Visual HTML/JSP Designer Hotfix  PostPosted: Oct 14, 2006 - 01:43 AM
Registered Member
Registered Member


Joined: Jan 06, 2004
Posts: 23818

For Linux Users Only

The MyEclipse developers have been hard at work assembling some fixes for the Visual HTML/JSP Designer on linux to help correct some of the instability issues that people have been seeing and we've prepared a Early Access patch for some of these issues that we would like any of our Linux users that are willing, to try it out.

We'd like to reiterate that this is an Early Access release intended to test some of the fixes for the designer to see if they should be rolled into the main product. We would discourage developers in production environments from installing this that need the designer to get work done but would encourage anyone willing to help us troubleshoot and give us feedback to install it.

Please be sure to follow the instructions very closely after downloading the patch to make sure it's installed correctly.

Download Link
http://downloads.myeclipseide.com/downloads/products/eworkbench/5.0.1-HotFix/ME-5.0.1-HotFix-20061004.zip

Instructions
Requirments
- Eclipse 3.2.0 SDK
- MyEclipse 5.0.1

Background
The ME-5.0.1-HotFix-20061004.zip includes replacement plugins for the
com.genuitec.javascript.debug.mozilla and org.mozilla.xpcom plugins.
The installation process overwrite the older plugins with the newer
versions when this archive is unzipped.

Install Steps
1. Shutdown all instances of Eclipse/MyEclipse
2. Unzip ME-5.0.1-HotFix-20061004.zip into the MyEclipse directory:

<myeclipse install directory>/eclipse

3. Because this process replaces existing plugins you should be prompted to
overwrite files when you unzip the archive. If you are not prompted to
overwrite you have not unzipped the archive into the correct location.
4. Create a script called myeclipse.sh in your eclipse installation directory
that that contains the following lines, while supplying the two
installation directories indicated:

Code:

      #!/bin/bash
      PATH=$PATH:./
      ECLIPSE_HOME=[your-eclipse-install-directory]
      MYECLIPSE_HOME=[your-myeclipse-install-directory]
      export MOZILLA_FIVE_HOME=""
      cd $ECLIPSE_HOME
      eclipse -clean -product com.genuitec.myeclipse.product.ide -vmargs -Duser.language=en -Xms128M -Xmx512M -XX:PermSize=64M -XX:MaxPermSize=256M -Dosgi.splashLocation="$MYECLIPSE_HOME/eclipse/MyEclipseSplash.bmp"


5. Start MyEclipse using myeclipse.sh
6. After the first successful startup, the -clean argument can be removed
from the script.

_________________
Riyad
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
arjan.tijms
Post subject:   PostPosted: Oct 17, 2006 - 09:35 AM
Registered Member
Registered Member


Joined: Mar 15, 2004
Posts: 185

About the startup command, is the "-product com.genuitec.myeclipse.product.ide" really required for a stable product? I thought it was only appearance and would rather not use it.
 
 View user's profile Send private message  
Reply with quote Back to top
arjan.tijms
Post subject:   PostPosted: Oct 17, 2006 - 09:57 AM
Registered Member
Registered Member


Joined: Mar 15, 2004
Posts: 185

Quote:

3. Because this process replaces existing plugins you should be prompted to
overwrite files when you unzip the archive. If you are not prompted to
overwrite you have not unzipped the archive into the correct location.


I extracted in the [MyEclipse]/eclipse directory, but only 2 files were prompted to be overwritten:

Code:

... few hundres entries...
 extracting: plugins/com.genuitec.javascript.debug.mozilla_5.0.2/XPCOM/os/win32/mozilla/softokn3.chk
  inflating: plugins/com.genuitec.javascript.debug.mozilla_5.0.2/XPCOM/os/win32/mozilla/softokn3.dll
  inflating: plugins/com.genuitec.javascript.debug.mozilla_5.0.2/XPCOM/os/win32/mozilla/ssl3.dll
  inflating: plugins/com.genuitec.javascript.debug.mozilla_5.0.2/XPCOM/os/win32/mozilla/xpcom.dll
  inflating: plugins/com.genuitec.javascript.debug.mozilla_5.0.2/XPCOM/os/win32/mozilla/xul.dll
replace plugins/org.mozilla.xpcom_1.8.1.0/META-INF/MANIFEST.MF? [y]es, [n]o, [A]ll, [N]one, [r]ename: y
  inflating: plugins/org.mozilla.xpcom_1.8.1.0/META-INF/MANIFEST.MF
replace plugins/org.mozilla.xpcom_1.8.1.0/MozillaInterfaces.jar? [y]es, [n]o, [A]ll, [N]one, [r]ename: y
  inflating: plugins/org.mozilla.xpcom_1.8.1.0/MozillaInterfaces.jar
  inflating: plugins/org.mozilla.xpcom_1.8.1.0/plugin.properties


Is that what should have happened?
 
 View user's profile Send private message  
Reply with quote Back to top
arjan.tijms
Post subject:   PostPosted: Oct 17, 2006 - 12:42 PM
Registered Member
Registered Member


Joined: Mar 15, 2004
Posts: 185

I just got this when I tried to save in the JSP editor:

signal 11 occured at b7f6d180
#
# An unexpected error has been detected by Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x0639d3a2, pid=3871, tid=3046656944
#
# Java VM: Java HotSpot(TM) Client VM (1.6.0-beta2-b86 mixed mode, sharing)
# Problematic frame:
# V [libjvm.so+0x39d3a2]
#
# An error report file with more information is saved as hs_err_pid3871.log
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
#

I'll continue testing with Java 5.0 U8 instead. If you'd like I can send you the log file.
 
 View user's profile Send private message  
Reply with quote Back to top
arjan.tijms
Post subject:   PostPosted: Oct 17, 2006 - 02:22 PM
Registered Member
Registered Member


Joined: Mar 15, 2004
Posts: 185

Continued testing with Java 5.0 U8 as promissed. After a couple of succesful saves, I got a JVM crash again. This happened at exactly the same point as with the other crash; just after saving in a JSP file.

Code:

#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
#  Internal Error (53414645504F494E540E43505001E8), pid=15355, tid=3085100736
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0_08-b03 mixed mode, sharing)
# An error report file with more information is saved as hs_err_pid15355.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
#


One thing that I didn't see with the Java 6.0 JDK (but something I did see before with the unpatched 5.01) is a long list of signal 11's :

Code:

signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
signal 11 occured at 0
... some hundred entries orso more...
 
 View user's profile Send private message  
Reply with quote Back to top
arjan.tijms
Post subject:   PostPosted: Oct 17, 2006 - 02:34 PM
Registered Member
Registered Member


Joined: Mar 15, 2004
Posts: 185

After restarting Eclipse, I tried to save in the same jsp file, and the editor hang. Had to kill it. After restarting Eclipse and opening the same file I noticed the file had been saved prior to the hang. Upon trying to safe it once more, I immediately got the same crash again:

Code:

signal 11 occured at b7eed46c
#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
#  SIGSEGV (0xb) at pc=0xb7719956, pid=22656, tid=2988673968
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0_08-b03 mixed mode, sharing)
# Problematic frame:
# V  [libjvm.so+0x129956]
#
# An error report file with more information is saved as hs_err_pid22656.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
#
 
 View user's profile Send private message  
Reply with quote Back to top
arjan.tijms
Post subject:   PostPosted: Oct 17, 2006 - 04:25 PM
Registered Member
Registered Member


Joined: Mar 15, 2004
Posts: 185

Tried to update to the latest Java 5.0 U9. For a short while saving in the JSP editor succeeded, but after a while I got a new error which I never saw before. In the console there was the dreaded signal 11 again, but this time instead of crashing the VM, a dialog popped up saying:

Code:

Save Failed:A native exception has occurred during XPCOM method invocation (0xb)


This time there was actually a helpfull message in the error log:

Code:

!ENTRY org.eclipse.ui.browser 2 0 2006-10-17 17:17:13.109
!MESSAGE Internal browser is not available: XPCOM error -2147221164

!ENTRY org.eclipse.ui 4 4 2006-10-17 17:18:10.347
!MESSAGE Save Failed

!ENTRY org.eclipse.ui 2 0 2006-10-17 17:18:10.348
!MESSAGE Save Failed
!STACK 0
org.mozilla.xpcom.XPCOMException: A native exception has occurred during XPCOM method invocation  (0xb)
   at org.mozilla.xpcom.internal.XPCOMJavaProxy.callXPCOMMethod(Native Method)
   at org.mozilla.xpcom.internal.XPCOMJavaProxy.invoke(XPCOMJavaProxy.java:140)
   at $Proxy10.loadURI(Unknown Source)
   at org.eclipse.swt.browser.AbstractMozillaBrowser.setUrl(AbstractMozillaBrowser.java:1210)
   at com.genuitec.eclipse.webdesigner3.design.MozillaEditor.loadURL(MozillaEditor.java:1255)
   at com.genuitec.eclipse.webdesigner3.design.DesignEditSystem.setEditorDocumentRoot(DesignEditSystem.java:114)
   at com.genuitec.eclipse.webdesigner3.design.DesignEditSystem.synchronize(DesignEditSystem.java:165)
   at com.genuitec.eclipse.webdesigner3.AbstractEditSystem.setSynchronized(AbstractEditSystem.java:24)
   at com.genuitec.eclipse.webdesigner3.WebDesigner3.setSynchronized(WebDesigner3.java:83)
   at com.genuitec.eclipse.webdesigner3.editors.WebDesignerMultiPageEditor.checkSynchronization(WebDesignerMultiPageEditor.java:577)
   at com.genuitec.eclipse.webdesigner3.editors.WebDesignerMultiPageEditor.doSave(WebDesignerMultiPageEditor.java:464)
   at org.eclipse.ui.internal.SaveableHelper$1.run(SaveableHelper.java:131)
   at org.eclipse.ui.internal.SaveableHelper$4.run(SaveableHelper.java:252)
   at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:369)
   at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:313)
   at org.eclipse.jface.window.ApplicationWindow$1.run(ApplicationWindow.java:763)
   at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:67)
   at org.eclipse.jface.window.ApplicationWindow.run(ApplicationWindow.java:760)
   at org.eclipse.ui.internal.WorkbenchWindow.run(WorkbenchWindow.java:2283)
   at org.eclipse.ui.internal.SaveableHelper.runProgressMonitorOperation(SaveableHelper.java:258)
   at org.eclipse.ui.internal.SaveableHelper.savePart(SaveableHelper.java:136)
   at org.eclipse.ui.internal.EditorManager.savePart(EditorManager.java:1386)
   at org.eclipse.ui.internal.WorkbenchPage.savePart(WorkbenchPage.java:2995)
   at org.eclipse.ui.internal.WorkbenchPage.saveEditor(WorkbenchPage.java:3008)
   at org.eclipse.ui.internal.SaveAction.run(SaveAction.java:67)
   at org.eclipse.jface.action.Action.runWithEvent(Action.java:499)
   at org.eclipse.jface.commands.ActionHandler.execute(ActionHandler.java:119)
   at org.eclipse.core.commands.Command.executeWithChecks(Command.java:461)
   at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:424)
   at org.eclipse.ui.internal.handlers.HandlerService.executeCommand(HandlerService.java:160)
   at org.eclipse.ui.internal.keys.WorkbenchKeyboard.executeCommand(WorkbenchKeyboard.java:466)
   at org.eclipse.ui.internal.keys.WorkbenchKeyboard.press(WorkbenchKeyboard.java:799)
   at org.eclipse.ui.internal.keys.WorkbenchKeyboard.processKeyEvent(WorkbenchKeyboard.java:846)
   at org.eclipse.ui.internal.keys.WorkbenchKeyboard.filterKeySequenceBindings(WorkbenchKeyboard.java:564)
   at org.eclipse.ui.internal.keys.WorkbenchKeyboard.access$3(WorkbenchKeyboard.java:506)
   at org.eclipse.ui.internal.keys.WorkbenchKeyboard$KeyDownFilter.handleEvent(WorkbenchKeyboard.java:122)
   at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
   at org.eclipse.swt.widgets.Display.filterEvent(Display.java:1343)
   at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1084)
   at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1109)
   at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1094)
   at org.eclipse.swt.widgets.Widget.sendKeyEvent(Widget.java:1121)
   at org.eclipse.swt.widgets.Widget.gtk_key_press_event(Widget.java:655)
   at org.eclipse.swt.widgets.Control.gtk_key_press_event(Control.java:2082)
   at org.eclipse.swt.widgets.Composite.gtk_key_press_event(Composite.java:637)
   at org.eclipse.swt.widgets.Widget.windowProc(Widget.java:1434)
   at org.eclipse.swt.widgets.Display.windowProc(Display.java:3798)
   at org.eclipse.swt.internal.gtk.OS._gtk_main_do_event(Native Method)
   at org.eclipse.swt.internal.gtk.OS.gtk_main_do_event(OS.java:5273)
   at org.eclipse.swt.widgets.Display.eventProc(Display.java:1135)
   at org.eclipse.swt.internal.gtk.OS._g_main_context_iteration(Native Method)
   at org.eclipse.swt.internal.gtk.OS.g_main_context_iteration(OS.java:1428)
   at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2840)
   at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:1914)
   at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1878)
   at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:419)
   at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
   at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:95)
   at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:78)
   at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:92)
   at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:68)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:177)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:585)
   at org.eclipse.core.launcher.Main.invokeFramework(Main.java:336)
   at org.eclipse.core.launcher.Main.basicRun(Main.java:280)
   at org.eclipse.core.launcher.Main.run(Main.java:977)
   at org.eclipse.core.launcher.Main.main(Main.java:952)
 
 View user's profile Send private message  
Reply with quote Back to top
arjan.tijms
Post subject:   PostPosted: Oct 17, 2006 - 04:31 PM
Registered Member
Registered Member


Joined: Mar 15, 2004
Posts: 185

Right after the previous error had occured, I tried to save once more and yet another error came up:

Code:

#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
#  SIGSEGV (0xb) at pc=0xa205f236, pid=28866, tid=3085297344
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0_09-b01 mixed mode, sharing)
# Problematic frame:
# C  [libxul.so+0x6d7236]  _ZN7nsFrame9BoxReflowER16nsBoxLayoutStateP13nsPresContextR19nsHTMLReflowMetricsRK17nsHTMLReflowStateRjiiiii+0x252
#
# An error report file with more information is saved as hs_err_pid28866.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
#
 
 View user's profile Send private message  
Reply with quote Back to top
support-rkalla
Post subject:   PostPosted: Oct 17, 2006 - 06:05 PM
Registered Member
Registered Member


Joined: Jan 06, 2004
Posts: 23818

Arjan,
Awesome feedback, I'm letting Greg know. Also if you use File > Switch Workspace to create a new workspace somewhere, then create a new web project and start editing a JSP page, is it really easy to reproduce the crashes then as well? (trying to rule out *any* polution)

_________________
Riyad
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-greg
Post subject:   PostPosted: Oct 17, 2006 - 06:10 PM
Moderator
Moderator


Joined: Mar 31, 2004
Posts: 1611

Arjan,

Thanks for the feedback. In your posted error logs, when the jvm crashes it writes out a log file like:
Code:
hs_err_pid28866.log
. Can you post the entire contents of one of these files?

However, I don't think your stability problems are related to the Visual HTML/JSP Designer. From your error logs it doesn't even look like it is coming up correctly.

First, are you launching MyEclipse using our shortcut and have you set the MOZILLA_FIVE_HOME="" in your environment? One quite way to tell is to try to launch the Web 2.0 Browser in the MyEclipse perspective in the toolbar. There is an icon with [2.0] written on it.

If that doesn't load could you post the error that is written in the error log? Window > Show View > PDE Runtime > Error Log

Are you are 64bit Linux? What distro?

_________________
Greg
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
arjan.tijms
Post subject:   PostPosted: Oct 18, 2006 - 10:58 AM
Registered Member
Registered Member


Joined: Mar 15, 2004
Posts: 185

support-greg wrote:
Arjan,

Thanks for the feedback. In your posted error logs, when the jvm crashes it writes out a log file like:
Code:
hs_err_pid28866.log
. Can you post the entire contents of one of these files?


Sure. They're a bit large to post in the forum, so I'll send them to support@myeclipseide.com with a link to this thread.

Quote:

However, I don't think your stability problems are related to the Visual HTML/JSP Designer. From your error logs it doesn't even look like it is coming up correctly.


I'm not sure. After a crash there's frequently a filed left in my workspace with the pattern [file in question]_wd3_init.html. You probably know the exact source of this file, but I would say this file relates to the Visual HTML/JSP Designer.

Note that I'm doing a lot of development in Eclipse, which is mainly at the pure Java layer. Sometimes we're making days in excess of 9 hours in which we're using a lot of parts of Eclipse; refactorings, (java) searches through hundreds of files, walking through call-hierarchies, etc etc. Eclipse never or rarely crashes. As soon as I edit a JSP page using the MyEclipse JSP editor, there is a very high chance that it crashes.

I was using MyEclipse 5.0.1 succesfully before (apart from the save failed:null errors). The only thing I upgraded in my system lately is Eclipse (3.2 to 3.2.1) and the subversive plugin (1.1.0 Mx to 1.1.0 M6). As I mentioned above, I did a completely clean install of Eclipse 3.2.1 and MyEclipse 5.0.1 prior to beginning the hotfix test.

Quote:

First, are you launching MyEclipse using our shortcut and have you set the MOZILLA_FIVE_HOME="" in your environment?


I did. The exact shortcut file I'm using is:

Code:

#!/bin/bash
PATH=$PATH:./
ECLIPSE_HOME=/home/arjan/programs/eclipse32
MYECLIPSE_HOME=/home/arjan/programs/MyEclipse32
export MOZILLA_FIVE_HOME=""
cd $ECLIPSE_HOME

eclipse -clean -product com.genuitec.myeclipse.product.ide -vmargs -Duser.language=en -Xms128M -Xmx512M -XX:PermSize=64M -XX:MaxPermSize=256M -Dosgi.splashLocation="$MYECLIPSE_HOME/eclipse/MyEclipseSplash.bmp"


Quote:

One quite way to tell is to try to launch the Web 2.0 Browser in the MyEclipse perspective in the toolbar. There is an icon with [2.0] written on it.


I tried that and it works. I get the MyEclipse browser, along with the DOM Inspector, JavaScript Scripts Inspector etc. Loading URL's in it also works. There are no messages in the error log when I bring this up.

Quote:

Are you are 64bit Linux? What distro?


I'm *not* using 64bit Linux. My distro is 32bit Debian testing (etch), using the 2.6.15-1-k7-smp kernel. My machine is a 3800+ X2 with 1GB of memory.
 
 View user's profile Send private message  
Reply with quote Back to top
peon303
Post subject:   PostPosted: Oct 31, 2006 - 03:54 PM
Veteran Member
Veteran Member


Joined: Jul 17, 2003
Posts: 5

Anytime I try to save a JSP file on my windows install I get a similar error???
Save Failed: A Native exception has occurred during XPCOM method invocation (0xc0000005)

!ENTRY org.eclipse.ui 2 0 2006-10-31 10:24:36.924
!MESSAGE Save Failed
!STACK 0
org.mozilla.xpcom.XPCOMException: A native exception has occurred during XPCOM method invocation (0xc0000005)
at org.mozilla.xpcom.internal.XPCOMJavaProxy.callXPCOMMethod(Native Method)
at org.mozilla.xpcom.internal.XPCOMJavaProxy.invoke(XPCOMJavaProxy.java:140)
at $Proxy17.appendChild(Unknown Source)
at com.genuitec.eclipse.webdesigner3.DOMCoordinator.addSyntheticDesignNodesToDocument(DOMCoordinator.java:356)
at com.genuitec.eclipse.webdesigner3.DOMCoordinator.synchronizeDOMsFromSource(DOMCoordinator.java:192)
at com.genuitec.eclipse.webdesigner3.design.DesignEditSystem.synchronize(DesignEditSystem.java:167)
at com.genuitec.eclipse.webdesigner3.AbstractEditSystem.setSynchronized(AbstractEditSystem.java:24)
at com.genuitec.eclipse.webdesigner3.WebDesigner3.setSynchronized(WebDesigner3.java:83)
at com.genuitec.eclipse.webdesigner3.editors.WebDesignerMultiPageEditor.checkSynchronization(WebDesignerMultiPageEditor.java:577)
at com.genuitec.eclipse.webdesigner3.editors.WebDesignerMultiPageEditor.doSave(WebDesignerMultiPageEditor.java:464)
at org.eclipse.ui.internal.SaveableHelper$1.run(SaveableHelper.java:131)
at org.eclipse.ui.internal.SaveableHelper$4.run(SaveableHelper.java:252)
at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:369)
at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:313)
at org.eclipse.jface.window.ApplicationWindow$1.run(ApplicationWindow.java:763)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:67)
at org.eclipse.jface.window.ApplicationWindow.run(ApplicationWindow.java:760)
at org.eclipse.ui.internal.WorkbenchWindow.run(WorkbenchWindow.java:2283)
at org.eclipse.ui.internal.SaveableHelper.runProgressMonitorOperation(SaveableHelper.java:258)
at org.eclipse.ui.internal.SaveableHelper.savePart(SaveableHelper.java:136)
at org.eclipse.ui.internal.EditorManager.savePart(EditorManager.java:1386)
at org.eclipse.ui.internal.WorkbenchPage.savePart(WorkbenchPage.java:2995)
at org.eclipse.ui.internal.WorkbenchPage.saveEditor(WorkbenchPage.java:3008)
at org.eclipse.ui.internal.SaveAction.run(SaveAction.java:67)
at org.eclipse.jface.action.Action.runWithEvent(Action.java:499)
at org.eclipse.jface.commands.ActionHandler.execute(ActionHandler.java:119)
at org.eclipse.core.commands.Command.executeWithChecks(Command.java:461)
at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:424)
at org.eclipse.ui.internal.handlers.HandlerService.executeCommand(HandlerService.java:160)
at org.eclipse.ui.internal.keys.WorkbenchKeyboard.executeCommand(WorkbenchKeyboard.java:466)
at org.eclipse.ui.internal.keys.WorkbenchKeyboard.press(WorkbenchKeyboard.java:799)
at org.eclipse.ui.internal.keys.WorkbenchKeyboard.processKeyEvent(WorkbenchKeyboard.java:846)
at org.eclipse.ui.internal.keys.WorkbenchKeyboard.filterKeySequenceBindings(WorkbenchKeyboard.java:564)
at org.eclipse.ui.internal.keys.WorkbenchKeyboard.access$3(WorkbenchKeyboard.java:506)
at org.eclipse.ui.internal.keys.WorkbenchKeyboard$KeyDownFilter.handleEvent(WorkbenchKeyboard.java:122)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
at org.eclipse.swt.widgets.Display.filterEvent(Display.java:982)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:927)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:952)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:937)
at org.eclipse.swt.widgets.Widget.sendKeyEvent(Widget.java:965)
at org.eclipse.swt.widgets.Widget.sendKeyEvent(Widget.java:961)
at org.eclipse.swt.widgets.Widget.wmChar(Widget.java:1275)
at org.eclipse.swt.widgets.Control.WM_CHAR(Control.java:3346)
at org.eclipse.swt.widgets.Control.windowProc(Control.java:3246)
at org.eclipse.swt.widgets.Display.windowProc(Display.java:4025)
at org.eclipse.swt.internal.win32.OS.DispatchMessageW(Native Method)
at org.eclipse.swt.internal.win32.OS.DispatchMessage(OS.java:1925)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2966)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:1914)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1878)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:419)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:95)
at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:78)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:92)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:68)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:177)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.core.launcher.Main.invokeFramework(Main.java:336)
at org.eclipse.core.launcher.Main.basicRun(Main.java:280)
at org.eclipse.core.launcher.Main.run(Main.java:977)
at org.eclipse.core.launcher.Main.main(Main.java:952)


My Configuration (Windows Xp, Eclipse 3.2.1, MyEclipse 5.0.1)

*** System properties:
GRE_HOME=C:\Program Files\MyEclipse 5.0GA\eclipse\plugins\com.genuitec.javascript.debug.mozilla_5.0.1\XPCOM\os\win32\mozilla
awt.toolkit=sun.awt.windows.WToolkit
eclipse.buildId=M20060629-1905
eclipse.commands=-os
win32
-ws
win32
-arch
x86
-launcher
C:\dev\eclipse32\eclipse\eclipse.exe
-name
Eclipse
-showsplash
600
-exitdata
a9c_cc
-vmargs -Xms512M -Xmx1024M -XX:PermSize=128M -XX:MaxPermSize=256M
-product
com.genuitec.myeclipse.product.ide
-vm
C:\WINDOWS\system32\javaw.exe
eclipse.ee.install.verify=false
eclipse.product=org.eclipse.sdk.ide
eclipse.startTime=1162309818406
eclipse.vm=C:\WINDOWS\system32\javaw.exe
eclipse.vmargs=-Duser.language=en
-Xms512M
-Xmx1024M
-XX:PermSize=128M
-XX:MaxPermSize=256M
-jar
C:\dev\eclipse32\eclipse\startup.jar
eof=eof
file.encoding=Cp1252
file.encoding.pkg=sun.io
file.separator=\
java.awt.graphicsenv=sun.awt.Win32GraphicsEnvironment
java.awt.printerjob=sun.awt.windows.WPrinterJob
java.class.path=C:\dev\eclipse32\eclipse\startup.jar
java.class.version=49.0
java.endorsed.dirs=C:\Program Files\Java\jre1.5.0_09\lib\endorsed
java.ext.dirs=C:\Program Files\Java\jre1.5.0_09\lib\ext
java.home=C:\Program Files\Java\jre1.5.0_09
java.io.tmpdir=C:\DOCUME~1\adam.GMS\LOCALS~1\Temp\

<SNIP>

java.runtime.name=Java(TM) 2 Runtime Environment, Standard Edition
java.runtime.version=1.5.0_09-b03
java.specification.name=Java Platform API Specification
java.specification.vendor=Sun Microsystems Inc.
java.specification.version=1.5
java.vendor=Sun Microsystems Inc.
java.vendor.url=http://java.sun.com/
java.vendor.url.bug=http://java.sun.com/cgi-bin/bugreport.cgi
java.version=1.5.0_09
java.vm.info=mixed mode
java.vm.name=Java HotSpot(TM) Client VM
java.vm.specification.name=Java Virtual Machine Specification
java.vm.specification.vendor=Sun Microsystems Inc.
java.vm.specification.version=1.0
java.vm.vendor=Sun Microsystems Inc.
java.vm.version=1.5.0_09-b03
line.separator=

org.osgi.framework.bootdelegation=*
org.osgi.framework.executionenvironment=OSGi/Minimum-1.0,OSGi/Minimum-1.1,JRE-1.1,J2SE-1.2,J2SE-1.3,J2SE-1.4,J2SE-1.5
org.osgi.framework.language=en
org.osgi.framework.os.name=WindowsXP
org.osgi.framework.os.version=5.1
org.osgi.framework.processor=x86
<SNIP>
org.osgi.framework.vendor=Eclipse
org.osgi.framework.version=1.3.0
org.osgi.supports.framework.extension=true
os.arch=x86
os.name=Windows XP
os.version=5.1
osgi.arch=x86
osgi.bundles=org.eclipse.equinox.common@2:start, org.eclipse.update.configurator@3:start, org.eclipse.core.runtime@start
osgi.bundlestore=C:\dev\eclipse32\eclipse\configuration\org.eclipse.osgi\bundles
osgi.configuration.area=file:/C:/dev/eclipse32/eclipse/configuration/
osgi.framework=file:/c:/dev/eclipse32/eclipse/plugins/org.eclipse.osgi_3.2.1.R32x_v20060919.jar
osgi.framework.beginningstartlevel=1
osgi.framework.shape=jar
osgi.framework.version=3.2.1.R32x_v20060919
osgi.install.area=file:/C:/dev/eclipse32/eclipse/
osgi.instance.area=file:/C:/Documents and Settings/adam.GMS/workspace32/
osgi.instance.area.default=file:/C:/Documents and Settings/adam.GMS/workspace/
osgi.logfile=C:\Documents and Settings\adam.GMS\workspace32\.metadata\.log
osgi.manifest.cache=C:\dev\eclipse32\eclipse\configuration\org.eclipse.osgi\manifests
osgi.nl=en_US
osgi.os=win32
osgi.splashLocation=c:\dev\eclipse32\eclipse\plugins\org.eclipse.platform_3.2.0.v20060601\splash.bmp
osgi.splashPath=platform:/base/plugins/org.eclipse.platform
osgi.syspath=c:\dev\eclipse32\eclipse\plugins
osgi.ws=win32
path.separator=;
sun.arch.data.model=32
sun.boot.class.path=C:\Program Files\Java\jre1.5.0_09\lib\rt.jar;C:\Program Files\Java\jre1.5.0_09\lib\i18n.jar;C:\Program Files\Java\jre1.5.0_09\lib\sunrsasign.jar;C:\Program Files\Java\jre1.5.0_09\lib\jsse.jar;C:\Program Files\Java\jre1.5.0_09\lib\jce.jar;C:\Program Files\Java\jre1.5.0_09\lib\charsets.jar;C:\Program Files\Java\jre1.5.0_09\classes
sun.boot.library.path=C:\Program Files\Java\jre1.5.0_09\bin
sun.cpu.endian=little
sun.cpu.isalist=
sun.desktop=windows
sun.io.unicode.encoding=UnicodeLittle
sun.jnu.encoding=Cp1252
sun.management.compiler=HotSpot Client Compiler
sun.os.patch.level=Service Pack 2
user.country=US
user.dir=C:\dev\eclipse32\eclipse
user.home=C:\Documents and Settings\adam.GMS
user.language=en
user.name=adam
user.timezone=GMT-05:00
user.variant=
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-rkalla
Post subject:   PostPosted: Oct 31, 2006 - 05:30 PM
Registered Member
Registered Member


Joined: Jan 06, 2004
Posts: 23818

Peon,
This is the wrong thread to post to (as this hotfix is just for Linux developers). I would say though that your problem will likely be fixed with our 5.0.3 release due out very shortly. We upgraded the underlying technology bridge in the designer quite a bit along with this hotfix and a few more that will be going into the designer for the 5.0.3 release.

_________________
Riyad
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
peon303
Post subject:   PostPosted: Oct 31, 2006 - 05:43 PM
Veteran Member
Veteran Member


Joined: Jul 17, 2003
Posts: 5

arjan.tijms gets the exact same error message I get and I did a search on the forums and didn't come up with any other place with similar errors.

I did post my own thread titled "XPCOM Error when saving JSP on windows"

When do you expect 5.0.3 to be released?

Adam
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
knewman00
5 Post subject:   PostPosted: Nov 04, 2006 - 09:36 PM
Veteran Member
Veteran Member


Joined: Jul 20, 2006
Posts: 5

Maybe I'm missing something. Should com.genuitec.myeclipse.product.ide be changed to com.genuitec.myeclipse.product_5.0.1.jar?

When I use this startup command:
Code:

eclipse -clean -product com.genuitec.myeclipse.product.ide -vmargs -Duser.language=en -Xms128M -Xmx512M -XX:PermSize=64M -XX:MaxPermSize=256M -Dosgi.splashLocation="$MYECLIPSE_HOME/eclipse/MyEclipseSplash.bmp"


I get the following error message (slightly edited):
An error has occurred. See the log file
<home dir>/.eclipse/org.eclipse.platform_3.1.1.1/configuration/1162674965237.log.

The contents of the log is:
!SESSION 2006-11-04 15:16:05.41 ------------------------------------------------
eclipse.buildId=M20050929-0840
java.version=1.5.0_09
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Framework arguments: -product com.genuitec.myeclipse.product.ide
Command-line arguments: -os linux -ws gtk -arch x86 -data <home dir>/.eclipse -clean -product com.genuitec.myeclipse.product.ide

!ENTRY org.eclipse.core.runtime 2006-11-04 15:16:07.372
!MESSAGE Product com.genuitec.myeclipse.product.ide could not be found.

!ENTRY org.eclipse.osgi 2006-11-04 15:16:07.377
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:204)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:376)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:163)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
at org.eclipse.core.launcher.Main.run(Main.java:973)
at org.eclipse.core.launcher.Main.main(Main.java:948)

Did I miss something?

thanks,

kln
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits