Post new topic   Reply to topic
Author Message
support-rkalla
Registered Member
Registered Member


Joined: Jan 06, 2004
Posts: 23818

DaveO, thank you for the feedback, the drop-in-and-work scenario is absolutely one we have to get right in a future release.

Is this the complaint the rest of you guys have as well, that it won't work with existing projects? If so that would give us a very focused point on which to enhance (which was already on our short list, but atleast know we know this is a show-stopper for the maven gurus).

_________________
Riyad
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
daorriss
Registered Member
Registered Member


Joined: Aug 10, 2005
Posts: 255

If you read this thread you'll see that's *exactly* the problem. One of the other posters mentioned 400 maven-based projects. Without being able to add maven support from ME to the project, he can't function within ME 6.5.

I think if you can't fix M4ME at least make it so those of use who want to use M2E can turn off M4E.

_________________
DaveO

The delusion that people care about what I think:
http://www.codethought.com/blog
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
msquared
Veteran Member
Veteran Member


Joined: Mar 02, 2004
Posts: 25

Like many others here, I find Maven4MyEclipse to be a major step BACKWARDS in functionality from the plain-old m2eclipse plugin.
What in the world were you thinking to actually REMOVE from m2eclipse the standard maven project structure?
Simply defies all belief!

Fortunately I have found that by deleting the items below, MyEclipse6.5 seems to work perfectly fine with the standard m2eclipse plugin instead of Maven4MyEclipse:
The only functional loss is that web deployments no longer filter out scope=provided or test, but I have a workaround for that.

features/com.genuitec.myeclipse.maven_6.5.1.zmyeclipse650200806
plugins/com.genuitec.eclipse.maven_6.5.1.zmyeclipse650200806.jar
plugins/com.genuitec.myeclipse.maven_6.5.1.zmyeclipse650200806
plugins/org.maven.ide.components.archetype_common_2.0.0.20080331-1600
plugins/org.maven.ide.components.maven_embedder_2.1.0.20080410-2200
plugins/org.maven.ide.components.maven_model_edit_1.0.0.20080331-1600
plugins/org.maven.ide.components.maven_scm_1.0.0.20080410-2200
plugins/org.maven.ide.components.nexus_indexer_1.0.0.20080331-1600
plugins/org.maven.ide.components.qname_1.0.0.20080331-1600
plugins/org.maven.ide.eclipse_0.9.3.zmyeclipse650200806.jar
plugins/org.maven.ide.eclipse.central_0.9.1.zmyeclipse650200806.jar
plugins/org.maven.ide.eclipse.scm_0.9.2.zmyeclipse650200806.jar
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
daorriss
Registered Member
Registered Member


Joined: Aug 10, 2005
Posts: 255

What's the workaround?

_________________
DaveO

The delusion that people care about what I think:
http://www.codethought.com/blog
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-rkalla
Registered Member
Registered Member


Joined: Jan 06, 2004
Posts: 23818

Guys,
While the removal of the plugin may work now, it's not a scenario we support or tested... so keep your eyes peeled for odd behavior *if* you decide to go down this path (like Wizards failing, stuff like that). If it works fine for you, then all the better.

Our official workaround for folks that must have m2eclipse support is to step back to 6.0.1 and install it there; I know we covered that, just reminding folks.

And as for the "Why did you remove XYZ from m2eclipse?!" question, I answered it earlier in the thread.

_________________
Riyad
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
ibrandt
Registered Member
Registered Member


Joined: Jul 13, 2006
Posts: 21

dustmachine wrote:
Here's what I did to manually uninstall Maven4MyEclipse: ...


Worked for me. Got a one-time error about restoring the workspace on start-up, but that was to be expected. I'm now back to contributing to maven based open-source projects on the side.

[Edit: Oops, missed page 2 of this thread at first. Deleting the list of features and plugins I removed as that's already been posted.]

I look forward to trying a Maven4MyEclipse that can import existing projects...
 
 View user's profile Send private message  
Reply with quote Back to top
leej



Joined: Sep 05, 2008
Posts: 2

Where is the link to 6.0.1?
 
 View user's profile Send private message  
Reply with quote Back to top
paolo_denti
Veteran Member
Veteran Member


Joined: Apr 15, 2005
Posts: 34

msquared wrote:
Like many others here, I find Maven4MyEclipse to be a major step BACKWARDS in functionality from the plain-old m2eclipse plugin.
What in the world were you thinking to actually REMOVE from m2eclipse the standard maven project structure?
Simply defies all belief!

Fortunately I have found that by deleting the items below, MyEclipse6.5 seems to work perfectly fine with the standard m2eclipse plugin instead of Maven4MyEclipse:
The only functional loss is that web deployments no longer filter out scope=provided or test, but I have a workaround for that
....


daorriss wrote:
What's the workaround?


yes, please, that could be interesting for everybody

thanks
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
paolo_denti
Veteran Member
Veteran Member


Joined: Apr 15, 2005
Posts: 34

leej wrote:
Where is the link to 6.0.1?

+1
i can find the 5.5 and 6.5 but not the 6.0.1
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
leej



Joined: Sep 05, 2008
Posts: 2

bump...

Really need the 6.0.1 version for Maven functionality...
 
 View user's profile Send private message  
Reply with quote Back to top
support-rkalla
Registered Member
Registered Member


Joined: Jan 06, 2004
Posts: 23818

Sorry guys, it got archived, here you go:
http://downloads.myeclipseide.com/downloads/products/eworkbench/6.0.1GA/MyEclipse_6.0.1GA_E3.3.1_FullStackInstaller.exe

Also, all this should be fixed in 7.0M2 and 7.0GA, so hopefully this "6.0.1+m2eclipse" is a temporary workaround, thanks for being patient.

_________________
Riyad
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
paolo_denti
Veteran Member
Veteran Member


Joined: Apr 15, 2005
Posts: 34

support-rkalla wrote:
Sorry guys, it got archived, here you go:
http://downloads.myeclipseide.com/downloads/products/eworkbench/6.0.1GA/MyEclipse_6.0.1GA_E3.3.1_FullStackInstaller.exe

Also, all this should be fixed in 7.0M2 and 7.0GA, so hopefully this "6.0.1+m2eclipse" is a temporary workaround, thanks for being patient.

could you please post the link for the os x version too ?
thanks
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-rkalla
Registered Member
Registered Member


Joined: Jan 06, 2004
Posts: 23818


_________________
Riyad
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
carinoh



Joined: Jan 17, 2008
Posts: 4

I would like a clarification on the subject of disabling Maven capabilities in MyElcipse 7. Are there no supported way to disable Maven in this release? Have you any plan for future release to make this possible?

We have about 200 using MyEclipse 6.0.1 and about 50-100 users with Eclipse 3.3. We will distribute Eclipse 3.4 next week but see no possibility to distribute the next release of MyEcipse 7 due to the Maven integration to MyEclispe. We are using build tools that are not compatible with Maven, and it is not on the horizont to do the conversion to Maven yet.
 
 View user's profile Send private message  
Reply with quote Back to top
support-eugene
Registered Member
Registered Member


Joined: May 12, 2005
Posts: 472

carinoh wrote:
I would like a clarification on the subject of disabling Maven capabilities in MyElcipse 7. Are there no supported way to disable Maven in this release? Have you any plan for future release to make this possible?

We have about 200 using MyEclipse 6.0.1 and about 50-100 users with Eclipse 3.3. We will distribute Eclipse 3.4 next week but see no possibility to distribute the next release of MyEcipse 7 due to the Maven integration to MyEclispe. We are using build tools that are not compatible with Maven, and it is not on the horizont to do the conversion to Maven yet.


1. You can disable Maven4MyEclipse on the preference page in MyEclipse 7.0 M2.
2. MyEclipse does not mandate using Maven with your project. It should not conflict with any tools.

_________________
Eugene
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
All times are GMT - 6 Hours
Post new topic   Reply to topic
® 2014 - Genuitec, LLC.