Post new topic   Reply to topic
Author Message
cherngje
Registered Member
Registered Member


Joined: Aug 04, 2005
Posts: 16

This is old news, however, m2eclipse has already become an Eclipse project. (http://www.earthtimes.org/articles/show/sonatype-to-lead-new-eclipse-project-to-integrate-maven-into-eclipse,450512.shtml). Moreover, Sonatype has have joined the Eclipse Foundation as a Strategic Developer. (http://www.marketwatch.com/news/story/sonatype-joins-eclipse-foundation-strategic/story.aspx?guid={30613CAA-BF78-4941-9C21-DB08684CE9C6}&dist=hppr). Seems very likely m2eclipse will be integrated into future Eclipse without separate installation steps. What does development team of MyEclipse think about these latest developments? If m2eclipse does get integrated with Eclipse release, will MyEclipse continues to have it's own special version of m2eclipse (Maven4MyEclipse)? If this is the case, will the development team of MyEclipse promise to solve the conflict issues that's currently introduced with MyEclispe 6.5?

Thanks
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-rkalla
Registered Member
Registered Member


Joined: Jan 06, 2004
Posts: 23818

cherngje,
Our mission statement has always been to provide tools that enhance developer's productivity and we will continue to work with you guys to do that.

If m2eclipse gets integrated and shipped with Eclipse, e.g. 3.5, that's fine. MyEclipse, as a product, will continue to ship whatever tooling makes the most sense for our users.

This is basically the WTP question all over again from 3 years ago. It was a separate project and some folks were curious what will happen when WTP is integrated and shipped with Eclipse; we just kept doing what we do best... fixing bugs, integration and shipping a more cohesive/powerful feature set to our user base.

Maven is a brand-new thing for us and 6.5 signifies our first release of it and we will continue to enhance it according to user requirements. So if you have any feedback for us (what worked well, what didn't work at all) please let us know. We want to make sure we are keeping you guys happy.

_________________
Riyad
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
caryp
Registered Member
Registered Member


Joined: Jun 01, 2006
Posts: 8

I installed m2eclipse not realizing that MyEclipse 6.5 had a maven plugin. I seem to have had a conflict (both m2eclispe or Maven4MyEclipse preferences pages are getting exceptions) so I disabled the m2eclipse plugin. Even though m2eclipse is disabled, I am still getting a java.lang.NoClassDefFound error from Maven4MyEclipse preference page. I am unsure how to recover at this point -- do I have to reinstall MyEclipse 6.5 and start over?

Also, is there a way to disable Maven4MyEclipse?
 
 View user's profile Send private message  
Reply with quote Back to top
support-nipun
Registered Member
Registered Member


Joined: Apr 18, 2007
Posts: 8010

caryp,
Im afraid you will have to start over again. You cannot disable Maven4MyEclipse. Incase you want to use m2eclispe, you will have to revert back to MyEclipse 6.0.1.

_________________
Nipun
MyEclipse Support
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
EricAdriaansen
Registered Member
Registered Member


Joined: Jul 12, 2006
Posts: 3

Hi,

Is there a plan to be able to disable Maven4MyEclipse in 7.0? As a large group of Maven users, we were about ready to move off of MyEclipse due to lack of support, but then you came out with 6.5 and Maven support.....The problem is that (currently) Maven4MyEclipse is not yet as full featured as the third party plugin....

I feel that until Maven4MyEclipse fully supports all Maven features, you should give your customers the ability to choose either....otherwise all the Maven users in your group are stuck at 6.0.1...while non maven users are moving forward with 6.5, 7.x

Thanks.
 
 View user's profile Send private message  
Reply with quote Back to top
support-nipun
Registered Member
Registered Member


Joined: Apr 18, 2007
Posts: 8010

EricAdriaansen,
We have been monitoring the feedback from our Maven users and going forward, MyEclipse would support m2eclipse plugin so the Maven users are not stuck at 6.0.1.

_________________
Nipun
MyEclipse Support
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
support-rkalla
Registered Member
Registered Member


Joined: Jan 06, 2004
Posts: 23818

Guys the improvements that everyone has been demanding are being worked on right now for 7.0, I don't have a clear status update from dev (they were in-progress when I pinged them) but the first signs of it should be in 7.0M2, and our goal is to just open everything up if necessary, but otherwise to be a much smoother use-case for existing Maven projects (which is where we fell down face-first with our first-draft plans)

_________________
Riyad
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
All times are GMT - 6 Hours
Post new topic   Reply to topic
® 2014 - Genuitec, LLC.