MyEclipse Forums
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
support-rkalla
Post subject: [Troubleshoot] Debugging isn't working, why?  PostPosted: Dec 01, 2005 - 08:03 PM
Registered Member
Registered Member


Joined: Jan 06, 2004
Posts: 23818

Full debugging support for a application with MyEclipse requires that the application server being used fully supports the JSR 45 (http://www.jcp.org/en/jsr/detail?id=45) specification. This specification allows for full debugging of any Java classes (Beans, Servlets, EJBs, etc.) as well as full debugging for JSP files. For application servers that don't provide JSR 45 support, debugging for Java classes should still mostly work, but JSP debugging will not.

Some users have complained that certain servers that claim to support JSR 45 do a very poor job of debugging their JSPs, this is caused by those servers providing insufficient information in what is called a "source map" back to the debugger about the file being debugged. This makes it impossible for MyEclipse to accurately translate line and variable information during a debugging session.

The application server we usually encourage developers to use during development is Tomcat (a version of which is built into MyEclipse) or JBoss, if a full EJB container is necessary. Both fully support the JSR 45 specification and provide good debugging support.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits