MyEclipse Forums
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
snpe
Post subject: MyEclipse and Linux problem [Closed]  PostPosted: Jul 22, 2003 - 11:17 PM
Quality Board
Quality Board


Joined: Jul 05, 2003
Posts: 544

Hello,
I install myeclipse IDE on :
linux kernel 2.4.21, jdk 1.4.1, eclipse cvs 2.1.1 build 200306271545

installer get error, but I don't know where is install log for myEclipse
First screen can't scroll (install description screen)

When I start eclipse after install, I get myeclipse menu, but when
I create new project I have error in log file :
!SESSION Jul 23, 2003 01:26:11.87 ----------------------------------------------
java.version=1.4.1
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86 -install file:/u1/svasta/eclipse.new/
!ENTRY org.eclipse.ui 4 4 Jul 23, 2003 01:26:11.88
!MESSAGE Unable to find Action Set: com.genuitec.myeclipse.actions.server
!ENTRY com.objectlearn.jdt.j2ee 1 0 Jul 23, 2003 01:31:18.324
!MESSAGE Creating server definition manager[/u1/svasta/eclipse.new/plugins/com.objectlearn.jdt.j2ee/]
!ENTRY org.eclipse.ui 4 4 Jul 23, 2003 01:32:01.84
!MESSAGE Unhandled exception caught in event loop.
!ENTRY org.eclipse.ui 4 0 Jul 23, 2003 01:32:01.99
!MESSAGE Invalid Eclipse Base Version.
!STACK 0
<giant stacktrace elided />

at org.eclipse.core.launcher.Main.main(Main.java:583)
!SESSION Jul 23, 2003 02:43:46.505 ---------------------------------------------
java.version=1.4.2
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86 -install file:/u1/svasta/eclipse-3.0/result/eclipse/
!ENTRY org.eclipse.ui 4 4 Jul 23, 2003 02:43:46.520
!MESSAGE Unable to find Action Set: com.genuitec.myeclipse.actions.deploytools
!ENTRY org.eclipse.ui 4 4 Jul 23, 2003 02:43:46.537
!MESSAGE Unable to find Action Set: com.genuitec.myeclipse.actions
!ENTRY org.eclipse.ui 4 4 Jul 23, 2003 02:43:46.537
!MESSAGE Unable to find Action Set: com.genuitec.myeclipse.actions.webtools
!ENTRY org.eclipse.ui 4 4 Jul 23, 2003 02:43:46.538
!MESSAGE Unable to find Action Set: com.objfac.xmleditor.XMLActionSet
!ENTRY org.eclipse.ui 4 4 Jul 23, 2003 02:43:46.539
!MESSAGE Unable to find Action Set: com.omondo.uml.UMLElementCreationActionSet


Please help

regards
Haris Peco
 
 View user's profile Send private message  
Reply with quote Back to top
support-scott
Post subject:   PostPosted: Jul 23, 2003 - 12:07 AM
Moderator
Moderator


Joined: May 06, 2003
Posts: 6761

Haris,

It appears that you installed MyEclipse and associated it with an Eclipse install that also has the Objectlearn plugins and Omondo's stuff installed. MyEclipse is a pretty big product extension. Please try installing a clean release of Eclipse 2.1.0 or 2.1.1 and installing MyEclipse on that version. Once you have it working, you can reevaluate whether or not you need anything else.

--Scott
MyEclipse Support

_________________
--Scott
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
snpe
Post subject:   PostPosted: Jul 23, 2003 - 10:45 AM
Quality Board
Quality Board


Joined: Jul 05, 2003
Posts: 544

Hello Scott,
Yes, I have objectlearn and omondo plugin (I remove objectlearn
later), but this is not problem (I guess)

Problem 1 :
<scott: unnecessary hacks of plugin descriptors elided/>
Problem 3 :
Introduction window (after licence) haven't scroll bar and I don't see install information

Problem 4 :
I don't know where is install log for myeclipse - installer tell me
for error and install log

regards
Haris Peco
 
 View user's profile Send private message  
Reply with quote Back to top
support-michael
Post subject:   PostPosted: Jul 23, 2003 - 03:21 PM
Moderator
Moderator


Joined: May 05, 2003
Posts: 1042

The nature of your problem is your environment, not MyEclipse. I will repeat Scott's instructions: Please download and install a fresh copy of Eclipse 2.1.0 or 2.1.1 with the full JDT tools. Then reinstall MyEclipse to the new instance.

NOTE: The MyEclipse plugin descriptors are considered part of the MyEclipse internals and are off limits for modification. Please refrain from such activities in the future.

Michael
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
snpe
Post subject:   PostPosted: Jul 23, 2003 - 03:49 PM
Quality Board
Quality Board


Joined: Jul 05, 2003
Posts: 544

hello,
I don't make modification more - I try, myeclipse only
I want to use omondo UML with myeclipse and maybe anoter plugins.


regards
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits