MyEclipse Forums
This thread has been locked & this forum has been archived.
Please post new topics to General Development
View previous topic Printable version Log in to check your private messages View next topic
Author Message
jbobek
Post subject: Bug with setting User code for title in tabbed pane  PostPosted: Nov 28, 2007 - 10:14 PM
Registered Member
Registered Member


Joined: Aug 20, 2007
Posts: 1

Hi
I created tabbed pane with three tabs. I wants to set titles for these panes via <User Code> because i18n (bundle.getstring(key)). It works. When I save mattisse form i can see in XML file that there is :
Code:

<Container class="javax.swing.JPanel" name="jPanel2">
                  <Constraints>
                    <Constraint layoutClass="org.netbeans.modules.form.compat2.layouts.support.JTabbedPaneSupportLayout" value="org.netbeans.modules.form.compat2.layouts.support.JTabbedPaneSupportLayout$JTabbedPaneConstraintsDescription">
                      <JTabbedPaneConstraints tabName="&lt;User Code&gt;">
                        <Property name="tabTitle" type="java.lang.String" editor="org.netbeans.modules.form.RADConnectionPropertyEditor">
                          <Connection code="LRB.s4k(&quot;main.tabGatesTree.title&quot;)" type="code"/>

                       </Property>
                      </JTabbedPaneConstraints>
                    </Constraint>
                  </Constraints>


When I closed form, after while open it a change anything else (for example font for other component) via mattisse, after that I save it in XML file was this code:
Code:

                <Container class="javax.swing.JPanel" name="jPanel2">
                  <Constraints>
                    <Constraint layoutClass="org.netbeans.modules.form.compat2.layouts.support.JTabbedPaneSupportLayout" value="org.netbeans.modules.form.compat2.layouts.support.JTabbedPaneSupportLayout$JTabbedPaneConstraintsDescription">
                      <JTabbedPaneConstraints tabName="&lt;User Code&gt;">
                        <Property name="tabTitle" type="java.lang.String" value="&lt;User Code&gt;"/>
                      </JTabbedPaneConstraints>
                    </Constraint>
                  </Constraints>

All ma changes are lost and there is only one stupid string.
What and why it happen??
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-nipun
Post subject: RE: Bug with setting User code for title in tabbed pane  PostPosted: Nov 30, 2007 - 04:54 PM
Registered Member
Registered Member


Joined: Apr 18, 2007
Posts: 8012

Can you switch to a new workspace and try this out again. Incase you are able to reproduce this bug, can you please list the exact steps that need to be followed to reproduce this bug.

Also, please go to MyEclipse > Installation Summary > Installation Details and paste the information here for me so that this can be tested on the same version of MyEclipse.

_________________
Nipun
MyEclipse Support
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits