MyEclipse Forums
This thread has been locked & this forum has been archived.
Please post new topics to General Development
View previous topic Printable version Log in to check your private messages View next topic
Author Message
rickcr
Post subject: next editor key functionality not working on linux  PostPosted: Apr 17, 2008 - 08:50 PM
Registered Member
Registered Member


Joined: Aug 27, 2003
Posts: 26

On Linux (Suse10.3) I can not use ctrl-f6 to go to "next editor." It works fine on eclipse in windows (not sure about myeclipse there.)

I really have to have this functionality working so I hope it's easy to resolve. I often toggle between two files and having this really helps (I often rebind it to ctrl-tab as well.)

Can someone please confirm whether this is a bug?
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-rkalla
Post subject: RE: next editor key functionality not working on linux  PostPosted: Apr 18, 2008 - 05:59 PM
Registered Member
Registered Member


Joined: Jan 06, 2004
Posts: 23818

rickcr,
Have you confirm this key mapping is set correctly under Window > Prefs > General > Keys?

_________________
Riyad
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
rickcr
Post subject: RE: next editor key functionality not working on linux  PostPosted: Apr 18, 2008 - 06:16 PM
Registered Member
Registered Member


Joined: Aug 27, 2003
Posts: 26

Sorry, I feel dumb now... it looks like it's an issue with xfce destkop. ctrl-f6 is working fine in gnome and kde. I figured xfce would just use my gnome settings for keybindings so figured it would have been messed up in gnome as well. I'll investigate more the keybindings in xfce to see what's going on. I figured application keybindings would always take preference over desktop manager settings, but I guess that isn't the case? I'll see what I turn up.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-rkalla
Post subject: RE: next editor key functionality not working on linux  PostPosted: Apr 18, 2008 - 06:31 PM
Registered Member
Registered Member


Joined: Jan 06, 2004
Posts: 23818

No worries, let us know incase others find a similar issue.

_________________
Riyad
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
rickcr
Post subject: RE: next editor key functionality not working on linux  PostPosted: Apr 18, 2008 - 07:16 PM
Registered Member
Registered Member


Joined: Aug 27, 2003
Posts: 26

Yea that was it. Stupid xfce keybinding to the workspace desktop. Wish there was a way now to delete this post I started:)
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-rkalla
Post subject: RE: next editor key functionality not working on linux  PostPosted: Apr 18, 2008 - 08:09 PM
Registered Member
Registered Member


Joined: Jan 06, 2004
Posts: 23818

it's actually useful information, if someone else googles for "xfce myeclipse keybinding" or something like that, you never know, you might save someone a lot of time ;)

_________________
Riyad
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
typek_pb
Post subject: Re: RE: next editor key functionality not working on linux  PostPosted: Oct 24, 2012 - 11:51 AM



Joined: Oct 24, 2012
Posts: 3

this forum thread seem to be quite old one, but I'm facing the same issue now.
I'm also using eclipse in Xfce.
So, were you able to resolve the problem? If so, how?
Thanks.

rickcr wrote:
Sorry, I feel dumb now... it looks like it's an issue with xfce destkop. ctrl-f6 is working fine in gnome and kde. I figured xfce would just use my gnome settings for keybindings so figured it would have been messed up in gnome as well. I'll investigate more the keybindings in xfce to see what's going on. I figured application keybindings would always take preference over desktop manager settings, but I guess that isn't the case? I'll see what I turn up.
 
 View user's profile Send private message  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Oct 25, 2012 - 08:08 AM



Joined: Mar 09, 2011
Posts: 949

typek_pb,

I'm sorry you're seeing this issue. However, there doesn't seem to be anything we can do to get Xfce to forward the Ctrl+F6 key combination to the application, instead of processing it in the Xfce window manager. Ctrl+Fn causes a switch to Xfce workspace n. It's quite possible that you don't have six or more Xfce workspaces but that doesn't avoid Xfce consuming the key combination. I've tried removing the Ctrl+F6 setting with the Xfce settings application for the window manager but it didn't help. I tried removing the key binding from the Xfce system-wide key bindings file but that didn't help either.

You might get some solution if you ask on an Xfce or Xubuntu forum. However, there are a couple of workarounds you could try.


  1. Go to Window->Preferences->General->Keys. Search for the Next Editor command, select it, change the Binding and click Apply. To change the binding, you have to actually press the keys you want to use as the binding (like Ctrl-Alt-[, for example). This is an eclipse preference page, not a specific MyEclipse preference page.
  2. Use the key binding for Previous Editor instead. Shift-Ctrl-F6 is the default. This will just go through the editors in reverse order but might suit you.


Please let us know if this helps.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
typek_pb
Post subject:   PostPosted: Nov 15, 2012 - 12:10 PM



Joined: Oct 24, 2012
Posts: 3

thanks for feedback.

I have in the meantime submitted bug report to Xfce: https://bugzilla.xfce.org/show_bug.cgi?id=9478
 
 View user's profile Send private message  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Nov 15, 2012 - 10:56 PM



Joined: Mar 09, 2011
Posts: 949

Peter,

I hope the bug report gets some action. Thanks for letting us know.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
typek_pb
Post subject: workaround found!  PostPosted: Feb 27, 2013 - 11:36 AM



Joined: Oct 24, 2012
Posts: 3

I'm glad to inform you, that there is a workaround for the problem!

I've included it in the official xfce bug report as well. For those interested, see the blog entry I've written about the way I got it solved.
 
 View user's profile Send private message  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Feb 28, 2013 - 04:17 AM



Joined: Mar 09, 2011
Posts: 949

Thanks for posting this workaround, Peter. Any other users facing this problem will find it useful.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits