MyEclipse Forums
This thread has been locked & this forum has been archived.
Please post new topics to General Development
View previous topic Printable version Log in to check your private messages View next topic
Author Message
ryreeves
Post subject: Error when reverse-engineering certain classes  PostPosted: Jul 07, 2008 - 04:54 PM



Joined: Jul 07, 2008
Posts: 3

Hi,

Here is the error when trying to rev-eng an abstract class:

Creation of element failed.

Unrecognized object [Package: Owner/class
ru.novosoft.uml.model_management.MPackageImpl]

I'm running Eclipse 3.2 with MyEclipse 5.5.1 GA

Thanks,
Ryan
 
 View user's profile Send private message  
Reply with quote Back to top
support-nipun
Post subject: RE: Error when reverse-engineering certain classes  PostPosted: Jul 07, 2008 - 06:55 PM
Registered Member
Registered Member


Joined: Apr 18, 2007
Posts: 8012

Ryan,
Can you please go to MyEclipse > Installation Summary > Installation Details and paste the information here for me.

What is the error that gets logged under <workspace>/.metadata/.log file?

_________________
Nipun
MyEclipse Support
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
ryreeves
Post subject: RE: Error when reverse-engineering certain classes  PostPosted: Jul 07, 2008 - 07:39 PM



Joined: Jul 07, 2008
Posts: 3

I did not see any errors after attempting this. Do you want me to send you the class ?

Here are the Installation Details:

*** Date:
Monday, July 7, 2008 1:35:12 PM CDT

** System properties:
OS=WindowsXP
OS version=5.1
Java version=1.5.0_09


*** MyEclipse details:
MyEclipse Enterprise Workbench
Version: 5.5.1 GA
Build id: 20070521-5.5.1-GA


*** Eclipse details:
Eclipse SDK

Version: 3.2.2
Build id: M20070212-1330




Eclipse Platform

Version: 3.2.2.r322_v20070119-RQghndJN8IM0MsK
Build id: M20070212-1330


Eclipse Java Development Tools

Version: 3.2.2.r322_v20070104-R4CR0Znkvtfjv9-
Build id: M20070212-1330


Eclipse Plug-in Development Environment

Version: 3.2.1.r321_v20060823-6vYLLdQ3Nk8DrFG
Build id: M20070212-1330


Eclipse Project SDK

Version: 3.2.2.r322_v20070104-dCGKm0Ln38lm-8s
Build id: M20070212-1330


Eclipse Graphical Editing Framework

Version: 3.2.2.v20070208
Build id: 20070208-1315


Eclipse RCP

Version: 3.2.2.r322_v20070104-8pcviKVqd8J7C1U
Build id: M20070212-1330


Eclipse Graphical Editing Framework

Version: 3.2.2.v20070208
Build id: 20070208-1315




Eclipse startup command=-os
win32
-ws
win32
-arch
x86
-launcher
C:\eclipse\eclipse.exe
-name
Eclipse
-showsplash
600
-exitdata
370_8c
-data
c:\redi08.1\workspace
-vm
C:\WINDOWS\system32\javaw.exe
 
 View user's profile Send private message  
Reply with quote Back to top
support-nipun
Post subject: RE: Error when reverse-engineering certain classes  PostPosted: Jul 07, 2008 - 08:08 PM
Registered Member
Registered Member


Joined: Apr 18, 2007
Posts: 8012

Ryan,
We added support for Java 5 in MyEclipse 6.0, that might be the issue here. Could you please upgrade to MyEclipse 6.5 and test this again.

Let me know if the problem persists.

_________________
Nipun
MyEclipse Support
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
ryreeves
Post subject: RE: Error when reverse-engineering certain classes  PostPosted: Jul 09, 2008 - 09:00 PM



Joined: Jul 07, 2008
Posts: 3

I upgraded and still the same error. Here is my Installation Summary.

*** Date:
Wednesday, July 9, 2008 2:57:56 PM CDT

** System properties:
OS=WindowsXP
OS version=5.1
Java version=1.5.0_11


*** MyEclipse details:
MyEclipse Enterprise Workbench
Version: 6.5.0 GA
Build id: 6.5.0-GA-20080609


*** Eclipse details:
MyEclipse Enterprise Workbench

Version: 6.5.0 GA
Build id: 6.5.0-GA-20080609




Eclipse Platform

Version: 3.3.3.r33x_r20080129-_19UEl7Ezk_gXF1kouft
Build id: M20080221-1800


Eclipse RCP

Version: 3.3.3.r33x_r20080129-8y8eE9UEUWI6qujeED0xT7bc
Build id: M20080221-1800


Eclipse Java Development Tools

Version: 3.3.2.r33x_r20080129-7o7jE7_EDhYDiyVEnjb1pFd7ZGD7
Build id: M20080221-1800


Eclipse Plug-in Development Environment

Version: 3.3.3.r33x_r20080129-7N7M5DQVIA_6oJsEFkEL
Build id: M20080221-1800


Eclipse Project SDK

Version: 3.3.3.r33x_r20080129-7M7J7LB-u3aphGW6o3_VmiVfGXWO
Build id: M20080221-1800


Eclipse Graphical Editing Framework

Version: 3.3.2.v20080129
Build id: 20080221-1602




Eclipse startup command=-os
win32
-ws
win32
-arch
x86
-showsplash
-launcher
C:\Program Files\MyEclipse 6.5\eclipse\eclipse.exe
-name
Eclipse
--launcher.library
C:\Program Files\MyEclipse 6.5\eclipse\plugins\org.eclipse.equinox.launcher.win32.win32.x86_1.0.3.R33x_v20080118\eclipse_1023.dll
-startup
C:\Program Files\MyEclipse 6.5\eclipse\plugins\org.eclipse.equinox.launcher_1.0.1.R33x_v20080118.jar
-exitdata
10e8_84
-clean
-vm
C:\Program Files\MyEclipse 6.5\jre\bin\javaw.exe
 
 View user's profile Send private message  
Reply with quote Back to top
support-nipun
Post subject: RE: Error when reverse-engineering certain classes  PostPosted: Jul 10, 2008 - 06:24 PM
Registered Member
Registered Member


Joined: Apr 18, 2007
Posts: 8012

Can you please create a sample project with the classes and pm it to me. You can hit the pm button at the bottom of my post and send it across.

_________________
Nipun
MyEclipse Support
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
gbatumbya
Post subject: Error when reverse-engineering certain classes  PostPosted: Jul 14, 2011 - 04:31 PM



Joined: Jul 14, 2011
Posts: 1

Hi there I am having the same problem. Could you please help me out.

Here is the installation detalis for my setup:

*** Date:
Thursday, July 14, 2011 11:28:46 AM EDT

** System properties:
OS=WindowsVista
OS version=6.1.0
Java version=1.6.0_13


*** MyEclipse details:
MyEclipse Enterprise Workbench
Version: 9.1
Build id: 9.1-20110701


*** Eclipse details:
MyEclipse Enterprise Workbench

Version: 9.1
Build id: 9.1-20110701


Eclipse startup command=-os
win32
-ws
win32
-arch
x86
-showsplash
-launcher
D:\MyEclipse\MyEclipse 9\myeclipse.exe
-name
Myeclipse
--launcher.library
D:\MyEclipse\MyEclipse 9\../Common/plugins/org.eclipse.equinox.launcher.i18n.win32.win32.x86_3.2.0.v201103301700\eclipse_3215.dll
-startup
D:\MyEclipse\MyEclipse 9\../Common/plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-install
D:\MyEclipse\MyEclipse 9
-configuration
D:\MyEclipse\MyEclipse 9\configuration
-vm
D:\MyEclipse\Common\binary\com.sun.java.jdk.win32.x86_1.6.0.013\jre\bin\client\jvm.dll

Thanks
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Jul 15, 2011 - 07:09 AM



Joined: Nov 11, 2010
Posts: 2488

gbatumbya ,

Sorry that you ran into this issue with MyEclipse.

Can you answer some more questions for me to understand the issue better?

1) Are you trying to reverse engineer an Abstract class? Do you see the same error reported by user ryreeves ?

2) Do you see any specific errors of interest logged in the .log file which is located at <workspace dir>/.metadata/.log ? If yes then paste them here for me.

3) How are you trying to reverse engineer ? Is it using the menu option or the drag and drop feature?

4) Can you also please create a simple project with the classes and PM it to me ? You can hit the PM button at the bottom of this post and send it across.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits