MyEclipse Forums
This thread has been locked & this forum has been archived.
Please post new topics to General Development
View previous topic Printable version Log in to check your private messages View next topic
Author Message
kovacschris
Post subject: No support for <ResourceString> ?  PostPosted: Mar 31, 2009 - 07:49 PM



Joined: Oct 01, 2003
Posts: 18

We are considering moving from a NetBeans project to MyEclipse and M4M.

I have noticed that M4M does not support setting text properties using a resource string as NetBeans does. This is a deal-breaker for us unfortunately so I really hope you have plans to include this in an upcoming release.

Looking at the .form file, settings like this are simply removed by M4M resulting in empty strings being shown in the UI:

Code:
<Component class="javax.swing.JLabel" name="lblSelectMibView">
  <Properties>
    <Property name="text" type="java.lang.String" editor="org.netbeans.modules.i18n.form.FormI18nStringEditor">
      <ResourceString bundle="com/example/Messages.properties" key="TEXT_KEY" replaceFormat="java.util.ResourceBundle.getBundle(&quot;{bundleNameSlashes}&quot;).getString(&quot;{key}&quot;)"/>
    </Property>
  </Properties>
</Component>


[/code]
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
kovacschris
Post subject: RE: No support for <ResourceString> ?  PostPosted: Mar 31, 2009 - 07:53 PM



Joined: Oct 01, 2003
Posts: 18

*** Date:
Tuesday, March 31, 2009 11:53:38 AM PDT

** System properties:
OS=WindowsXP
OS version=5.1.0
Java version=1.6.0_11


*** MyEclipse details:
MyEclipse Enterprise Workbench
Version: 7.1.1
Build id: 7.1.1-20090310


*** Eclipse details:
Eclipse Platform

Version: 3.4.1
Build id: M20080911-1700




Eclipse Platform

Version: 3.4.1.r341_v20080731-9I96EiDElYevwz-p1bP5z-NlAaP7vtX6Utotqsu
Build id: M20080911-1700


Eclipse Graphical Editing Framework GEF

Version: 3.4.1.v20080806-67718083A56B4H2A3213573
Build id: 200809101400


Eclipse RCP

Version: 3.4.100.r341_v20080814-989JESIEdAciFYfkZZsBfSwQ2341
Build id: M20080703-0800


Eclipse Java Development Tools

Version: 3.4.1.r341_v20080709-0800-7o7tEAfEF_U5qyUgrb2HAp539P97
Build id: M20080709-0800




Eclipse startup command=-os
win32
-ws
win32
-arch
x86
-showsplash
C:\eclipse\plugins\org.eclipse.platform_3.3.101.v200809111700\splash.bmp
-launcher
C:\eclipse\eclipse.exe
-name
Eclipse
--launcher.library
C:\eclipse\plugins\org.eclipse.equinox.launcher.win32.win32.x86_1.0.101.R34x_v20080731\eclipse_1115.dll
-startup
C:\eclipse\plugins\org.eclipse.equinox.launcher_1.0.101.R34x_v20080819.jar
-framework
plugins\org.eclipse.osgi_3.4.2.R34x_v20080826-1230.jar
-vm
C:\Program Files\Java\jre6\bin\client\jvm.dll
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-nipun
Post subject: RE: No support for <ResourceString> ?  PostPosted: Apr 01, 2009 - 02:09 PM
Registered Member
Registered Member


Joined: Apr 18, 2007
Posts: 8012

We know about this and we already have it on our TODO. We will try to get this out asap. Sorry for the inconvenience caused.

_________________
Nipun
MyEclipse Support
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
kovacschris
Post subject: RE: No support for <ResourceString> ?  PostPosted: Apr 01, 2009 - 04:50 PM



Joined: Oct 01, 2003
Posts: 18

Good to know you're working on it. Thank you for the response. Is there any way I track when this fix will be available?
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-nipun
Post subject: RE: No support for <ResourceString> ?  PostPosted: Apr 01, 2009 - 05:39 PM
Registered Member
Registered Member


Joined: Apr 18, 2007
Posts: 8012

Im afraid there is not way for you to track this but I'll keep you updated on this thread.

_________________
Nipun
MyEclipse Support
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
kovacschris
Post subject: RE: No support for <ResourceString> ?  PostPosted: Apr 01, 2009 - 06:22 PM



Joined: Oct 01, 2003
Posts: 18

Subscribing to thread.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-nipun
Post subject: RE: No support for <ResourceString> ?  PostPosted: Apr 16, 2009 - 08:38 PM
Registered Member
Registered Member


Joined: Apr 18, 2007
Posts: 8012

This support will be in the 8.x release family and it's very important for our planned Matisse rework that will take place on the Eclipse 3.5 platform later this year.

_________________
Nipun
MyEclipse Support
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
kovacschris
Post subject: Re: RE: No support for <ResourceString> ?  PostPosted: Sep 30, 2009 - 04:17 AM



Joined: Oct 01, 2003
Posts: 18

support-nipun wrote:
This support will be in the 8.x release family and it's very important for our planned Matisse rework that will take place on the Eclipse 3.5 platform later this year.


Has this been addressed in 8.0M1? I don't see it in the list of "Recent Enhancements and Fixes" for 8.0M1

Thanks.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
kovacschris
Post subject: Re: RE: No support for <ResourceString> ?  PostPosted: Oct 01, 2009 - 11:17 PM



Joined: Oct 01, 2003
Posts: 18

Since I haven't gotten a response, I had to test this out myself. This hasn't been resolved. It's the same issue.

I need an update on the status of this problem.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-nipun
Post subject: RE: Re: RE: No support for <ResourceString> ?  PostPosted: Oct 05, 2009 - 09:44 PM
Registered Member
Registered Member


Joined: Apr 18, 2007
Posts: 8012

We didn't have time to get this into the 8.0 release unfortunately, but we are considering a larger scale Matisse refresh all together for the 8.5 release early next year

_________________
Nipun
MyEclipse Support
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
kovacschris
Post subject:   PostPosted: Jan 11, 2010 - 10:57 PM



Joined: Oct 01, 2003
Posts: 18

So any word on whether this is fixed for 8.5?
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits