MyEclipse Forums
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
Support-Brian
Post subject: Issues updating to MyEclipse 8.5  PostPosted: Mar 26, 2010 - 09:19 AM
Moderator
Moderator


Joined: Aug 21, 2004
Posts: 2583

If you update to MyEclipse 8.5 from MyEclipse 8 using the in-product dashboard, due to a P2 bug the update may fail in the following ways after hitting "Restart".

a) The workbench will not come up, instead, you will see an error dialog prompting you to look at a log file.
b) The workbench does come up but you still have MyEclipse 8.0 installed (Please check the version mentioned at Help > About. The splash screen may display MyEclipse 8 even if you have 8.5 installed due to this same bug)

You can fix this issue in the following ways:

1) If you are not a Pulse user, please visit our Web Installer, leave the default All profile selected and click install. This will install a new instance of MyEclipse 8.5 for you; however, you can point it to your existing workspace when it starts to continue working without losing any of your settings.

2) If you are a Pulse user and have installed this profile using Pulse, simply start Pulse Explorer, select the profile in question and choose "Reinstall and Run" to fix the 8.5 instance.

There will be no additional downloads required for either of these techniques because the files required will already have been downloaded during the update process.

If you update fails with the following exception
Code:
Software being installed: MyEclipse 8.5 (Profile) 2.0.0.0000000005 (com.poweredbypulse.profile-XXXXXX-rmb-XXXXXX 2.0.0.0000000005)
  Missing requirement: Skyway Builder Java Integration 7.0.0.201002041409 (org.skyway.integration.java 7.0.0.201002041409) requires 'bundle org.maven.ide.components.maven_model_edit 1.0.0' but it could not be found
  Cannot satisfy dependency:
    From: MyEclipse 8.5 (Profile) 2.0.0.0000000005
...

You must uninstall this add-on using the Dashboard before attempting to update. If you wish to use MyEclipse for Spring, it will be available as a separate standalone installation next week.

The All-in-one installers will be released later today and I will post the links when available.

I sincerely apologize for any inconvenience caused.

_________________
Brian
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
tennisbum79
Post subject: RE: Issues updating to MyEclipse 8.5  PostPosted: Apr 05, 2010 - 09:08 PM
Veteran Member
Veteran Member


Joined: Jul 26, 2006
Posts: 40

Of the 2 alternatives or option at developers disposal, whick option do you recomment the most?
1) All-In-One - Eclipse and MyEclipse in one download - Installed as a unit
2) Eclipse and MyEclipse in separate downloads. Instatted separately and integrated later.


I installed my first My All-In-One starting with MyEclipse 6.1.

I have just installed All-In-One MyEclipse 8.5, and I have been all kind of problems.
Both with the install and config.
After I worked through those issues, I am now having problem with the deploy.

I am getting this error (below) and have not found much about it on this forum

Quote:

pr 5, 2010 11:28:28 AM EDT> <Error> <Deployer> <BEA-149265> <Failure occured in the execution of deployment request with ID '1270481242719' for task '0'. Error is: 'weblogic.application.ModuleException: '
weblogic.application.ModuleException:
at weblogic.servlet.internal.WebAppModule.prepare(WebAppModule.java:292)
at weblogic.application.internal.flow.ScopedModuleDriver.prepare(ScopedModuleDriver.java:176)
at weblogic.application.internal.flow.ModuleListenerInvoker.prepare(ModuleListenerInvoker.java:93)
at weblogic.application.internal.flow.DeploymentCallbackFlow$1.next(DeploymentCallbackFlow.java:360)
at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:26)
Truncated. see log file for complete stacktrace

java.lang.UnsupportedClassVersionError: unsupported classversion 50.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
at weblogic.utils.classloaders.GenericClassLoader.defineClass(GenericClassLoader.java:355)
at weblogic.utils.classloaders.GenericClassLoader.findLocalClass(GenericClassLoader.java:294)
Truncated. see log file for complete stacktrace


My environment Winddows XP, using Weblogic 9.2 as server.

Note that All-in-One for MyEclipse 6.1was also using the same environment.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits