This thread has been locked & this forum has been archived.
Please post new topics to General Development
Author Message
maynardp



Joined: Oct 16, 2010
Posts: 1

Code:
*** Date:
Saturday, October 16, 2010 2:34:32 o'clock PM PDT

** System properties:
OS=Linux
OS version=2.6.32
Java version=1.6.0_13


*** MyEclipse details:
MyEclipse Enterprise Workbench
Version: 8.6
Build id: 8.6-20100806


*** Eclipse details:
MyEclipse Enterprise Workbench

Version: 8.6
Build id: 8.6-20100806

Eclipse startup command=-os
linux
-ws
gtk
-arch
x86_64
-showsplash
-launcher
/home/maynardp/Genuitec/MyEclipse-8.6/myeclipse
-name
Myeclipse
--launcher.library
/home/maynardp/Genuitec/MyEclipse-8.6//../Common/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.0.200.v20090519/eclipse_1206.so
-startup
/home/maynardp/Genuitec/MyEclipse-8.6//../Common/plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar
-exitdata
16a0013
-install
/home/maynardp/Genuitec/MyEclipse-8.6
-configuration
/home/maynardp/Genuitec/MyEclipse-8.6/configuration
-Dlinux.experimental=true
-vm
/home/maynardp/Genuitec/Common/binary/com.sun.java.jdk.linux.x86_64_1.6.0.013/bin/java



Problem: Internal Web Browser Error dialog box opens

Followed the direction in the "Linux Internal Web Browser Compatibility" help document with no luck.

=====================
This is a brand new Ubuntu 10.04 64bit install.
Fully patched.
Only package added was Sun JDK to allow for installation of MyEclipse
xulrunner-1.9.2 is installed (I assume as part of base build)

I'm using a script to start MyEclipse as documented in "Linux Internal Web Browser Compatibility". So export MOZILLA_FIVE_HOME="" is being set.

Code:
export MOZILLA_FIVE_HOME=""
/home/maynardp/Genuitec/MyEclipse-8.6/myeclipse


I have also tried using -Dlinux.experimental=true which I found documented in a couple forum articles. No difference with or without adding this to the script.

Code:
export MOZILLA_FIVE_HOME=""
/home/maynardp/Genuitec/MyEclipse-8.6/myeclipse -Dlinux.experimental=true


Based on the final message in the error log, this appears to be an issue with Xulrunner.

Any suggestions?



Code:
Error Log
----------
!SESSION 2010-10-16 12:52:35.235 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_13
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_CA
Framework arguments:  -Dlinux.experimental=true
Command-line arguments:  -os linux -ws gtk -arch x86_64 -Dlinux.experimental=true

!ENTRY org.eclipse.jface 2 0 2010-10-16 12:52:41.804
!MESSAGE Keybinding conflicts occurred.  They may interfere with normal accelerator operation.
!SUBENTRY 1 org.eclipse.jface 2 0 2010-10-16 12:52:41.804
!MESSAGE A conflict occurred for CTRL+F9:
Binding(CTRL+F9,
   ParameterizedCommand(Command(org.eclipse.mylyn.tasks.ui.command.activateTask,Activate Task,
      ,
      Category(org.eclipse.ui.category.navigate,Navigate,null,true),
      ,
      ,,true),null),
   org.eclipse.ui.defaultAcceleratorConfiguration,
   org.eclipse.ui.contexts.window,,,system)
Binding(CTRL+F9,
   ParameterizedCommand(Command(RunSQLAction,Run SQL,
      Run SQL,
      Category(org.eclipse.ui.category.edit,Edit,null,true),
      ,
      ,,true),null),
   org.eclipse.ui.defaultAcceleratorConfiguration,
   org.eclipse.ui.contexts.window,,,system)
!SUBENTRY 1 org.eclipse.jface 2 0 2010-10-16 12:52:41.804
!MESSAGE A conflict occurred for SHIFT+DEL:
Binding(SHIFT+DEL,
   ParameterizedCommand(Command(org.eclipse.datatools.sqltools.result.removeAllInstances,Remove All Visible Results,
      ,
      Category(org.eclipse.datatools.sqltools.result.category,SQL Results View,null,true),
      ,
      ,,true),null),
   org.eclipse.ui.defaultAcceleratorConfiguration,
   org.eclipse.ui.contexts.window,,,system)
Binding(SHIFT+DEL,
   ParameterizedCommand(Command(org.eclipse.ui.edit.cut,Cut,
      Cut the selection to the clipboard,
      Category(org.eclipse.ui.category.edit,Edit,null,true),
      org.eclipse.ui.internal.handlers.WidgetMethodHandler@79b5459e,
      ,,true),null),
   org.eclipse.ui.defaultAcceleratorConfiguration,
   org.eclipse.ui.contexts.dialogAndWindow,,,system)
Binding(SHIFT+DEL,
   ParameterizedCommand(Command(org.topcased.modeler.deleteModelObject,remove from Model,
      Allows the user to delete the selected graph element and its associated model element in a Topcased editor.,
      Category(org.eclipse.ui.category.edit,Edit,null,true),
      ,
      ,,true),null),
   org.eclipse.ui.defaultAcceleratorConfiguration,
   org.eclipse.ui.contexts.window,,,system)

!ENTRY org.eclipse.osgi 2 1 2010-10-16 12:52:42.333
!MESSAGE NLS unused message: prompt.optclasspath in: com.genuitec.eclipse.easie.core.configuration

!ENTRY org.eclipse.osgi 2 1 2010-10-16 12:52:42.333
!MESSAGE NLS unused message: prompt.preclasspath in: com.genuitec.eclipse.easie.core.configuration

!ENTRY org.eclipse.osgi 2 1 2010-10-16 12:52:42.333
!MESSAGE NLS unused message: prompt.optlibrarypath in: com.genuitec.eclipse.easie.core.configuration

!ENTRY com.genuitec.eclipse.core 1 0 2010-10-16 12:52:42.977
!MESSAGE Unable to locate .myeclipse.properties file

!ENTRY org.eclipse.atf.mozilla.ide.core 4 0 2010-10-16 12:52:45.551
!MESSAGE Invalid extension contributed by:org.mozilla.xulrunner.gtk.linux.x86_64 Missing, empty or invalid version or path attribute in extension: org.eclipse.atf.mozilla.ide.core.xulrunner



Thanks
 
 View user's profile Send private message  
Reply with quote Back to top
support-shalini
Registered Member
Registered Member


Joined: May 18, 2009
Posts: 1532

maynardp,
Can you try the workaround given in the link below and let me know how that works for you -
http://www.myeclipseide.com/index.php?name=PNphpBB2&file=viewtopic&p=110513

_________________
Shalini
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
rcoe67
Registered Member
Registered Member


Joined: Jan 22, 2009
Posts: 16

I have the same problem as maynardp and tried the same solutions. I also tried the posted workaround, which isn't.

I can see my start page but what I can't get access to is the ajax toolset.

#! /bin/bash
export MOZILLA_FIVE_HOME=/usr/lib/xulrunner-1.9.2.10
export LD_LIBRARY_PATH=$MOZILLA_FIVE_HOME:$LD_LIBRARY_PATH

~/Genuitec/MyEclipse-8.6/myeclipse &

I installed MyEclipse with the all-in-one installer.
 
 View user's profile Send private message  
Reply with quote Back to top
support-shalini
Registered Member
Registered Member


Joined: May 18, 2009
Posts: 1532

rcoe67,
I shall escalate this issue to the dev team.
They will get back to you on this.

_________________
Shalini
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
rcoe67
Registered Member
Registered Member


Joined: Jan 22, 2009
Posts: 16

I have not heard back. Is this problem solved in v9?
 
 View user's profile Send private message  
Reply with quote Back to top
douglas_a_lauder
Registered Member
Registered Member


Joined: Jan 05, 2005
Posts: 11

I am having the same issue; tried all the workarounds above with no luck. Is MyEclipse 8.6.1 compatible with XULRunner 1.9.2 on Ubuntu 10.04? I need to do some Javascript debugging and this

Quote:
org.mozilla.xpcom.XPCOMException: The function "getServiceByContractID" returned an error condition (0x80040154)


error is driving me crazy. Spent hours so far trying all the config workarounds.

-DL
 
 View user's profile Send private message  
Reply with quote Back to top
douglas_a_lauder
Registered Member
Registered Member


Joined: Jan 05, 2005
Posts: 11

I am having the same issue; tried all the workarounds above with no luck. Is MyEclipse 8.6.1 compatible with XULRunner 1.9.2 on Ubuntu 10.04? I need to do some Javascript debugging and this

Quote:
org.mozilla.xpcom.XPCOMException: The function "getServiceByContractID" returned an error condition (0x80040154)


error is driving me crazy. Spent hours so far trying all the config workarounds.

-DL
 
 View user's profile Send private message  
Reply with quote Back to top
All times are GMT - 6 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
® 2014 - Genuitec, LLC.