MyEclipse Forums
This thread has been locked & this forum has been archived.
Please post new topics to Java EE Development (EJB, JSP, Struts, XDoclet, etc.)
View previous topic Printable version Log in to check your private messages View next topic
Author Message
lnadai
Post subject: Developing JAX-WS Web Services & Clients Tutorial proble  PostPosted: Dec 19, 2010 - 10:10 PM
Registered Member
Registered Member


Joined: Dec 19, 2010
Posts: 5

I have seen several postings, but no solutions for me.
Trying the above tutorial, at step 5, I get the error (from MyEclipse):

An internal error occurred during: "Generating JAX-WS Web Services".
Could not initialize class org.eclipse.wst.wsdl.WSDLPackage$Literals


Have tried to change Java version, but no luck.
I am running Version: 8.6

Error log msg:
An internal error occurred during: "Generating JAX-WS Web Services".

What am I missing (as a newbie) ?
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-swapna
Post subject: RE: Developing JAX-WS Web Services & Clients Tutorial pr  PostPosted: Dec 20, 2010 - 08:09 AM



Joined: Nov 11, 2010
Posts: 2490

lnadai,

I could not replicate it at my end.

Please copy paste your installation details here from the menu MyEclipse > Installation Summary > Installation Details.
I assume you have tried working with this tutorial. Right? :
http://www.myeclipseide.com/documentation/quickstarts/blueedition/blue_jaxws/

If no then send me the link for the tutorial which you are following.
Check if there are any specific errors pertaining to webservice logged in .log file which is at <workspace dir>/.metadata folder. Paste them here.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
lnadai
Post subject: RE: Developing JAX-WS Web Services & Clients Tutorial pr  PostPosted: Dec 21, 2010 - 06:44 PM
Registered Member
Registered Member


Joined: Dec 19, 2010
Posts: 5

Thank you. Here is the info:
---------------------------------------------------------------------
Installation details:
*** Date:
Tuesday, December 21, 2010 10:40:52 AM PST

** System properties:
OS=WindowsXP
OS version=5.1.0
Java version=1.6.0_13


*** MyEclipse details:
MyEclipse Enterprise Workbench
Version: 8.6.1
Build id: 8.6.1-20101117
-------------------------------------------------

Error log:
-------------------------------------------------
!ENTRY org.eclipse.core.jobs 4 2 2010-12-21 10:38:26.921
!MESSAGE An internal error occurred during: "Generating JAX-WS Web Services".
!STACK 0
java.lang.NoClassDefFoundError: Could not initialize class org.eclipse.wst.wsdl.WSDLPackage$Literals
at org.eclipse.wst.wsdl.internal.impl.DefinitionImpl.eStaticClass(DefinitionImpl.java:295)
at org.eclipse.emf.ecore.impl.EObjectImpl.eClass(EObjectImpl.java:224)
at org.eclipse.emf.ecore.impl.ENotificationImpl.getFeature(ENotificationImpl.java:223)
at org.eclipse.wst.wsdl.internal.impl.WSDLElementImpl.eNotify(WSDLElementImpl.java:379)
at org.eclipse.wst.wsdl.internal.impl.DefinitionImpl.eNotify(DefinitionImpl.java:515)
at org.eclipse.wst.wsdl.internal.impl.WSDLElementImpl.setElementGen(WSDLElementImpl.java:181)
at org.eclipse.wst.wsdl.internal.impl.WSDLElementImpl.setElement(WSDLElementImpl.java:367)
at org.eclipse.wst.wsdl.internal.impl.DefinitionImpl.setElement(DefinitionImpl.java:1704)
at org.eclipse.wst.wsdl.internal.impl.DefinitionImpl.createDefinition(DefinitionImpl.java:1511)
at org.eclipse.wst.wsdl.util.WSDLResourceImpl.handleDefinitionElement(WSDLResourceImpl.java:572)
at org.eclipse.wst.wsdl.util.WSDLResourceImpl.findDefinition(WSDLResourceImpl.java:540)
at org.eclipse.wst.wsdl.util.WSDLResourceImpl.doLoad(WSDLResourceImpl.java:285)
at org.eclipse.wst.wsdl.util.WSDLResourceImpl.doLoad(WSDLResourceImpl.java:358)
at org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:1494)
at org.eclipse.wst.wsdl.internal.impl.wsdl4j.WSDLReaderImpl.readWSDL(WSDLReaderImpl.java:193)
at org.eclipse.wst.ws.internal.parser.wsil.WebServicesParser.getWSDLDefinitionVerbose(WebServicesParser.java:231)
at org.eclipse.wst.ws.internal.parser.wsil.WebServicesParser.getWSDLDefinition(WebServicesParser.java:205)
at com.genuitec.eclipse.ws.jaxws.WSDLManager.parse(WSDLManager.java:53)
at com.genuitec.eclipse.ws.jaxws.WSDLManager.copyTo(WSDLManager.java:98)
at com.genuitec.eclipse.ws.jaxws.JaxWSBUJob.manageWSDL(JaxWSBUJob.java:185)
at com.genuitec.eclipse.ws.jaxws.JaxWSBUJob.run(JaxWSBUJob.java:131)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
anthonyestelita
Post subject:   PostPosted: Nov 10, 2011 - 06:55 PM
Registered Member
Registered Member


Joined: Feb 16, 2005
Posts: 75

I know this is an old bug, but what was the resolution? I am all of a sudden getting this same exact error and was hoping to find a solution here. :( Do you happen to know what was the problem?

Greatly appreciated,
Anthony
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits