MyEclipse Forums
This thread has been locked & this forum has been archived.
Please post new topics to General Development
View previous topic Printable version Log in to check your private messages View next topic
Author Message
WGPuckett
Post subject: ICEFaces Tutorial Project Fails when Tomcat starts up  PostPosted: Feb 15, 2011 - 07:12 PM
Registered Member
Registered Member


Joined: Jun 08, 2006
Posts: 78

I am using MyEclipse v: 8.6.1 Build: 6.6.1-20101117 on Win7 Pro

I am having the same problem as a prior post. But it never really gave a resolution to the issue. I have followed the project down to where you try to run it the first time. I have tried starting it two different ways. I have tried just starting Tomcat through the Servers tab and I have right clicked on the project and selecting Run As Myeclipse Server Application.

As Tomcat initializes I get the following error:

Code:

INFO: Starting Servlet Engine: Apache Tomcat/6.0.13
Feb 15, 2011 1:59:57 PM org.apache.catalina.core.StandardContext listenerStart
SEVERE: Error configuring application listener of class com.icesoft.faces.util.event.servlet.ContextEventRepeater
java.lang.ClassNotFoundException: com.icesoft.faces.util.event.servlet.ContextEventRepeater
   at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1358)
   at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1204)
   at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3770)
   at org.apache.catalina.core.StandardContext.start(StandardContext.java:4334)
   at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791)
   at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771)
   at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:525)
   at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:920)
   at org.apache.catalina.startup.HostConfig.deployDirectories(HostConfig.java:883)
   at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:492)
   at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1138)
   at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:311)
   at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:117)
   at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1053)
   at org.apache.catalina.core.StandardHost.start(StandardHost.java:719)
   at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
   at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
   at org.apache.catalina.core.StandardService.start(StandardService.java:516)
   at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
   at org.apache.catalina.startup.Catalina.start(Catalina.java:566)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:597)
   at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
   at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
Feb 15, 2011 1:59:57 PM org.apache.catalina.core.StandardContext listenerStart
SEVERE: Skipped installing application listeners due to previous error(s)
Feb 15, 2011 1:59:57 PM org.apache.catalina.core.StandardContext start
SEVERE: Error listenerStart
Feb 15, 2011 1:59:57 PM org.apache.catalina.core.StandardContext start
SEVERE: Context [/icefacesTutorial] startup failed due to previous errors
Feb 15, 2011 1:59:57 PM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Feb 15, 2011 1:59:57 PM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
Feb 15, 2011 1:59:57 PM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/10  config=null
Feb 15, 2011 1:59:57 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 118 ms


I have tried a little of everything but nothing gets me past this. For now I think I will delete the project and try it again.

I have sucessfully completed the JSF tutorial with no problems. It's only when I moved to the ICEFaces tutorial that I have a problem.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
support-joy
Post subject: RE: ICEFaces Tutorial Project Fails when Tomcat starts up  PostPosted: Feb 17, 2011 - 10:50 AM
Registered Member
Registered Member


Joined: Feb 03, 2009
Posts: 3442

WGPuckett,

I am afraid, I cannot replicate this issue at my end. Can you quickly check the below item for me -
1. Open MyEclipse IDE, from menu options click on MyEclipse > Installation Summary > Installation Details and copy and paste the same here
2. From menu options click on MyEclipse > Examples on Demand. This will open an Examples on Demand browser, scroll down and click on [install] button next to the ICEfacesTutorialExample. This will add the sample EOD to your package explorer. Next right click on the same and click on Run As > MyEclipse Server Application > MyEclipse Tomcat. This will run the ICEFaces sample EOD project on MyEclipse Web Browser. Let me know if you are able to run this example.

_________________
Joy
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits