MyEclipse Forums
This thread has been locked & this forum has been archived.
Please post new topics to General Development
View previous topic Printable version Log in to check your private messages View next topic
Author Message
RickSuds
Post subject: MyEclipse EJB 3.x Tutorial Problems  PostPosted: Mar 21, 2011 - 02:15 PM
Registered Member
Registered Member


Joined: Mar 09, 2011
Posts: 13

I have tried to run this tutorial and it does not seem to work with GlassFish 3.0.1 final
I got this exception "contains zero ejb. Note: 1. A valid ejb jar requires at least one session, entity (1.x/2.x style)"



It seems to want a pre 3.0 entity bean? Is there a patch/workaround available...

I am using MyEclipse for Spring 8.6

Thanks

After some more fruitless searching Its now throwing this
javax.naming.NamingException: Lookup failed for xxx.xxx.xxxx in SerialContext targetHost=127.0.0.1,targetPort=3700,orb'sInitialHost=localhost,orb'sInitialPort=3700 [Root exception is javax.naming.NameNotFoundException: xxx.xxx.xxxx not found

This is'nt as far as I can tell an Eclipse problem but rather GlassFish 3.0.1, this is absurd, this problem has been around forever and no one seems to have a fix for it. In any event you might want to rework your tutorials to exclude any reference to GlassFish until they fix the problem
 
 View user's profile Send private message  
Reply with quote Back to top
support-joy
Post subject: RE: MyEclipse EJB 3.x Tutorial Problems  PostPosted: Mar 22, 2011 - 01:17 PM
Registered Member
Registered Member


Joined: Feb 03, 2009
Posts: 3442

RickSuds,

Sorry to hear you are running into these issues. Can you answer below queries -
1. Can you copy and paste your installation details? Open ME4S IDE, from menu options click on MyEclipse > Installation Summary > Installation Details
2. Can you clear your .log file located at [your workspace dir]/.metadata/.log, replicate the steps and copy and paste relevant portion of the .log file here
3. Can you share the weblink of the tutorial here
4. Can you elaborate the steps that resulted in the above issue?
5. Also attach screenshots which will help me get a visual. You can either [pm]/[post reply] the attachments

_________________
Joy
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
RickSuds
Post subject: MyEclipse EJB 3.x Tutorial Problems  PostPosted: Mar 22, 2011 - 03:03 PM
Registered Member
Registered Member


Joined: Mar 09, 2011
Posts: 13

Thanks for getting back to me

I got it working, the problem was with GlassFish and the location of the AutoDeploy folder. Anyway here is the link to the tutorial - http://127.0.0.1:16196/help/topic/com.genuitec.myeclipse.doc/html/quickstarts/ejb3/index.html?resultof=%22%45%4a%42%22%20%22%65%6a%62%22%20. Also under the section about the test client you might want to add something like this:
Code:

Properties jndiProps = new Properties();
         jndiProps.put("java.naming.factory.initial", "com.sun.enterprise.naming.impl.SerialInitContextFactory");
         jndiProps.put("java.naming.factory.url.pkgs", "com.sun.enterprise.naming");
         jndiProps.put("java.naming.factory.state", "com.sun.corba.ee.impl.presentation.rmi.JNDIStateFactoryImpl");
         jndiProps.put("java.naming.provider.url", "iiop://localhost:3700");
         jndiProps.setProperty("org.omg.CORBA.ORBInitialHost", "127.0.0.1");
         jndiProps.setProperty("org.omg.CORBA.ORBInitialPort", "3700");
           InitialContext ctx = new InitialContext(jndiProps);           
           myRemote bean = (myRemote) ctx.lookup("xxx.xxxx.xxxx.myRemote");
          
            bean.doSomething();

Thanks Again
Rick
 
 View user's profile Send private message  
Reply with quote Back to top
support-joy
Post subject: RE: MyEclipse EJB 3.x Tutorial Problems  PostPosted: Mar 23, 2011 - 12:40 PM
Registered Member
Registered Member


Joined: Feb 03, 2009
Posts: 3442

Rick,

Good to hear you are all set. I am afraid, the link for EJB3 tutorial site provided by you is not valid. I see that it refers to your localhost. Can you please check http://www.myeclipseide.com/module-htmlpages-display-pid-7.html and verify if the tutorial you are referring to is also provided here and point me to the relevant link?

Thanks

_________________
Joy
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
RickSuds
Post subject: My Eclipse 3.x Tutorial Problems  PostPosted: Mar 23, 2011 - 07:26 PM
Registered Member
Registered Member


Joined: Mar 09, 2011
Posts: 13

 
 View user's profile Send private message  
Reply with quote Back to top
support-joy
Post subject: RE: My Eclipse 3.x Tutorial Problems  PostPosted: Mar 24, 2011 - 01:02 PM
Registered Member
Registered Member


Joined: Feb 03, 2009
Posts: 3442

Rick,

Thank you. I shall investigate and get back to you

_________________
Joy
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits