MyEclipse Forums
This thread has been locked & this forum has been archived.
Please post new topics to General Development
View previous topic Printable version Log in to check your private messages View next topic
Author Message
Mork
Post subject: Run As MyEclipse Server Issue  PostPosted: Sep 05, 2011 - 01:13 PM
Veteran Member
Veteran Member


Joined: Dec 09, 2004
Posts: 607

I have several MyEclipse projects in a particular workspace.

The problem is that when I click "Run As ... MyEclipse Application" and pick the internal MyEcipse app server, MyEclipse then tries to resolve all the startup items on ALL the projects -- even the closed ones! You see all the startup items scroll by in the console window for the closed projects!

Huh???

In some of the **closed** projects, I have JDBC connections that aren't open at the moment (but, hey, those projects are ** closed ** so it shouldn't matter, right?).

Because MyEclipse is trying to load all the closed projects in the workspace -- even ones where JDBC connections are not open at the moment, the Run As..MyEclipse Server application fails every time.

So, to get anything to work in the Run As..., I have to use the separate Tomcat 6 app server I installed (or have a workspace with a single project in it).

Why does MyE try to start up all these closed projects' startup items?

Is there a way to just right-click the single opened project and have MyEcilpse "understand" that I want it to Run...As only that OPEN project (the _only_ open project in the workspace) and to please (!!!) ignore all the closed projects???

(confused).

Look forward to any suggestions.

Thanks,

--mork
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Sep 06, 2011 - 08:02 AM



Joined: Nov 11, 2010
Posts: 2499

Mork ,

I cannot replicate the issue at my end.

If the project is already deployed to the server and if you close the project, it will not be seen as deployed on the MyEclipse screen but it is deployed as far as Tomcat is concerned. Can you recheck the deployment location and remove the projects from the location, close the projects and check if the issue persists ?

Let me know how this works for you.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Mork
Post subject:   PostPosted: Sep 06, 2011 - 10:58 AM
Veteran Member
Veteran Member


Joined: Dec 09, 2004
Posts: 607

This is actually easy to replicate.

If you have multiple projects in a workspace and all are closed but one. You then right click one of the projects and do a Run...As MyEclipse Server Application (the built in one).

None of the (closed) projects that scroll by in the console window when I right-click and do a run...as MyEclipse server application are deployed.

In the console window, you'll see that MyEclipse is loading the other projects (the closed ones in the workspace) as well.

If you cannot replicate this, please escalate this issue (since it's clearly reproducible) so I can get a reply that addresses my question.

thanks,

-m
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Sep 06, 2011 - 11:09 AM



Joined: Nov 11, 2010
Posts: 2499

Mork ,

1) I could replicate the issue when the project which is closed is actually deployed to MyEclipse Tomcat. As the project is closed, it will not be listed under deployed projects for MyEclipse Tomcat.

2) You will have to remove the deployment for the closed projects for MyEclipse Tomcat to stop loading the closed projects. Can you go to the deployment location for MyEclipse Tomcat and check if you see the directory for the closed project ? Delete it and then check if the issue persists.

3) If you can check, the same is the behavior in Tomcat 6 too. You can deploy a project to Tomcat 6 and then close the project without undeploying it. Now when you try to deploy another project to Tomcat 6, it will also load the first closed project.

Let us know how this works for you.

_________________
Swapna
MyEclipse Support


Last edited by support-swapna on Sep 06, 2011 - 11:26 AM; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
Mork
Post subject:   PostPosted: Sep 06, 2011 - 11:21 AM
Veteran Member
Veteran Member


Joined: Dec 09, 2004
Posts: 607

OK, thanks.

Yes, the (unfortunately, hidden for some reason on the mac) folder
*did* have that deployment in the MyEclipse Tomcat folder.

However, in the servers tab in the IDE itself nothing was shown as deployed. The "Manage Deployments" for the MyEclipse Tomcat server showed an empty list.

Isn't this the actual bug?

Should I have had to navigate to a hidden folder to remove a project that MyEclipse doesn't seem to know about?

Hmmmmm

In any case, it's working now

thanks.

-- m
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Sep 06, 2011 - 11:36 AM



Joined: Nov 11, 2010
Posts: 2499

Mork ,

I am afraid this is how it works on Eclipse which is the base version of MyEclipse.
When you close a project, it is no longer seen in the Server's tab too. For now, all you can do is to make sure the project is undeployed and then close it to avoid any issues.

Let us know if you have any other issues.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Mork
Post subject:   PostPosted: Sep 06, 2011 - 11:42 AM
Veteran Member
Veteran Member


Joined: Dec 09, 2004
Posts: 607

I'm not using the "base version" of MyEclipse.

I'm using MyEclipse for Spring, but perhaps that's not what you meant.

Seems like MyEcipse (all versions) should do more to keep things cleaned up.

It's really not a great company line to say..."this is just how it works."

It should work better... do more for the user/developer.

Clearly an area for improvement.

thanks for your reply.

- m
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Sep 07, 2011 - 03:28 AM



Joined: Nov 11, 2010
Posts: 2499

Mork ,

Thank you for the suggestions. We are working on making MyEclipse a better product.
Do let us know if you have any other issues.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Sep 08, 2011 - 08:40 AM



Joined: Mar 09, 2011
Posts: 919

Mork,

We've raised the profile of this problem and, hopefully, it will be fixed in a later release.

Thanks for reporting it.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits