MyEclipse Forums
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
balanceofpower
Post subject: Please add support for J6 EE  PostPosted: Sep 08, 2011 - 11:36 PM
Registered Member
Registered Member


Joined: Mar 10, 2005
Posts: 286

I open java files and a lot of annotations don't have attached documentation.
As an example the CDI type annotations @Inject does not have any "doco" when you hover or use ctrl-space for completion.

Quote:

Note: This element neither has attached source nor attached Javadoc and hence no Javadoc could be found.


I am using JBoss's Weld for CDI.

Secondly; its been quite a few years and I was wondering if more of the JBoss Tools can be added to MyEclipse. I believe they were incompatible for a long while.
 
 View user's profile Send private message  
Reply with quote Back to top
support-joy
Post subject:   PostPosted: Sep 09, 2011 - 09:12 AM
Registered Member
Registered Member


Joined: Feb 03, 2009
Posts: 3442

balanceofpower,

We are looking into the issue of documentation related to annotations in Java EE 6.

We are doing a JBoss Tools upgrade in ME 10.1, but I am afraid it is not possible to add JBoss Tools upgrade right now. Could you elaborate what features of JBoss Tools you are looking for, so that we can ensure these get included in 10.1 version?

Sorry for the inconvenience.

_________________
Joy
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
balanceofpower
Post subject:   PostPosted: Sep 09, 2011 - 01:27 PM
Registered Member
Registered Member


Joined: Mar 10, 2005
Posts: 286

CDI
Weld,
Seam 3
Drools
 
 View user's profile Send private message  
Reply with quote Back to top
balanceofpower
Post subject: Addition of a "MyEclipse project"  PostPosted: Sep 14, 2011 - 05:21 AM
Registered Member
Registered Member


Joined: Mar 10, 2005
Posts: 286

Here is a MyEclipse project.

I reverse engineered from a war file created through the Seam3 drop.

It does run up (well since jBoss 6 does not work I had to run up through a cmd window on Windows)...

Please use this as part of your UAT testing for your next drop as a number of things, in MyEclipse, don't seem to validate properly.

I can supply the project file (cant be attached!)
 
 View user's profile Send private message  
Reply with quote Back to top
support-joy
Post subject:   PostPosted: Sep 14, 2011 - 10:46 AM
Registered Member
Registered Member


Joined: Feb 03, 2009
Posts: 3442

balanceofpower,

Could you send your project as an attachment to support@myeclipseide.com . Please include the weblink of this post and steps to reproduce. This project would not be visible and would be treated as strictly confidential for our internal testing. Please add ATTN:Joy in the subject for quick tracing.

Thank you for your help.

_________________
Joy
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
balanceofpower
Post subject:   PostPosted: Sep 23, 2011 - 01:02 AM
Registered Member
Registered Member


Joined: Mar 10, 2005
Posts: 286

Please can you advise when there may be a version (patch or new) of MyEclipse that I can actually use?

Looking forward to JBoss 6 and 7 being supported.

Have you managed to debug all the errors in the supplied project I kindly supplied.
 
 View user's profile Send private message  
Reply with quote Back to top
support-joy
Post subject:   PostPosted: Sep 26, 2011 - 08:31 AM
Registered Member
Registered Member


Joined: Feb 03, 2009
Posts: 3442

balanceofpower,

Apologies for the late reply. MyEclipse 10 is going to support JBoss 7. It is tentatively due on second week of October. Thank you for sending in your project. Our dev teams have included this in the UAT testing of your issues.

_________________
Joy
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
balanceofpower
Post subject:   PostPosted: Sep 26, 2011 - 08:51 AM
Registered Member
Registered Member


Joined: Mar 10, 2005
Posts: 286

support-joy wrote:
balanceofpower,

Apologies for the late reply. MyEclipse 10 is going to support JBoss 7. It is tentatively due on second week of October. Thank you for sending in your project. Our dev teams have included this in the UAT testing of your issues.


Happy to let you release the Project as an example (download) of CDI (+Seam 3 extensions)... it shows Exploded deployment.

It also should be used as part of ME10 UAT.
 
 View user's profile Send private message  
Reply with quote Back to top
balanceofpower
Post subject:   PostPosted: Oct 23, 2011 - 07:48 AM
Registered Member
Registered Member


Joined: Mar 10, 2005
Posts: 286

This was part of an Email to another Architect... you may find the insights useful:

Our IDE (MyEclipse) supports exploded deployment and to the user it LOOKS LIKE you don't need a build script (SHOCK HORROR).
Set up your code laid out 100% like an EAR (or WAR for J6EE); then you set up your server and point MyEclipse at the server and MyEclipse will handle moving files through to the server without ANY build scripts when you tell it to deploy as an exploded deployment. To the user it appears that you are coding on the server as ANY changes you make are immediately visible on the "site" just be refreshing the page or going to the relevant page. WOW THIS MAKES FOR FAST DEVELOPMENT.

There are some exceptions:
Changing a method signature as a message pops up saying its too big a change and asks you to re-start the server... but how often do you do that ;) and 45 seconds later the server is re-started and you carry on...
Changing the few XML files (this is almost eliminated in JSR299 as nearly everything possible is done via annotations now).
 
 View user's profile Send private message  
Reply with quote Back to top
balanceofpower
Post subject:   PostPosted: Nov 01, 2011 - 07:17 AM
Registered Member
Registered Member


Joined: Mar 10, 2005
Posts: 286

Please can you advise when a version will be available (even one for me to test).
 
 View user's profile Send private message  
Reply with quote Back to top
Support-Brian
Post subject:   PostPosted: Nov 01, 2011 - 09:31 AM
Moderator
Moderator


Joined: Aug 21, 2004
Posts: 2584

Tony,

We are planning to MyEclipse 10 today on Pulse, installers may take an additional day or two to appear.

1) We have fixed the JEE 6 annotation issue.
2) We also have JBoss 7 support.
3) In our internal testing, we were able to deploy your project without issue to JBoss 7, however, there were some Seam related errors at runtime which I'm afraid we did not have the time to look into for 10.0; unfortunately we had too many other moving parts and an already delayed release.
4) There are also some flexible deployment enhancements (which I will talk to here: http://www.myeclipseide.com/PNphpBB2-viewtopic-t-24072.html)

A JBoss tools refresh is planned for the next major release, but we will most likely not be integrating the tools you requested. However, the refresh should allow you to add these to MyEclipse without issue - the aim is to try and make MyEclipse as compatible as possible with additional tools and I realize the current state makes it impossible.

If you try 10.0 and you still experience issues with deployment, I will work with you personally on making sure your needs are met as long as they are viable. Most of the flexible deployment support you see in 10.0 has been a result of rather intense customer interaction.

_________________
Brian
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
balanceofpower
Post subject:   PostPosted: Nov 01, 2011 - 10:14 AM
Registered Member
Registered Member


Joined: Mar 10, 2005
Posts: 286

I tried pulse but it just crashed (W7 x64).
I will try again tomorrow (bedtime in this timeline).
A full installer for 64 base version would be what I normally download.
 
 View user's profile Send private message  
Reply with quote Back to top
balanceofpower
Post subject:   PostPosted: Nov 02, 2011 - 09:11 AM
Registered Member
Registered Member


Joined: Mar 10, 2005
Posts: 286

No all inclusive installers yet.
I tried Pulse but got that attached response.

Thx for your support.

Can't want to try it out...
 
 View user's profile Send private message  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Nov 02, 2011 - 10:46 AM



Joined: Mar 09, 2011
Posts: 916

Tony,

That error may happen if you downloaded the 32 bit version of Pulse but only have a 64 bit Java installed (or vice versa). If this is the case, please download the correct version of Pulse.

Hopefully, the offline installers won't be too much longer in coming.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
balanceofpower
Post subject:   PostPosted: Nov 02, 2011 - 06:37 PM
Registered Member
Registered Member


Joined: Mar 10, 2005
Posts: 286

Humm...

Looking forward to installer...
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits