This thread has been locked & this forum has been archived.
Please post new topics to Java EE Development (EJB, JSP, Struts, XDoclet, etc.)
Author Message
simon9251



Joined: Oct 01, 2011
Posts: 2

I am evaluating MyEclipse for the team.

After successful connection to MSSQL, I encountered java.lang.NullPointerException when I clicked the database to list the tables.

The same problem still occurred even after servers are restarted or MyEclipse is re-installed

Could you give any resolution?

PS:
Reverse engineering is quite important to us since we are going to develop the reports on a BPM system which uses MS SQL 2008 R2

MyEclipse version
-------------------------
Version: 9.1
Build id: 9.1-20110701
32 bit

Windows / Driver version
---------------------------------
Windows 7 64 bit Profressinal
Microsoft SQL Server JDBC Driver 3.0

<Workspace>/.metadata/.log (first few lines)
------------------------------------------------------------
!ENTRY org.eclipse.jface 4 2 2011-10-02 11:15:54.341
!MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.jface".
!STACK 0
java.lang.NullPointerException
at com.genuitec.eclipse.sqlexplorer.model.CatalogNode.getSchemas(CatalogNode.java:114)
at com.genuitec.eclipse.sqlexplorer.model.CatalogNode.getChildren(CatalogNode.java:98)
at com.genuitec.eclipse.sqlexplorer.views.DatabaseContentProvider.getChildren(DatabaseContentProvider.java:71)
 
 View user's profile Send private message  
Reply with quote Back to top
support-joy
Registered Member
Registered Member


Joined: Feb 03, 2009
Posts: 3441

simon9251,

Sorry to hear you are running into this issue. Could you answer below queries -
1. Open MyEclipse IDE, from menu options click on MyEclipse > Installation Summary > Installation Details and copy and paste the same here
2. Clear your .log file located at [your workspace dir]/.metadata/.log, replicate issue and attach the file here
3. List out the steps take by you in detail that resulted in this issue including the type of project you have created
4. Have you added any third party plugins to your profile? If yes, please list them here
5. Please try clean, refer - http://www.myeclipseide.com/PNphpBB2-viewtopic-t-10280.html

_________________
Joy
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
simon9251



Joined: Oct 01, 2011
Posts: 2

Hi, Joy,

Thanks. Please find the required information:
support-joy wrote:
simon9251,

Sorry to hear you are running into this issue. Could you answer below queries -
1. Open MyEclipse IDE, from menu options click on MyEclipse > Installation Summary > Installation Details and copy and paste the same here

*** Date:
2011年10月03日 星期一 下午09時26分54秒 CST

** System properties:
OS=WindowsVista
OS version=6.1.0
Java version=1.6.0_13


*** MyEclipse details:
MyEclipse Enterprise Workbench
Version: 9.1
Build id: 9.1-20110701


*** Eclipse details:
MyEclipse Enterprise Workbench

Version: 9.1
Build id: 9.1-20110701






Eclipse startup command=-os
win32
-ws
win32
-arch
x86
-showsplash
-launcher
C:\MyEclipse\MyEclipse 9\myeclipse.exe
-name
Myeclipse
--launcher.library
C:\MyEclipse\MyEclipse 9\../Common/plugins/org.eclipse.equinox.launcher.i18n.win32.win32.x86_3.2.0.v201103301700\eclipse_3215.dll
-startup
C:\MyEclipse\MyEclipse 9\../Common/plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-install
c:\MyEclipse\MyEclipse 9
-configuration
c:\MyEclipse\MyEclipse 9\configuration
-vm
c:\MyEclipse\Common\binary\com.sun.java.jdk.win32.x86_1.6.0.013\jre\bin\client\jvm.dll




2. Clear your .log file located at [your workspace dir]/.metadata/.log, replicate issue and attach the file here


!SESSION 2011-10-03 21:31:47.418 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_13
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=zh_HK
Command-line arguments: -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.jface 2 0 2011-10-03 21:32:05.373
!MESSAGE Keybinding conflicts occurred. They may interfere with normal accelerator operation.
!SUBENTRY 1 org.eclipse.jface 2 0 2011-10-03 21:32:05.373
!MESSAGE A conflict occurred for SHIFT+DEL:
Binding(SHIFT+DEL,
ParameterizedCommand(Command(org.eclipse.datatools.sqltools.result.removeAllInstances,Remove All Visible Results,
,
Category(org.eclipse.datatools.sqltools.result.category,SQL Results View,null,true),
,
,,true),null),
org.eclipse.ui.defaultAcceleratorConfiguration,
org.eclipse.ui.contexts.window,,,system)
Binding(SHIFT+DEL,
ParameterizedCommand(Command(org.eclipse.ui.edit.cut,Cut,
Cut the selection to the clipboard,
Category(org.eclipse.ui.category.edit,Edit,null,true),
org.eclipse.ui.internal.handlers.WidgetMethodHandler@b81fa0,
,,true),null),
org.eclipse.ui.defaultAcceleratorConfiguration,
org.eclipse.ui.contexts.dialogAndWindow,,,system)
Binding(SHIFT+DEL,
ParameterizedCommand(Command(org.topcased.modeler.deleteModelObject,remove from Model,
Allows the user to delete the selected graph element and its associated model element in a Topcased editor.,
Category(org.eclipse.ui.category.edit,Edit,null,true),
,
,,true),null),
org.eclipse.ui.defaultAcceleratorConfiguration,
org.eclipse.ui.contexts.window,,,system)

!ENTRY com.genuitec.eclipse.core 1 0 2011-10-03 21:32:12.097
!MESSAGE Unable to locate .myeclipse.properties file

!ENTRY org.eclipse.jface 4 2 2011-10-03 21:32:14.702
!MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.jface".
!STACK 0
java.lang.NullPointerException
at com.genuitec.eclipse.sqlexplorer.model.CatalogNode.getSchemas(CatalogNode.java:114)
at com.genuitec.eclipse.sqlexplorer.model.CatalogNode.getChildren(CatalogNode.java:98)
at com.genuitec.eclipse.sqlexplorer.views.DatabaseContentProvider.getChildren(DatabaseContentProvider.java:71)
at org.eclipse.jface.viewers.AbstractTreeViewer.getRawChildren(AbstractTreeViewer.java:1354)
at org.eclipse.jface.viewers.TreeViewer.getRawChildren(TreeViewer.java:391)
at org.eclipse.jface.viewers.StructuredViewer.getFilteredChildren(StructuredViewer.java:896)
at org.eclipse.jface.viewers.AbstractTreeViewer.getSortedChildren(AbstractTreeViewer.java:601)
at org.eclipse.jface.viewers.AbstractTreeViewer$1.run(AbstractTreeViewer.java:801)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
at org.eclipse.jface.viewers.AbstractTreeViewer.createChildren(AbstractTreeViewer.java:778)
at org.eclipse.jface.viewers.TreeViewer.createChildren(TreeViewer.java:644)
at org.eclipse.jface.viewers.AbstractTreeViewer.createChildren(AbstractTreeViewer.java:749)
at org.eclipse.jface.viewers.AbstractTreeViewer.setExpandedState(AbstractTreeViewer.java:2436)
at com.genuitec.eclipse.sqlexplorer.views.DatabaseTreeViewer$5.doubleClick(DatabaseTreeViewer.java:164)
at org.eclipse.jface.viewers.StructuredViewer$1.run(StructuredViewer.java:824)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:49)
at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175)
at org.eclipse.jface.viewers.StructuredViewer.fireDoubleClick(StructuredViewer.java:822)
at org.eclipse.jface.viewers.AbstractTreeViewer.handleDoubleSelect(AbstractTreeViewer.java:1421)
at org.eclipse.jface.viewers.StructuredViewer$4.widgetDefaultSelected(StructuredViewer.java:1225)
at org.eclipse.jface.util.OpenStrategy.fireDefaultSelectionEvent(OpenStrategy.java:238)
at org.eclipse.jface.util.OpenStrategy.access$0(OpenStrategy.java:235)
at org.eclipse.jface.util.OpenStrategy$1.handleEvent(OpenStrategy.java:296)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4066)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3657)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2640)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2604)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2438)
at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:664)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:115)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
at org.eclipse.equinox.launcher.Main.run(Main.java:1407)

!ENTRY org.eclipse.osgi 2 0 2011-10-03 21:32:15.623
!MESSAGE While loading class "org.eclipse.wst.jsdt.internal.core.JavaModelManager$16", thread "Thread[Worker-6,5,main]" timed out waiting (5000ms) for thread "Thread[Worker-5,5,main]" to finish starting bundle "org.eclipse.wst.jsdt.core_1.1.2.me201106211924 [899]". To avoid deadlock, thread "Thread[Worker-6,5,main]" is proceeding but "org.eclipse.wst.jsdt.internal.core.JavaModelManager$16" may not be fully initialized.
!STACK 0
org.osgi.framework.BundleException: State change in progress for bundle "reference:file:/c:/MyEclipse/Common/plugins/org.eclipse.wst.jsdt.core_1.1.2.me201106211924.jar" by thread "Worker-5".
at org.eclipse.osgi.framework.internal.core.AbstractBundle.beginStateChange(AbstractBundle.java:1077)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:282)
at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:417)
at org.eclipse.osgi.internal.loader.BundleLoader.setLazyTrigger(BundleLoader.java:265)
at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:106)
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:453)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:216)
at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:393)
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:469)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:422)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
at org.eclipse.wst.jsdt.internal.core.JavaModelManager$15.run(JavaModelManager.java:4182)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
Caused by: org.eclipse.osgi.framework.internal.core.AbstractBundle$BundleStatusException
... 16 more
Root exception:
org.eclipse.osgi.framework.internal.core.AbstractBundle$BundleStatusException
at org.eclipse.osgi.framework.internal.core.AbstractBundle.beginStateChange(AbstractBundle.java:1077)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:282)
at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:417)
at org.eclipse.osgi.internal.loader.BundleLoader.setLazyTrigger(BundleLoader.java:265)
at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:106)
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:453)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:216)
at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:393)
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:469)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:422)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
at org.eclipse.wst.jsdt.internal.core.JavaModelManager$15.run(JavaModelManager.java:4182)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)


3. List out the steps take by you in detail that resulted in this issue including the type of project you have created


1) Launch MyEclipse, click "OK" to accept workspace location in Workspace Launcher window
2) Open DB Browser and navigate to my MSSQL database in the treeview
3) Double-click the database and the error message appears



4. Have you added any third party plugins to your profile? If yes, please list them here


I did not use any plugin, except MSSQL JDBC driver downloaded from Microsoft website
http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=21599


5. Please try clean, refer - http://www.myeclipseide.com/PNphpBB2-viewtopic-t-10280.html


I have tried but still encountered the same problem


 
 View user's profile Send private message  
Reply with quote Back to top
support-joy
Registered Member
Registered Member


Joined: Feb 03, 2009
Posts: 3441

simon9251,

Thank you for the details. I shall investigate and get back to you on this.

_________________
Joy
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Support-Brian
Moderator
Moderator


Joined: Aug 21, 2004
Posts: 2680

simon,

Could you try a quick test and connect to MSSQL using the jTDS driver instead of the standard MS SQL Driver? Once you connect with this driver, do you still see the same issue?

You can find the jTDS driver here: http://jtds.sourceforge.net/

_________________
Brian
MyEclipse Support
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
All times are GMT - 6 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
® 2014 - Genuitec, LLC.