MyEclipse Forums
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
sweepy
Post subject: Upgrading ME4s Web Project from 9.1 to 10 does not work  PostPosted: Jan 20, 2012 - 08:54 AM
Registered Member
Registered Member


Joined: Oct 22, 2008
Posts: 56

Hi, I have downloaded and installed version 10 from the installer. I open my ME4S9.1 Workspace, it asks me to upgrade, but when i do there are heaps of errors. the classpaths file has changed and is missing jars. I have tried this multiple times. Not sure why this is happening. quite frustrating...any ideas?

_________________
Thanks!
Peter
 
 View user's profile Send private message  
Reply with quote Back to top
sweepy
Post subject:   PostPosted: Jan 21, 2012 - 01:52 AM
Registered Member
Registered Member


Joined: Oct 22, 2008
Posts: 56

More info...

It changed my classpath file from
Code:


<?xml version="1.0" encoding="UTF-8"?>
<classpath>
   <classpathentry excluding="main/resources/|main/java/" kind="src" output="WebRoot/WEB-INF/classes" path="src"/>
   <classpathentry kind="src" path="misc"/>
   <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
   <classpathentry kind="con" path="org.maven.ide.eclipse.MAVEN2_CLASSPATH_CONTAINER"/>
   <classpathentry kind="con" path="org.eclipse.jst.j2ee.internal.web.container"/>
   <classpathentry kind="con" path="org.eclipse.jst.j2ee.internal.module.container"/>
   <classpathentry kind="src" path="src/main/resources"/>
   <classpathentry kind="src" path="src/main/java"/>
   <classpathentry exported="true" kind="lib" path="C:/Users/Peter/Development/Tech/Programming/Java/APIs/supercsv-1.20.jar"/>
   <classpathentry exported="true" kind="lib" path="C:/Users/Peter/Development/Tech/Programming/Java/APIs/quartz-1.8.5/quartz-1.8.5/quartz-all-1.8.5.jar"/>
   <classpathentry exported="true" kind="lib" path="C:/Users/Peter/Development/Tech/Programming/Java/APIs/spring-security-3.1.0.RC3/dist/spring-security-config-3.1.0.RC3.jar"/>
   <classpathentry exported="true" kind="lib" path="C:/Users/Peter/Development/Tech/Programming/Java/APIs/spring-security-3.1.0.RC3/dist/spring-security-core-3.1.0.RC3.jar"/>
   <classpathentry exported="true" kind="lib" path="C:/Users/Peter/Development/Tech/Programming/Java/APIs/spring-security-3.1.0.RC3/dist/spring-security-taglibs-3.1.0.RC3.jar"/>
   <classpathentry exported="true" kind="lib" path="C:/Users/Peter/Development/Tech/Programming/Java/APIs/spring-security-3.1.0.RC3/dist/spring-security-web-3.1.0.RC3.jar"/>
   <classpathentry kind="lib" path="C:/Users/Peter/Development/Tech/Programming/Java/APIs/edtftpj-pro-2.1.2/lib/edtftpj-pro.jar"/>
   <classpathentry kind="lib" path="C:/Users/Peter/Development/Tech/Programming/Java/APIs/joda-time-hibernate-1.2/joda-time-hibernate-1.2.jar"/>
   <classpathentry kind="lib" path="C:/Users/Peter/Development/Tech/Programming/Java/APIs/ibatis-2.3.4.726/lib/ibatis-2.3.4.726.jar"/>
   <classpathentry kind="lib" path="C:/Users/Peter/Development/Tech/Programming/Java/APIs/postgresql-9.1-901.jdbc4.jar"/>
   <classpathentry kind="output" path="WebRoot/WEB-INF/classes"/>
</classpath>


to

Code:


<?xml version="1.0" encoding="UTF-8"?>
<classpath>
   <classpathentry including="**/*.java" kind="src" output="WebRoot/WEB-INF/classes" path="src"/>
   <classpathentry kind="src" path="misc"/>
   <classpathentry kind="src" path="src/main/resources"/>
   <classpathentry kind="src" path="src/main/java"/>
   <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
   <classpathentry kind="con" path="org.eclipse.m2e.MAVEN2_CLASSPATH_CONTAINER">
      <attributes>
         <attribute name="org.eclipse.jst.component.dependency" value="/WEB-INF/lib"/>
      </attributes>
   </classpathentry>
   <classpathentry kind="con" path="org.maven.ide.eclipse.MAVEN2_CLASSPATH_CONTAINER"/>
   <classpathentry kind="output" path="WebRoot/WEB-INF/classes"/>
</classpath>

_________________
Thanks!
Peter
 
 View user's profile Send private message  
Reply with quote Back to top
sweepy
Post subject:   PostPosted: Jun 01, 2012 - 06:47 AM
Registered Member
Registered Member


Joined: Oct 22, 2008
Posts: 56

still have this problem... any suggestions?

_________________
Thanks!
Peter
 
 View user's profile Send private message  
Reply with quote Back to top
cconway
Post subject:   PostPosted: Jun 03, 2012 - 03:35 PM



Joined: Apr 04, 2011
Posts: 196

Typically in a maven project, the POM would be the place to specify dependencies. It looks like there are additional dependencies on the classpath of this project (prior to the upgrade).

It looks like the upgrader for Maven projects is not taking into consideration additional classpath entries added to the project. Have you tried re-adding the missing libraries to the classpath, or maybe specifying them in the POM instead?

_________________
Cindy
MyEclipse for Spring Support
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits