MyEclipse Forums
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
benp
Post subject: "unable to locate companion shared library"(Mac OS  PostPosted: May 15, 2012 - 12:03 AM



Joined: Apr 14, 2008
Posts: 25

Hi All.

Over the weekend, I migrated from my old MacBook Pro to a new MacBook Pro via Migration Assistant.

Now, for some reason, whenever I try to open MyEclipse on the new MacBook Pro, I get the following error: "The Myeclipse executable launcher was unable to locate its companion shared library."

After a few days of searching Google, I have yet to find anyone with a similar problem on Mac OS X (lots of Windows posts).

If there is a thread on my situation already, please point me in that direction, but if not, please help!

I was hoping I wouldn't have to do a clean reinstall, because I hate having to set up MyEclipse with CVS...it can be quite trying on one's nerves.

Thank you for your help!!!
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
support-joy
Post subject:   PostPosted: May 15, 2012 - 08:40 AM
Registered Member
Registered Member


Joined: Feb 03, 2009
Posts: 3442

benp,

Sorry to hear you are running into this issue. Could you verify if you have myeclipse.ini in your MyEclipse installation directory? Please refer - http://myeclipseide.com/PNphpBB2-viewtopic-t-27743.html on the location of files and folders. If you do not have it, I would recommend you copy the same from an earlier install and validate the path, vmargs, etc.

If you have myeclipse.ini file, one way to fix it would be to edit the myeclipse.ini file and add the following lines to the beginning:

--launcher.library
/path/to/myeclipse/plugins/org.eclipse.equinox.launcher.carbon.macosx.......

(With the proper version numbers corresponding to your install).

If this is not the issue, please verify that the path of the installation after migration is the same as before, for both Common and the specific ME folder. Please refer http://myeclipseide.com/PNphpBB2-viewtopic-t-27743.html and validate the <install base> and <myeclipse install folder>

Let me know how this works for you.

_________________
Joy
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
benp
Post subject:   PostPosted: May 15, 2012 - 08:50 PM



Joined: Apr 14, 2008
Posts: 25

Hi Joy.

Thank you for your help!

Unfortunately, I can't find a myeclipse.ini file ):

Also, when I went to the link you gave me, I couldn't find the folders they talked about. Perhaps it's because I'm using MyEclipse 7.5? The reason I haven't upgraded is that every time I've upgrade computers or tried to upgrade MyEclipse, I run into problems like this ): I don't want to have to completely reinstall and reconnect to CVS for all of the five million projects I need to work on. Why can't the upgrade maintain your working environment along with window setup and open files? Perhaps it does now, but it has never worked for me over the past seven years or so.

ANYWAY.

I have tried to uninstall MyEclipse 7.5 in order to install MyEclipse 10.1. However, when I try to uninstall, I get the following message: "An error has occurred. See the log file <file_path>/1337111249312.log"

When I try to install MyEclipse 10.1, I get the following message "Installation Problem An unexpected issue has occurred while attempting to perform the requested operation. You can retry again later or use Get Help below to request help on MyEclipse. Description of problem: An error occurred while preparing to install MyEclipse"

Any ideas what I should try next??
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
support-joy
Post subject:   PostPosted: May 16, 2012 - 07:50 AM
Registered Member
Registered Member


Joined: Feb 03, 2009
Posts: 3442

benp,

Sorry to hear you are running into issues while un-installing ME 7.5 and installing ME 10.1. Could you provide below information -
1. Attach file <file_path>/1337111249312.log
2. How are you trying to install MyEclipse 10.1? Meaning using all-in-one installer / pulse / myeclipse update site on top of eclipse classic?
3. If you have used all-in-one installer, please confirm you have verified the file size and md5sum of the installer matches that mentioned in the site.
4. I would recommend you manually un-install ME 7.5. Please refer this FAQ - http://myeclipseide.com/PNphpBB2-viewtopic-t-10277.html
5. For the installation issues, I would recommend you double click on the installer file. This would list you 4 options. You could choose to repair current MyEclipse profile or install another copy of MyEclipse. Please note that you can install any versions of MyEclipse. You need not remove an earlier version to install the latest version.
6. If this is still an issue, please attach a screenshot to help me get a visual.

Let me know how this works for you.

_________________
Joy
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
benp
Post subject:   PostPosted: May 16, 2012 - 02:59 PM



Joined: Apr 14, 2008
Posts: 25

Here you go:

1. I have pasted the contents of the log below:

!SESSION 2012-05-16 08:48:40.634 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_31
java.vendor=Apple Inc.
BootLoader constants: OS=macosx, ARCH=x86, WS=carbon, NL=en_US
Framework arguments: -uninstallProfile com.poweredbypulse.profile-0-rb-218851
Command-line arguments: -os macosx -ws carbon -arch x86 -uninstallProfile com.poweredbypulse.profile-0-rb-218851

!ENTRY org.eclipse.osgi 4 0 2012-05-16 08:48:41.330
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:74)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:386)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1236)

2. I am trying to install MyEclipse 10.1 using the all-in-one installer. Why are there multiple ways to install it? What's the difference? It would be simpler if there was always just one way...

3. Could you please give me a link on how to verify the md5sum? Not sure how to do this, and I couldn't find it when I searched for a few minutes just now ):

4. I'll do this next chance I get!

5. Double clicking the installer file, then clicking next yields the error I described to you already (see attached screenshot)

6. See attached screenshot of the installer
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
benp
Post subject:   PostPosted: May 16, 2012 - 03:03 PM



Joined: Apr 14, 2008
Posts: 25

Also, Here's a screenshot of the error I get when I try to open MyEclipse 7.5 which used to work just fine before I transferred all my data to my new computer ):
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
benp
Post subject:   PostPosted: May 16, 2012 - 03:08 PM



Joined: Apr 14, 2008
Posts: 25

One More Thing: As I think about it, while uninstalling MyEclipse 7.5 does not sound like a requirement for installing MyEclipse 10.1. So I'd rather not give up yet on getting MyEclipse 7.5 back up and running again since it should have all of my settings intact in the transfer, I would guess?

Getting MyEclipse 7.5 up and running is my top priority. Then I could install 10.1 in parallel while at least still being able to get my work done in the meantime.

All that to say I won't try the manual uninstall for now.

Now that I've answered your questions, any ideas why 7.5 won't open and why 10.1 won't install? Just let me know what else you need from me that would assist in your diagnosis.
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: May 17, 2012 - 01:37 PM



Joined: Mar 09, 2011
Posts: 939

ben,

Sorry you've been having these problems. I think it would have been better to install MyEclipse on your new system, instead of migrating it across. If you still have the installer, that might still be your best option.

Regarding your settings, these are primarily held in your workspace, so you should not need to redefine CVS repositories or check out 5 million projects, as they will all still be there in your workspace. So reinstalling 7.5, or installing 10.1 and opening your old workspace should get you back to where you were.

As Joy mentioned, uninstalling 7.5 can be done manually, as well as through the uninstaller. It seems like your 7.5 install didn't get migrated cleanly and so the uninstaller might have difficulties, as starting up does. One of the reasons for the error you're getting on startup of 7.5 is a missing or corrupt myeclipse.ini file. Another reason might be that the file paths of the common folder (this holds all of the MyEclipse code) and/or the specific MyEclipse 7.5 folder (where the executable is) are different from what they were at installation.

So there are two things to check there.

Firstly, is there a myeclipse.ini file in the same folder as the myeclipse executable? If the locations are not the same as in the FAQ that Joy pointed to, look for the application file (probably called MyEclipse 7.5.app) that is used to launch MyEclipse. You might not see the ".app" suffix in Finder though that doesn't matter (but you can alter that in the Finder preferences). Right click on this file (which is really a folder) and choose Show Package Contents. Now one of the folders in the contents should have either the executable or a file called myeclipse.app. If it's the former, then the myeclipse.ini file should also be there. If it's the latter, you have to drill down further; right click on myeclipse.app and select Show Package Contents again, then open the MacOS folder. The executable and myeclipse.ini file should be in there. If there is an executable but no myeclipse.ini file then you need a new myeclipse.ini file. If you need a new file, try and locate in on your old machine and copy it across, somehow. I'm trying to get hold of an old 7.5 installer to try this myself but didn't want to delay a response, in case this can get you going.

Secondly, did the migration leave the file paths to the installation the same as on your old machine? If not, is it possible to move the application to a location that is the same? If that's not possible, re-installation or installation of 10.1 may be the only option. If you need to get hold of a 7.5 installer, you can email ales@genuitec.com and they will be able to assist you. Be sure to include your name, subscription id, subscription code, MyEclipse version desired, and operating system so they can provide the correct download link without delay.

Now, your 10.1 install. The md5 can be checked by opening a terminal window on the Mac and entering "md5 installerName" where "installerName" is the file path of the MyEclipse installer executable. The result should be the same as given on the download page. If it isn't, then please download again. If it is the same and you still get the error, please attach the installer log file. This file can be found in your temporary folder, with a name beginning "pulse-one". The temporary folder can be found by opening a terminal and entering "echo $TMPDIR".

Another thing to note is the a file .pulse2.locator in your home directory, which normally points to the base installation folder. You should check this as I'm not sure what effect an invalid file path might have. Also, there is a file called .myeclipse.properties, in the home directory, which contains the license key and (for 10.1) the activation code. If these also weren't copied over in the migration, that might have an impact.

Lastly, there are multiple ways of installing in order to be as flexible as possible. Some users prefer to install as a set of plug-ins on a standard eclipse install, some prefer more management of profiles if they have multiple releases installed and others just want a plain install program (for either a completely downloaded application or one that requires download during installation) This has actually proved useful in a few situations where one technique was not possible but a second install method has worked. This might be helpful in your case, also.

Please let us know if any of this helps. If not, I'll try to install 7.5 on a Mac which might allow us to help you further. If so, please let us know the level of OS X that you're now using (e.g. 10.7.2).

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: May 18, 2012 - 04:45 AM



Joined: Mar 09, 2011
Posts: 939

Ben,

Here is some additional information as I have tried to install 7.5 on a Snow Leopard (OS X 10.6.8) system. I couldn't install from an all-in-one installer, at first; it got stuck at some point in the installation. I also tried this on a Lion system and had the same problem. However, after removing all previous MyEclipse installations, it installed fine. Also, I installed easily using Pulse. To install using Pulse, you will need to download Pulse and install it first. Then start Pulse and log in or select anonymous use (then click Next). To install 7.5, select the Ganymede domain (for 10.1, select the Indigo domain), in the top left pull down. Then select MyEclipse and click the green arrow to install.

After installing this way, I notice that the path to the myeclipse.ini file was not as complex as with later releases, the first .app is not an app at all but just a folder, so is easier to navigate into.

If you just need a myeclipse.ini, I am attaching the default file that got installed with 7.5 (note that file paths may need to be changed accordingly, depending on where you have 7.5 installed). you will only see the attached file if you are logged in to our site. Please save it as "myeclipse.ini" (not "myeclipse.ini.txt"), to the appropriate location.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
benp
Post subject:   PostPosted: May 18, 2012 - 08:30 PM



Joined: Apr 14, 2008
Posts: 25

Hey Tony.

I HAVE tried to install MyEclipse (10.1) on my new system (as well as trying to migrate it across). However, when I try to install it via the all-in-one installer, it gives the following error (as I have already indicated in my second post on this thread): "Installation Problem An unexpected issue has occurred while attempting to perform the requested operation. You can retry again later or use Get Help below to request help on MyEclipse. Description of problem: An error occurred while preparing to install MyEclipse"

As I said in my second post, there is no MyEclipse.ini file on my machine in the location that I have been told where it should be. I see that you have attached a MyEclipse.ini file. I'll try that one the next chance I get (busy weekend), could you please verify where it should be? Under /Library/Genuitec/.… or under /Applications/MyEclipse 7.5.app? I'm a bit confused about that issue.

Under the MyEclipse 7.5 application in my Applications folder (when I "show package contents"), all I have is "Info.plist", a "MacOS" directory with one file in it called "redirect-to-install", and a "Resources" directory with one file in it called "myeclipse.icns". I don't see myeclipse.ini NOR do I see a myeclipse.app file anywhere in the "package contents." Not sure if that helps you.

Under /Library/Genuitec/Pulse Explorer/Eclipse.app, when I "show package contents," there is nothing under that file. Not sure if that is an old file or not.

Again, I have already tried to install MyEclipse 10.1 and it errors out. That's at least 50% of my issue here.

Thanks for the instructions on the md5sum…here's what I got:
md5 /Volumes/MyEclipse/MyEclipse\ 10.1\ Installer.app/Contents/MacOS/standard-install
MD5 (/Volumes/MyEclipse/MyEclipse 10.1 Installer.app/Contents/MacOS/standard-install) = a5407087bb08bc67f738b499fec21241

It doesn't seem to match what's on the website, but did I check the right file? If not, please make sure to tell me which file inside the installer is the "executable" file that I should be checking the md5 on.

I can't redownload right now, but I will try next chance I get. In the meantime, please confirm which file is the "executable."

My .pulse2.locator file is set to: /Library/Genuitec. Under that directory, there are two directories, "Common" and "Pulse Explorer." This appears to be correct, but I wouldn't know!

The .myeclipse.properties file is there and appears to have the correct information in it.

I'm currently using Mac OS X 10.7.4 on a MacBook Pro.

Thanks for the responses!
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: May 18, 2012 - 11:40 PM



Joined: Mar 09, 2011
Posts: 939

Ben,

I'm not near my Mac right now but just wanted to confirm the location of the myeclipse.ini file. It should be in the same folder as the "myeclipse" executable. If you investigate the directories and subdirectories in the 7.5 installation, you should come across a file of that name. The ini file should be there. As I indicated in my last post, it looks like the installation of 7.5 is a little less complicated than for later installs, so just investigate all subdirectories of the installation directory. You may not be looking in the correct place, if you've come across a redirect-to-install file. To me, the Mac seems far too secretive about its applications, so I know it can be difficult to find the right location, but when you run MyEclipse 7.5, it must ultimately be running the myeclipse executable file. This is the one you have to find.

It looks like your old computer had installed MyEclipse at a different location to what you have now, so you might find that the problem is that, rather than a missing myeclipse.ini file. It would probably be better to reinstall 7.5, if you can. It will not harm your workspace settings.

I'll take a longer look at your reply when I get the chance, and respond, but I just wanted to ensure you had some more help, as soon as possible. One last thing - the md5 should be run against the file you downloaded, which, in your case, is "myeclipse-10.1-offline-installer-macosx.dmg". That is probably in your Downloads folder.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
benp
Post subject:   PostPosted: May 19, 2012 - 04:18 AM



Joined: Apr 14, 2008
Posts: 25

Thanks Tony, That's helpful.

I actually finally figured out to run the md5 on the .dmg file! It matches:
md5 /Users/padulab/Downloads/myeclipse-10.1-offline-installer-macosx.dmg
MD5 (/Users/padulab/Downloads/myeclipse-10.1-offline-installer-macosx.dmg) = 36a0dd12bf543f12b0288e63b8c5e5e1

So I'm good on that front...still getting the error when I try to install.

I'll try reinstalling 7.5 next chance I get!
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
benp
Post subject:   PostPosted: May 19, 2012 - 04:22 AM



Joined: Apr 14, 2008
Posts: 25

):

Just tried installing Pulse, and got the following error (see screenshot below).

Any ideas?

Maybe I need to uninstall all of the Eclipse installations or any previous Pulse installations?
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: May 19, 2012 - 09:44 AM



Joined: Mar 09, 2011
Posts: 939

Ben,

Try deleting the .pulse2.locator file and installing pulse again.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
benp
Post subject:   PostPosted: May 19, 2012 - 01:06 PM



Joined: Apr 14, 2008
Posts: 25

I'm still getting the same error. There's also a ".pulse" directory and a ".pulse2" directory in my home folder. Should I delete those as well?
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits